THE NATIONAL ANTHEM

Jana-gana-mana adhinayaka, jaya he
Bharatha-bhagya-vidhata.
Punjab-Sindh-Gujarat-Maratha
Dravida-Utkala-Banga
Vindhya-Himachala-Yamuna-Ganga
Uchchala-Jaladhi-taranga
Tava subha name jage,
Tava subha asisa mage,
Gahe tava jaya gatha.
Jana-gana-mangala-dayaka jaya he
Bharatha-bhagya-vidhata.
Jaya he, jaya he, jaya he,
Jaya jaya jaya, jaya he!

PLEDGE

India is my country. All Indians are my brothers and sisters.
I love my country, and I am proud of its rich and varied heritage. I shall always strive to be worthy of it.
I shall give my parents, teachers and all elders respect, and treat everyone with courtesy.
To my country and my people, I pledge my devotion. In their well-being and prosperity alone lies my happiness.

Prepared by:

State Council of Educational Research and Training (SCERT)
Poojappura, Thiruvananthapuram 695012, Kerala
Website: www.scertkerala.gov.in e-mail: scertkerala@gmail.com
Phone: 0471 - 2341883, Fax: 0471 - 2341869
Typesetting and Layout: SCERT
© Department of Education, Government of Kerala

To be printed in quality paper - 80gsm map litho (snow-white)
Dear learners,

The syllabus of Computer Application for the Humanities stream has been revised in view of the growing importance of computer aided technology for various applications, especially in the field of publishing, information sharing, data analysis, etc. While designing the syllabus and the textbook, the other subjects of the Humanities group were also taken into consideration. Such a study will render the learning of those subjects more interesting and effective. It will also enlighten the learner about emerging trends in the field of computer applications and Information Technology.

The text book, designed in accordance with the syllabus for the academic year 2014 - 15, begins with the concept of data processing and presents a variety of computer hardware and software for various applications of the times. In addition to familiarising students with various hardware components used in IT application development, the concerns and remedies for e-waste management are also highlighted. A wide coverage is given for computer network and Internet technology, underlining the virtues and vices in their use. The syllabus and the text book provide adequate space to various software packages, for analysis of data, its presentation and manipulating images, that are highly in demand nowadays. This exclusive section incorporates the use of advanced tools of these packages giving focus on lab activities.

I hope this book will meet all the requirements for stepping to levels of higher education and pave the way to the peak of success.

Dr P. A. Fathima  
Director  
SCERT, Kerala
<table>
<thead>
<tr>
<th>Names</th>
<th>Roles and Institutions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prasanth P. M.</td>
<td>HSST, St. Joseph’s Boys’ HSS, Kozhikode.</td>
</tr>
<tr>
<td>Vinod V.</td>
<td>HSST, NSS HSS, Prakkulam, Kollam.</td>
</tr>
<tr>
<td>Joy John</td>
<td>HSST, St. Joseph’s HSS, Thiruvananthapuram.</td>
</tr>
<tr>
<td>Aboobacker P.</td>
<td>HSST, Govt. GHSS, Chalappuram, Kozhikode.</td>
</tr>
<tr>
<td>Shajan Jos N.</td>
<td>HSST, St. Joseph’s HSS, Pavaratty, Thrissur.</td>
</tr>
<tr>
<td>Mustafa Shamsul Haq K. K.</td>
<td>HSST, GHSS Kuthuparamba, Kannur.</td>
</tr>
<tr>
<td>Najeeb P. P.</td>
<td>HSST, Himayathul Islam HSS, Kozhikode.</td>
</tr>
<tr>
<td>Sunil Kariyatan</td>
<td>HSST, Govt. Brennen HSS, Thalassery, Kannur.</td>
</tr>
<tr>
<td>Sai Prakash S.</td>
<td>HSST, St. Thomas HSS, Poonthura, Thiruvananthapuram.</td>
</tr>
<tr>
<td>T. Mohammed Salim</td>
<td>HSST, Oriental HSS, Thirurangadi, Malappuram.</td>
</tr>
<tr>
<td>A. N. Sathian</td>
<td>HSST, GMHSS, Koyilandy, Kozhikode.</td>
</tr>
<tr>
<td>Hassinnar Mankada</td>
<td>Master Trainer, IT@School, Malappuram.</td>
</tr>
</tbody>
</table>

**Experts**

- **Dr. Lajish V. L.**
  Assistant Professor, Dept. of Computer Science, University of Calicut
- **Dr. Madhu S. Nair**
  Assistant Professor, Dept. of Computer Science, University of Kerala
- **Madhu V. T.**
  Director, Computer Centre, University of Calicut
- **Dr. Binu P. Chacko**
  Associate Professor, Dept. of Computer Science, Prayoti Niketan College, Pudukad
- **Dr. Sushil Kumar R.**
  Associate Professor, Dept. of English, D. B. College, Sasthamcotta
- **Dr. Vineeth K. Paleri**
  Professor, Dept. of Computer Science and Engineering, NIT, Kozhikode
- **Maheswaran Nair V.**
  Sub Divisional Engineer, Regional Telecom Training Centre, Kaimanom, Tvm.

**Artists**

- **Sudheer Y.**
- **Vineeth V.**

**Academic Co-ordinator**

- **Dr. Meena S.**
  Research Officer, SCERT
<table>
<thead>
<tr>
<th></th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Fundamentals of Computer</td>
<td>07</td>
</tr>
<tr>
<td>2.</td>
<td>Components of Computer System</td>
<td>25</td>
</tr>
<tr>
<td>3.</td>
<td>Data Processing with Electronic Spreadsheet</td>
<td>67</td>
</tr>
<tr>
<td>4.</td>
<td>Data Analysis using Spreadsheet</td>
<td>95</td>
</tr>
<tr>
<td>5.</td>
<td>Presentation Software</td>
<td>127</td>
</tr>
<tr>
<td>6.</td>
<td>Getting Started with GIMP</td>
<td>155</td>
</tr>
<tr>
<td>7.</td>
<td>Advanced Tools for Image Editing</td>
<td>189</td>
</tr>
<tr>
<td>8.</td>
<td>Computer Networks</td>
<td>219</td>
</tr>
<tr>
<td>9.</td>
<td>Internet</td>
<td>249</td>
</tr>
<tr>
<td>10.</td>
<td>IT Applications</td>
<td>277</td>
</tr>
</tbody>
</table>
Icons used in this textbook

- Let us do
- Check yourself
- Information box
- Lab activities
- Learning outcomes
Computers have now become an integral part of our daily life. People use computers for a variety of reasons and purposes. Be it education, business, entertainment, communication, government service or transportation, computers are inevitable today. As far as students are concerned, computers are used for learning different subjects effectively and for carrying out learning activities apart from their primary function of computing. Try to recollect the situations where we used computers and identify the benefits from it. Therefore it is essential to know more about computers and its applications. This chapter presents the concepts of data processing and functional units of computer. Different data representation methods used in computers are also discussed in this chapter.

1.1 Data and Information

Many of us are familiar with the terms - data and information. We often use these terms interchangeably in our daily life. But there exists fundamental differences between these two. As part of our attempt to explore the field of computers, it is very essential to distinguish between these two terms.

Figure 1.1 shows a portion of the class diary of a
teacher. Can you make out the words and numbers? Since it is a teacher’s diary, these can be the names of some students. What do the numbers mean? One cannot be sure. It can be the marks scored by students in tests, their attendance for some months, or something similar. We call these facts and figures data, because they do not give a complete idea. Data denotes raw facts and figures such as numbers, words, amount, quantity etc. that can be processed or manipulated.

If these facts and figures were written as shown in Figure 1.2, there would be no confusion as to what they mean. It is clear that the figures show the scores obtained by students in Continuous Evaluation (CE) activities. We can see that when the data is arranged in a meaningful way, we get a clear-cut idea about these facts and figures. This is known as information. It is a meaningful and processed form of data.

Information may also act as data in other contexts. In our example of preparation of CE scores of students, the teacher converts these numbers into a consolidated score out of 10. Similarly, after the evaluation of answer scripts of the public examination, each of these students will be awarded a score out of 40. During the preparation of results of examination, the scores of all the subjects are collected and corresponding grades are granted. The personal details and grades are put in an appropriate format with suitable labels and it becomes the mark sheet of the student, which is again information.

Figure 1.3 shows the score sheet of a student issued after the public examination. It contains personal details of the student and the grades obtained in each subject. The personal details like Anitha Mohan, Female, 13/04/1997, etc. are printed against proper labels such as Name, Sex, Date of Birth, etc. Here the facts and figures that represent the personal details and grades are the data. When these data are specified with suitable labels, it becomes information about that student. Thus we can say that the score sheet contains the information about the performance of a student in an examination. This information adds to our knowledge about the level of achievement of the students in various subjects. It also helps them to take decisions about their higher studies or to plan their future.
Information is always generated by performing some operations on data. In other words, data is like raw material to generate information. Now let us try to distinguish between these two terms. Table 1.1 summarises the comparison between data and information.

<table>
<thead>
<tr>
<th>Data</th>
<th>Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Raw facts and figures</td>
<td>Processed data</td>
</tr>
<tr>
<td>Similar to raw material</td>
<td>Similar to the finished product</td>
</tr>
<tr>
<td>Cannot be directly used</td>
<td>Adds to knowledge and helps in</td>
</tr>
<tr>
<td></td>
<td>taking decisions</td>
</tr>
<tr>
<td>Does not give precise and</td>
<td>Clear and meaningful</td>
</tr>
<tr>
<td>clear sense</td>
<td></td>
</tr>
</tbody>
</table>

As we know, information always adds to knowledge. One can apply this knowledge to solve problems or in decision making. Generally, the ability to draw useful inferences from the acquired knowledge is known as intelligence. It depends on how we process knowledge and apply in various situations. Recent advancement in computer science and technology have attempted to make computers do things, which at the moment people do better, incorporating knowledge and intelligence. This is referred to artificial intelligence.
1.2 Data processing

In the case of preparation of the score sheet mentioned in the previous section, the scores given to each subject as part of Continuous Evaluation (CE) and Terminal Evaluation (TE) are added together, and grades are determined based on some predefined criteria. The activities or operations to generate information can collectively be termed as process. **Data processing** refers to the operations or activities performed on data to generate information. So we can say that information is the result of data processing.

As shown in Figure 1.4, data is supplied for processing and information is obtained after processing. In other words, data is the input to the process and information is the output from the process.

Let us consider the case of the Single Window System (*Ekajaalakam*) - the admission procedure for higher secondary courses in Kerala. We can briefly list out its activities as follows:

1. The authority collects the data from applicants through application forms, in which score sheet of Class X examination will be referenced to furnish the required details. Note that in this context the facts and figures in the score sheet become the data.
2. The collected data is then fed to the computer.
3. The input data is stored and will later be retrieved for processing.
4. The data within the computer is used for performing operations such as calculations, comparisons, categorisation, sorting, filtering etc.
5. The allotment slips for candidates and allotment lists for schools are generated. The slips and lists are printed and may be stored for later reference. It may be used as data to generate information in some other situation.
6. The slips are distributed to the applicants and lists are forwarded to schools.

---

**Let us do**

- Examine a telephone bill, electricity bill or water bill and identify the data contained in it.
- Think of the purchase of some items from a shop. Identify the data involved and see how it is converted into information.
- Identify data and information in any real life situation. Make sure that you can clearly distinguish them.

---

*Fig. 1.4 : Data Processing*
Thus it is clear that data processing proceeds through six stages, as listed below:

(a) Capturing data
(b) Input of data
(c) Storage of data
(d) Processing / manipulating data
(e) Output of information
(f) Distribution of information

The thick arrow marks in Figure 1.5 indicate the flow of the activities in data processing and the dotted lines specify the flow of activities that are optional. Let us take a close look at these stages.

**Figure 1.5 : Stages of data processing**

(a) Capturing data

When we apply for admission to the higher secondary course, we usually provide the details through a prescribed application form. The authority is actually collecting the required data for the admission process through the proforma. This is the first stage in data processing. The proforma, also known as the source document, is so designed that all relevant data are to be recorded in proper order and format. Thus, preparation of source document and data collection are the activities that take place in this stage. Today, hard copy of the prescribed application forms are not used for collecting data. Instead, data are directly entered through on-line facility.

(b) Input

In the case of seeking admission, we submit the filled up application form to the school. There the data is extracted and fed into the computer. Sometimes, we may enter these details directly into the computer. Feeding data to the computer for processing is known as input. The input data is usually stored in computers before it is processed.
(c) Storage

In many cases, the amount of data given to the computers will be large. Besides, the data entry may not be completed in a single session or a day. In the case of admissions, the data of lakhs of applicants is input to the computer. It usually takes a few weeks to complete the data entry. So the data input at different times should be stored then and there. The processing will start only after the entire data is stored. The information obtained as a result of processing is also stored in the computer. This stored data and information can be used in the future for various purposes.

(d) Process

The data stored in computers is retrieved for processing. Various operations like calculation, classification, comparison, sorting, filtering, summarising etc. are carried out as part of processing. In the case of admission to the higher secondary course, Weighted Grade Point Average (WGPA) of each applicant is calculated. Then the applicants are listed under various categories based on the descending order of WGPA. Here, school of choice, course, and performance in various co-curricular activities are considered. Finally, allotment lists for schools and allotment slips for applicants are prepared.

(e) Output

The information obtained after processing will be available in this stage. Output stage should provide the information in such a form that the beneficiary should be able to take decision or solve the problem. In the case of admission to the higher secondary course, allotment slip for the applicant and allotment list for the school are generated in the desired format as outputs.

(f) Distribution of information

The information obtained in the output stage is distributed to the beneficiaries. They take decisions or solve problems according to the information. For example, in higher secondary admission, the allotment slips are distributed to applicants for joining the school allotted and allotment
lists are issued to the schools for admitting the eligible applicants. The allotment slips may be used to prepare admission register or roll list of classes. The allotment lists may be used to prepare nominal roll for registering the students for public examination.

Let us do

- Identify and write the data processing activities in (i) opening an account in a bank and (ii) applying for scholarships
- Identify data processing cases in other real life situations and write the activities performed in each stage.

Check yourself

1. Raw facts and figures are known as ________.
2. Processed data is known as ________.
3. Which of the following helps us to take decisions?
   (a) data  (b) information  (c) knowledge  (d) intelligence
4. Manipulation of data to get information is known as ________.
5. Arrange the following in proper order:
   Process, Output, Storage, Distribution, Data Capture, Input
6. Pick the odd one out and give reason:
   (a) Calculation  (b) Storage  (c) Comparison  (d) Categorization
7. Why do we store information?
8. Information may act as data. State True or False.

1.3 Functional units of a computer

Even though computers differ in size, shape, performance and cost over the years, the basic organisation of a computer is the same. It is based on a model proposed by John Von Neumann, a mathematician and a computer scientist. It consists of some functional units namely Input Unit, Central Processing Unit (CPU), Storage Unit and Output Unit. Each of these units is assigned to perform a particular task. Let us discuss the functions of these units.
1. Input unit

The collected data and the instructions for their processing are entered into the computer through the input unit. They are stored in the memory (storage unit). The data may be in different forms like number, text, image, audio, video, etc. A variety of devices are available to input the data depending on its nature. Keyboard, mouse, scanner, mic, digital camera, etc. are some commonly used input devices. In short, the functions performed by input unit are as follows:

1. Accepts instructions and data from the outside world.
2. Converts these instructions and data to a form acceptable to the computer.
3. Supplies the converted instructions and data to the computer for processing.

2. Central Processing Unit (CPU)

The CPU is the brain of the computer. In a human body, all major decisions are taken by the brain and other parts of the body function as directed by the brain. Similarly, in a computer system, all major computations and comparisons are made inside the CPU. It is also responsible for activating and controlling the operations of other units of the computer. The functions of CPU are performed by three components - Arithmetic Logic Unit (ALU), Control Unit (CU) and registers.

a. Arithmetic Logic Unit (ALU)

The actual operations specified in the instructions are carried out in the Arithmetic Logic Unit (ALU). It performs calculations and logical operations such as comparisons and decision making. The data and instructions stored in the storage unit are transferred to the ALU and the processing takes place in it. Intermediate results produced by the ALU are temporarily transferred back to the storage and are retrieved later when needed for further processing. Thus there is a data flow between the storage and the ALU many times before the entire processing is completed.
b. Control Unit (CU)

Each of the functional units has its own function, but none of these will perform the function until it is asked to. This task is assigned to the control unit. It invokes the other units to take charge of the operation they are associated with. It is the central nervous system that manages and co-ordinates all other units of the computer. It obtains instructions from the program stored in the memory, interprets the operation, and issues signals to the unit concerned in the system to execute them.

c. Registers

These are temporary storage elements that facilitate the functions of CPU. There are a variety of registers; each is designated to store unique items like data, instruction, memory address, results, etc.

3. Storage unit

The data and instructions entered in the computer through input unit are stored inside the computer before actual processing starts. Similarly, the information or results produced after processing are also stored inside the computer, before transferring to the output unit. Moreover, the intermediate results, if any, must also be stored for further processing. The storage unit of a computer serves all these purposes. In short, the specific functions of storage unit are to hold or store:

1. data and instructions required for processing.
2. intermediate results for ongoing processing.
3. final results of processing, before releasing to the output unit.

The storage unit comprises of two types as detailed below:

**Primary Storage:** It is also known as main memory. It is again divided into two - Random Access Memory (RAM) and Read Only Memory (ROM). RAM holds instructions, data and intermediate results of processing. It also holds the recently produced results of the job done by the computer. ROM contains instructions for the start up procedure of the computer. The Central Processing Unit can directly access the main memory at a very high speed. But it is costly and has limited storage capacity.

**Secondary Storage:** It is also known as auxiliary storage and it takes care of the limitations of primary storage. It has a huge storage capacity and the storage is permanent. Usually we store data, programs and information in the secondary storage, but we have to give instruction explicitly for this. Hard disk, CDs, DVDs, memory sticks, etc. are some examples.

4. Output unit

The information obtained after data processing is supplied to the outside world through the output unit in a human-readable form. Monitor and printer are the commonly used output devices. The functions performed by output unit can be concluded as follows:

1. Receives the results produced by the CPU in coded form.
2. Converts these coded results to human-readable form.
3. Supplies the results to the outside world.

1.4 **Computer - as data processor**

We have seen the activities involved in data processing and identified the different stages in data processing. Imagine the situation where humans are involved in these stages for performing the operations. It is sure that we will not get the information always in time and without any error all the time. We always need accurate, comprehensive, reliable and timely information in proper format and media so that it can be applied to the context concerned to formulate knowledge. Only then problems can be solved and/or decisions be made using intelligence. From the discussions we had so far, computers can be considered as the best data processing machine. In short, **computer** may be defined as an electronic machine designed to accept the data and instructions, performs arithmetic and logical operations on the data according to a set of instructions and output the results or information.

---

**Fill up the following table by comparing human beings and the computer in the context of data processing. In the case of operations, the organs or components may be specified and for characteristics, performance may be indicated. You can also add more features.**

<table>
<thead>
<tr>
<th>Features</th>
<th>Human being</th>
<th>Computer</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Operation</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Input</td>
<td>Eyes, Ears</td>
<td>Keyboard, Mouse</td>
</tr>
<tr>
<td>Calculation &amp; Comparison</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Temporary Storage</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Permanent Storage</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Controlling</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Characteristics</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Speed</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Accuracy</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reliability</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---
1.4.1 Characteristics of computers

You might have already recognized some of the characteristics of computers by performing the learning activity of filling the comparison table given in the “Let us do” box. As we know, computers can execute millions of instructions in a second. The results produced after processing the data are very accurate, but computers do not have adequate knowledge or intelligence to interpret the results. They only carry out instructions like an obedient servant. The computer gives correct results only if the data and instructions given are correct. The term Garbage In Garbage Out (GIGO) is used to mean this feature. That is, if a wrong input is given to the computer, it will give a wrong output. Look at Table 1.2 and identify the advantages and limitations of computer.

<table>
<thead>
<tr>
<th>Computers</th>
<th>Advantages</th>
<th>Limitations</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Speed:</strong> A computer can perform millions of operations in a second or in fraction of second. It can do in a minute, as much work as a man do taking months and years.</td>
<td><strong>Lack of IQ:</strong> Many people think that computer has super human capabilities. However this is not true. A computer does not have natural intelligence as humans have.</td>
<td></td>
</tr>
<tr>
<td><strong>Accuracy:</strong> A computer can perform arithmetic operations with a very high degree of accuracy. By accuracy, we mean fewer errors in the output and precision with which computations are performed.</td>
<td><strong>Lack of decision making power:</strong> Computer cannot decide on its own and it does not possess intuitive capabilities like human beings.</td>
<td></td>
</tr>
<tr>
<td><strong>Diligence:</strong> Since computer is a machine, it can operate for long hours untiringly. Unlike human beings, it will not show any emotion or disobey you. Hence computers are best suited for routine jobs.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Versatility:</strong> Computer can be used to perform many different kinds of processing tasks. It is a general purpose data processing machine.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Huge memory:</strong> Computer has enormous memory capacity. Huge volume of data can be stored in its memory for processing. The storage capacity can also be increased as per requirement.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Table 1.2: Advantages and limitations of computers*
1.5 Number system

A number is a mathematical object used to count, label and measure. A number system is a systematic way to represent numbers. The number system we use in our day to day life is the decimal number system that uses 10 different symbols or digits. The number 289 is pronounced as two hundred and eighty nine and it consists of the symbols 2, 8 and 9. Similarly there are other number systems. Each has its own symbol and method for constructing a number. A number system has a unique base, which depends upon the number of symbols. The number of symbols used in a number system is called base or radix of a number system.

1.5.1 Decimal number system

The decimal number system consists of ten symbols 0, 1, 2, 3, 4, 5, 6, 7, 8 and 9 to form a number. Since there are ten symbols in this number system, its base is 10. So this number system is also known as base-10 number system.

Consider two decimal numbers 743 and 347

743 \rightarrow \text{seven hundred + four tens + three ones. (} 7 \times 10^2 + 4 \times 10^1 + 3 \times 10^0) \\
347 \rightarrow \text{three hundreds + four tens + seven ones. (} 3 \times 10^2 + 4 \times 10^1 + 7 \times 10^0) \\

Here place value (weight) of 7 in first number 743 is $10^2 = 100$. But weight of 7 in second number 347 is $10^0 = 1$. The weight of a digit depends on its relative position. Such a number system is known as positional number system. All positional number systems have a base and the place value of a digit is some power of this base.

Check yourself

1. Who proposed the model of modern computers?
2. Name the components of CPU.
3. Which of the functional units of the computer is not directly involved in data processing?
4. What is meant by 'execution of an instruction'?
5. Which part of a computer can be compared to the human brain?
Place value of each decimal digit is power of 10 (i.e. $10^0$, $10^1$, $10^2$, ... for integer part and $10^{-1}$, $10^{-2}$, ... for fractional part). Consider a decimal number 5876. This number can be written in expanded form as

<table>
<thead>
<tr>
<th>Place Value</th>
<th>$10^3$</th>
<th>$10^2$</th>
<th>$10^1$</th>
<th>$10^0$</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decimal Number</td>
<td>5</td>
<td>8</td>
<td>7</td>
<td>6</td>
</tr>
</tbody>
</table>

= $5 \times 10^3 + 8 \times 10^2 + 7 \times 10^1 + 6 \times 10^0$

= $5 \times 1000 + 8 \times 100 + 7 \times 10 + 6 \times 1$

= $5000 + 800 + 70 + 6$

= 5876

In the above example, the digit 5 has the maximum place value, $10^3 = 1000$ and 6 has the minimum place value, $10^0 = 1$. The digit with most weight (maximum place value) is called Most Significant Digit (MSD) and the digit with least weight (minimum place value) is called Least Significant Digit (LSD). So in the above number MSD is 5 and LSD is 6.

**Left most digit of a number is MSD and right most digit of a number is LSD.**

When we consider fractional numbers, place values of the digits to the right of decimal point are negative powers of 10 ($10^{-1}$, $10^{-2}$, $10^{-3}$, ...). Consider another example 249.367.

<table>
<thead>
<tr>
<th>Place Value</th>
<th>$10^2$</th>
<th>$10^1$</th>
<th>$10^0$</th>
<th>$10^{-1}$</th>
<th>$10^{-2}$</th>
<th>$10^{-3}$</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decimal Number</td>
<td>2</td>
<td>4</td>
<td>9</td>
<td>3</td>
<td>6</td>
<td>7</td>
</tr>
</tbody>
</table>

MSD (.) LSD

= $2 \times 10^2 + 4 \times 10^1 + 9 \times 10^0 + 3 \times 10^{-1} + 6 \times 10^{-2} + 7 \times 10^{-3}$

= $2 \times 100 + 4 \times 10 + 9 \times 1 + 3 \times 0.1 + 6 \times 0.01 + 7 \times 0.001$

= $200 + 40 + 9 + 0.3 + 0.06 + 0.007$

= 249.367

So far we have discussed a number system which uses 10 symbols. Now let us see the construction of other number systems with different bases.

### 1.5.2 Other number systems

The common number systems associated with computers are binary number system, octal number system and hexa decimal number system. The base must be specified in all number systems other than decimal number system.
The general format is: \((\text{Number})_{\text{base}}\)

This notation helps to differentiate numbers of different bases. If no base is given in a number, it will be considered as decimal. In other words, specifying the base is not compulsory in the decimal number system.

**Binary number system** uses only two symbols 0 and 1 to form a number. Bi means two. Base of this number system is two and the place values are powers of 2 \((2^0, 2^1, 2^2, \ldots \text{ for integer part} \ 2^{-1}, 2^{-2}, \ldots \text{ for fractional part})\). So it is also called base-2 number system. We use the subscript 2 to indicate that the number is in binary. The numbers \((1101)_2\), \((101010)_2\) and \((1101.11)_2\) are examples. The binary number \((1101)_2\) is read as "one one zero one to the base two". Each digit of a binary number is called bit. A **bit** stands for binary digit. The binary number system is also a positional number system where place value of each binary digit is power of 2.

**Octal number system** uses only eight symbols 0, 1, 2, 3, 4, 5, 6, 7 to form a number. Octal means eight and hence it is also called base-8 number system. Base of this number system is 8 and so the place value of each digit is power of 8 \((8^0, 8^1, 8^2, 8^3, \ldots \text{ for integer part} \ 8^{-1}, 8^{-2}, \ldots \text{ for fractional part})\). The numbers \((236)_8\), \((175)_8\) are examples.

**Hexadecimal number system** uses 16 symbols 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A, B, C, D, E and F to form a number. Hexa means six and Deci means ten. That is why this number system is called hexadecimal. Base of this number system is 16 and the place values are powers of 16 \((16^0, 16^1, 16^2, \ldots \text{ for integer part} \ 16^{-1}, 16^{-2}, \ldots \text{ for fractional part})\). This number system is also called base-16 number system. In this system, in addition to decimal digits (0 - 9), the symbols A, B, C, D, E, F are used to represent the numbers 10, 11, 12, 13, 14, 15 respectively.

### 1.5.3 Number conversions

A number in a particular system has an equivalent number in all the other systems. For example, the decimal number 12 is equivalent to \((1100)_2\), \((14)_8\) and \((C)_{16}\). Similarly the binary number \((110101)_2\) possesses the same value represented by the numbers \((65)_8\), \((53)_{10}\) and \((35)_{16}\). Conversion procedures are available to convert the numbers of one base to the equivalent numbers in other bases. There are different types of number conversions like decimal to binary, binary to decimal, decimal to octal, etc.

### 1.6 Data representation

Computers process different types of data such as numbers, characters, images, audios and videos. We know that computer is an electronic device functioning on the basis of
two states - ON and OFF. All electronic circuits have two states - open and closed. The two-state operation is called binary operation. Hence the data given to computer should also be in binary form. In this section we will discuss various methods for representing different types of data in a digital computer. Computer uses a fixed number of bits to represent a piece of data which could be a number, a character, image, audio, video etc. Data representation is the method used internally to represent data in a computer.

### 1.6.1 Representation of numbers

Numbers can be classified into integer numbers and floating point numbers. Integers are whole numbers or fixed point numbers without any fractional part. A floating point number or a real number is a number with fractional part. These two numbers are treated differently in computer memory.

There are three methods for representing an integer number in computer memory. They are (i) Sign and magnitude representation, (ii) 1’s complement representation and (iii) 2’s complement representation.

### 1.6.2 Representation of characters

As in the case of numbers, there are different schemes or codes to represent characters. Some of them are discussed in this section.

#### a. ASCII

The code called ASCII (pronounced “AS-key”), which stands for American Standard Code for Information Interchange, uses 7 bits to represent each character in computer memory. The ASCII representation has been adopted as a standard by the U.S. government and is widely accepted. A unique integer number is assigned to each character. This number called ASCII code of that character is converted into binary for storing in memory. For example, ASCII code of A is 65, its binary equivalent in 7-bit is 1000001. Since there are exactly 128 unique combinations of 7 bits, this 7-bit code can represent only 128 characters.

Another version is ASCII-8, also called extended ASCII, which uses 8 bits for each character, can represent 256 different characters. For example, the letter A is represented by 01000001, B by 01000010 and so on. ASCII code is enough to represent all of the standard keyboard characters.
b. EBCDIC
It stands for Extended Binary Coded Decimal Interchange Code. This is similar to ASCII and is an 8 bit code used in computers manufactured by International Business Machine (IBM). It is capable of encoding 256 characters. If ASCII coded data is to be used in a computer which uses EBCDIC representation, it is necessary to transform ASCII code to EBCDIC code. Similarly if EBCDIC coded data is to be used in a ASCII computer, EBCDIC code has to be transformed to ASCII.

c. ISCII
ISCII stands for Indian Standard Code for Information Interchange or Indian Script Code for Information Interchange. It is an encoding scheme for representing various writing systems of India. ISCII uses 8-bits for data representation. It was evolved by a standardisation committee under the Department of Electronics during 1986-88, and adopted by the Bureau of Indian Standards (BIS). Nowadays ISCII has been replaced by Unicode.

d. Unicode
Using 8-bit ASCII we can represent only 256 characters. This cannot represent all characters of written languages of the world and other symbols. Unicode is developed to resolve this problem. It aims to provide a standard character encoding scheme, which is universal and efficient. It provides a unique number for every character, no matter what the language and platform be.

Unicode originally used 16 bits which can represent up to 65,536 characters. It is maintained by a non-profit organisation called the Unicode Consortium. The Consortium first published the version 1.0.0 in 1991 and continues to develop standards based on that original work. Nowadays Unicode uses more than 16 bits and hence it can represent more characters. Unicode can represent data in almost all written languages of the world.

Let us sum up
Data processing is a series of activities by which data is converted into information. The limitations of manual data processing are overcome by electronic data processing and the computer is the best electronic data processor. A computer has five functional units such as input unit, storage unit, arithmetic logic unit, control unit and output unit. Though the data supplied to computers is of different forms, internally these are represented using bits. Different number systems are associated with computer and any number in one system has an equivalent form in another system. Different types of coding systems are also available to represent characters in computer.
1. Fundamentals of Computer

**Learning outcomes**

After the completion of this chapter the learner will be able to

- distinguish between data and information.
- identify various stages in data processing.
- list the functional units of a computer and explain the functions of each.
- explain why the computer is the best electronic data processing machine.
- infer the concept of data representation inside computers.
- list the features of various coding systems to represent characters.

**Sample questions**

**Very short answer type**

1. What is data?
2. Processed data is known as _______.
3. Hexadecimal number system uses _______ symbols and octal number system uses _______ symbols.
4. EBCDIC stands for _______.
5. Name the coding system that can represent almost all characters used in the human languages in the world.

**II. Short answer type**

1. Distinguish between data and information.
2. The application form for Plus One admission contains your personal details and your choice of groups and schools.
   a. Identify the data and information in the admission process.
   b. Explain how the information helps the applicants and the school authorities.
   c. Write down the activities involved in the processing of the data.
3. How is a computer superior to human in data processing?
4. Explain the role of storage in data processing activities.
5. List down the functions of input unit of a computer.
7. Write down the role of control unit in a computer?
8. How does the memory unit help CPU to perform its function?
9. "Computers are slaves, humans are masters". Do you agree with this? Give reasons.
10. List down the characteristics of computers.
11. Computer is a versatile machine. How?
12. What is meant by the term diligence, the characteristic of a computer?
13. Define the term data representation
14. What do you mean by a number system? List any four number systems.
15. What are the methods of representing characters in computer memory?
16. Write a short notes on ASCII and ISCII.
17. Briefly explain the significance of UNICODE in character representation.

Long answer type
1. Taking the example of a real life situation like banking, briefly describe the activities involved in each stage of data processing.
2. With the help of a block diagram, explain the functional units of a computer.
We are familiar with computers and their uses today. Computer can be defined as a fast electronic device that accepts data, processes it as per stored instructions and produces information as output. We know that a computer has two major components - hardware and software. Hardware refers to all physical components associated with a computer system while software is a set of instructions for the hardware to perform a specific task. When we use computers to solve any problem in real life situations, the tasks are usually set up to process data to generate information. This chapter presents the various hardware components followed by electronic waste, its disposal methods and the concept of green-computing. Different classifications of software are also dealt with. We also discuss the concepts of free and open source, freeware, shareware and proprietary software.

2.1 Hardware

We know that a computer system consists of hardware and software. The term hardware represents the tangible and visible parts of a computer, which consists of some electromechanical components. These hardware components are associated with the
functional units of computer that we discussed in the previous chapter. Let us discuss some of these components.

2.1.1 Processors

In high school classes we learned that the Central Processing Unit (CPU)/processor is responsible for all computing and decision making operations and coordinates the working of a computer. The performance of a CPU determines the overall performance of the computer (refer Figure 2.1). Since CPU is an Integrated Circuit (IC) package which contains millions of transistors and other components fabricated into a single silicon chip, it is also referred as microprocessor. A CPU is usually plugged into a large socket on the main circuit board (the motherboard) of the computer. Since heat is generated when the CPU works, a proper cooling system is provided with a heat sink and fan. Intel core i3, core i5, core i7, AMD Quadcore, etc. are some examples of processors.

Fig. 2.1: Central Processing Units

Every computer contains an internal clock that regulates the rate at which instructions are executed. The CPU requires a fixed number of clock ticks (or clock cycles) to execute each instruction. The faster the clock, the more instructions the CPU can execute per second. Another factor is the architecture of the chip. The number of bits a processor can process at one time is called word size. Processors with many different word sizes exist: 8-bit, 16-bit, 32-bit, 64-bit, etc.

Registers are storage locations inside CPU, whose contents can be accessed more quickly by the CPU than other memory. They are temporary storage areas for instructions or data. They are not a part of memory; rather they are special additional storage locations that offer computers the advantage of speed. Registers work under the direction of the control unit to accept, hold, and transfer instructions or data and perform arithmetic or logical operations at high speed. It speeds up the execution of programs.

Important registers inside a CPU are:

a. **Accumulator**: The accumulator is a part of the Arithmetic Logic Unit (ALU). This register is used to store data to perform arithmetic and logical operation. The result of an operation is stored in the accumulator.

b. **Memory Address Register (MAR)**: It stores the address of a memory location to which data is either to be read or written by the processor.
c. **Memory Buffer Register (MBR):** It holds the data, either to be written to or read from the memory by the processor.

d. **Instruction Register (IR):** The instructions to be executed by the processor are stored in the instruction register.

e. **Program Counter (PC):** It holds the address of the next instruction to be executed by the processor.

### 2.1.2 Motherboard

A motherboard is a large Printed Circuit Board (PCB) to which all the major components including the processor are integrated. Figure 2.2 shows the motherboard and its components. It also provides expansion slots for adding additional circuit boards like memory, graphics card, sound card, etc. The motherboard must be compatible with the processor chosen.

### 2.1.3 Peripherals and ports

Peripherals are devices that are attached to a computer system to enhance its capabilities. Ports on the motherboard are used to connect external devices. Figure 2.3 shows the various ports in a computer system. Peripherals include input devices, output devices, external storage and communication devices. Peripheral devices communicate with the motherboard, through the ports available on the motherboard like Video Graphics Array (VGA), IBM Personal System/2 (PS/2), Universal Serial Bus (USB), Ethernet, High Definition Multimedia Interface (HDMI), etc. Let us look at some kinds of ports used on personal computers.
a. Serial port

A serial port / serial communication port transmits data one bit at a time. In older computers devices such as modem, mouse or keyboard were connected through serial ports (refer Figure 2.4). Serial cables are cheaper to make and easier to shield from interference. Since its speed is too low, they are being replaced by faster ports like PS/2, USB, etc.

b. Parallel port

Parallel ports can transmit several bits of data simultaneously. It is faster than serial port and is used to connect a printer or scanner to the computer. Figure 2.5 shows a parallel port in a computer system.

c. USB port

Universal Serial Bus (USB) is a connection that provides high speed data communication between devices. Due to its high bandwidth data transfer is faster. It is used for short-distance communication. USB port is used for connecting devices like keyboard, mouse, printer, scanner, flash drive, external hard disk, etc. Figure 2.6 shows the various types of USB ports. The main advantage of USB ports are:

- USB ports are capable of supplying electric power to external devices. This technology led to the development of devices like external hard disk, flash drive, dongle, etc. which draw power from the USB port. It can also be used for power devices like mobile phones, tablets, laptops, etc.
- USB devices can be connected and disconnected even when the power is on.

d. LAN port

Alternatively referred to as an Ethernet port, network connection, and network port, the Local Area Network (LAN) port is a port connection that allows a computer to connect to a network using a wired connection. The registered jack RJ45 is a standard type of connector used for connecting cables through LAN ports (refer Figure 2.7).
e. **PS/2 port**

Personal System/2 (PS/2) ports are special ports invented by International Business Machines (IBM) for connecting the keyboard and mouse (refer Figure 2.8). These types of ports are too slow and replaced by faster ports like USB nowadays.

f. **Audio ports**

Audio ports are used to connect audio devices like speakers, microphone, etc. The three small connectors shown in Figure 2.9 are used for connecting:

a. Line in - Sound input (from any audio device like mobile line out, ipod, etc.)

b. Line out - Sound out (to connect your PC's sound output to external speakers)

c. Mic in - Microphone input port.

g. **Video Graphics Array (VGA) port**

VGA is a popular display standard developed by IBM. The VGA port is used to connect a monitor or a projector to a computer. The VGA connector has 15 pins displayed in three rows as indicated in Figure 2.10. Super VGA (SVGA) was developed to support 800 \( \times \) 600 resolution and was later replaced by Extended Graphics Array (XGA) that supports 1024 \( \times \) 768 resolution. Regardless of what resolution a monitor is able to support, they are commonly referred to as VGA.

h. **High Definition Multimedia Interface (HDMI)**

HDMI is a type of digital connection capable of transmitting high-definition video and multi channel audio over a single cable (refer Figure 2.11). To do the same thing with analog cables, we need to connect several video and audio cables.

2.1.4 **Memory**

Memory is a place where we can store data, instructions and results temporarily or permanently. Memory can be classified into two: primary memory and secondary memory. Primary memory holds data, intermediate results and results of ongoing jobs temporarily. Secondary memory on the other hand holds data and information permanently. Before learning more about memory, let us discuss the different memory measuring units.
a. **Primary Storage**

Primary memory is a semiconductor memory that is accessed directly by the CPU. It is capable of sending and receiving data at high speed. This includes mainly three types of memory such as RAM, ROM and Cache memory.

i. **Random Access Memory (RAM)**

RAM refers to the main memory that microprocessor can read from and write to. Data can be stored and retrieved at random from anywhere within the RAM, no matter where the data is. Data or instructions to be processed by the CPU must be placed in the RAM (refer Figure 2.12). The contents of RAM are lost when power is switched off. Therefore, RAM is a volatile memory. Storage capacity of RAM is 2 GB and above.

The speed of a RAM refers to how fast the data in memory is accessed. It is measured in Mega Hertz (MHz). When a computer is in use, its RAM contains the following:

1. The operating system software.
2. The application software currently being used.
3. Any data that is being processed.

ii. **Read Only Memory (ROM)**

ROM is a permanent memory that can perform only read operations and its contents cannot be easily altered. ROM is non-volatile; the contents are retained even after the power is switched off. ROM is used in most computers to hold a small, special piece of 'boot up' program known as Basic Input Output System (BIOS). This software runs when the computer is switched on or 'boots up'. It checks the computer's hardware and then loads the operating system. It is slower than RAM. Figure 2.13 shows a typical ROM chip.
There are some modified types of ROM that include:

1. **PROM** - Programmable ROM which can be programmed only once. PROM's are programmed at the time of manufacture.

2. **EPROM** - Erasable Programmable ROM that can be erased using ultra violet radiation and can be programmed using special electronic circuits.

3. **EEPROM** - Electrically Erasable Programmable ROM which can be erased and rewritten electrically.

Table 2.1 shows the comparison between RAM and ROM.

<table>
<thead>
<tr>
<th>RAM</th>
<th>ROM</th>
</tr>
</thead>
<tbody>
<tr>
<td>It is faster than ROM</td>
<td>It is a slower memory</td>
</tr>
<tr>
<td>It stores the operating system, application programs and data when the computer is functioning.</td>
<td>It stores the program required to boot the computer initially</td>
</tr>
<tr>
<td>It allows reading and writing.</td>
<td>Usually allows reading only.</td>
</tr>
<tr>
<td>It is volatile, i.e. its contents are lost when the device is powered off.</td>
<td>It is non-volatile, i.e. its contents are retained even when the device is powered off.</td>
</tr>
</tbody>
</table>

**Table 2.1 : Comparison of RAM and ROM**

### iii. Cache memory

Cache memory is a small and fast memory between the processor and RAM (main memory). Frequently accessed data, instructions, intermediate results etc. are stored in cache memory for quick access. When the processor needs to read from or write to a location in RAM, it first checks whether a copy of that data is in the cache. If so, the processor immediately reads the cache, which is much faster than reading from RAM. Cache is more expensive than RAM, but it is worth using it in order to maximise system performance. Commonly used cache memories and their capacities are as follows Level 1 Cache (128 KB), Level 2 Cache (1 MB), Level 3 Cache (8 MB) and Level 4 Cache (128 MB).

### b. Secondary or Auxiliary memory

Secondary memory is of permanent nature. Unlike the contents of RAM, the data stored in these devices does not vanish when power is turned off. Secondary memory is much larger in size than RAM, but is slower. It stores programs and data but the processor cannot access them directly. Secondary memory is also used for transferring data or programs from one computer to another. It also acts as a backup. The major categories of storage devices are magnetic, optical and semiconductor memory.
i. Magnetic storage devices

Magnetic storage devices use plastic tape or metal/plastic disks coated with magnetic materials. Data is recorded magnetically in these devices. Read/write heads are used to access data from these devices. Some of the popular magnetic storage devices are magnetic tapes, floppy disks, hard disks, etc.

Magnetic Tape

Magnetic tape is a backup device that can store huge volume of data. The cost per unit volume of a magnetic tape is less compared to other magnetic storage devices.

It is a recording medium consisting of a thin tape with a coating of fine magnetic material. It can be used for recording analog or digital data. Data is stored in frames across the width of the tape with a read/write head. The frames are grouped into blocks or records which are separated from other blocks by gaps as shown in Figure 2.14.

![Fig. 2.14 : Magnetic Tape and Blocks of data on tape](image)

It takes a lot of time to locate data in a magnetic tape, as it is a sequential access medium, similar to an audio cassette. For example, if we need to access the 100th record on the tape, we must first move through the previous 99 records. The capacity of tape media is referred in Terabytes.

Hard disk

The hard disk consists of metal disks coated with magnetic material concealed in dust free containers. Hard disks have very high storage capacity, high data transfer rates and low access time. It is more durable and less error prone. It is the most common secondary storage device used in computers.

A hard disk may contain one or more platters. Each platter requires two read/write heads, one for each surface. A tiny electromagnetic read/write head attached to an access arm magnetises tiny spots on the disk to store data as shown in Figure 2.15. The same electromagnetic head can later sense the magnetic fields of the spots, allowing the data to be read back from the disk.

![Fig. 2.15 : Hard disk](image)
Data is stored on the surface of a platter in sectors and tracks. Tracks are concentric circles on a platter and a sector is a pie-sliced part of a disk platter as shown in Figure 2.16. Formatting is the activity of creating sectors and tracks on the disk. Only then can read/write operation be performed on the disk. If a disk having data is formatted, then all data will be lost.

Large disks can be partitioned logically into distinct sections or volumes. These volumes are independent of each other and can be formatted independently.

Rating of Hard Disk Drive (HDD) depends on capacity, speed and access time.
- Storage capacity: 500GB, 1TB or more
- Speed: How fast the disk spins, rotations per minute (rpm) usually 5400 rpm/7200 rpm
- Access time: Time to retrieve bits of data from disk (in milliseconds)

**ii. Optical storage devices**

Optical disk is a data storage medium which uses low-powered laser beam to read from and write data into it. It consists of an aluminum foil sandwiched between two circular plastic disks. Data is written on a single continuous spiral in the form of pits and lands as shown in Figure 2.17. The laser beam reads this pits and lands as 0s and 1s. It is very cheap to manufacture optical disks in large quantities and are a popular secondary storage medium. The main types of optical disks are CD, DVD and Blu-Ray.

**Compact Disk (CD)**

Compact Disk is an optical storage medium capable of storing up to 700 MB of data. A CD drive uses red laser beams for reading from and writing data into CD. There are two types of CDs, CD-R and CD-RW. In CD-R (CD-Recordable) data can be written

Fig. 2.16: A platter

Fig. 2.17: CD, DVD and Blu-ray disk - pits & lands

Fig. 2.18: CD
once and read many times where in CD-RW (CD-Rewritable) disks can be erased and rewritten at any time.

**Digital Versatile Disk (DVD)**

Digital Versatile Disc is an optical storage media similar to CD-ROM, but with a higher storage capacity. This is achieved by using smaller spots to record data. Recording and reading of data is done using DVD drive. Here also red laser beam is used for doing these operations. The capacity of a DVD varies from 4.37 GB to 15.9 GB. There are three major types of DVDs: DVD-ROM, DVD-RW and DVD-RAM.

- **DVD-ROM**: DVD-Read Only Memory functions in the same way as CD-ROM
- **DVD-RW**: DVD-Rewritable disks can be erased and rewritten at any time.
- **DVD-RAM**: DVD Random Access Memory discs can be recorded and erased repeatedly. These are compatible only with devices manufactured by companies that support the DVD-RAM format. It is comparable to DVD-Rewritable disk, but have higher lifetime and can be erased more often than a DVD-RW.

A normal DVD known as DVD-5 stores 4.37 GB data whereas a dual layer double side DVD known as DVD-18 can store 15.9 GB.

**Blu-ray DVD**

Blu-ray is an optical disk format developed to enable recording, rewriting and playback of High Definition (HD) video as well as storing huge amounts of data. CD and DVD technologies use red laser to read and write data while blu-ray format uses a blue-violet laser. Hence it has the name Blu-ray. The benefit of using a blue-violet laser is that it has a shorter wavelength than a red laser, which makes it possible to focus the laser spot with greater precision. This allows data to be packed more tightly. Therefore it is possible to store more data on the disk even though it is of the same size of a CD/DVD. The format offers more than five times the storage capacity of traditional DVDs and can hold up to 25 GB on a single-layer disc and 50 GB on a dual-layer disc.

**iii. Semiconductor storage (Flash memory)**

Flash drives use EEPROM chips for data storage. They do not contain any moving parts and hence they are shockproof. Flash memory is faster and durable when compared to other types of secondary memory. The different variants of flash memories are available today.
USB flash drive

A flash drive is a small external storage device, which consists of flash memory typically the size of a human thumb. USB flash drives are portable and rewritable. The storage capacity of a USB drive currently varies from 2 GB to 32 GB.

Flash memory cards

Flash memory card is another type of flash memory. They are flat and have a size of about 1 inch × 0.75 inch with a thickness of about 2 mm. Memory cards currently have storage capacities in the range of 1 GB - 32 GB. Flash memory cards also have a smaller version which is used within cell phones, tablets, etc (refer Figure 2.20). These smaller cards are about 6 mm × 3 mm in size and are less than 1 mm thick.

Role of different types of memories in computer

Let us discuss an example of data processing. Consider the case of a payroll program to calculate the salary of an employee. The data for all the employees is available in the hard disk. All the data about a particular employee is taken to the RAM and from there data related to salary calculation (bonus, deductions, etc.) is taken to the cache. The data representing the hours worked and the wages is moved to their respective registers. Using data on the hours worked and the wage, ALU makes calculations based on instructions from control unit. For further calculations, it moves the overtime hours, bonus, etc. from cache to registers. As the CPU finishes calculations about one employee, the data about the next employee is brought from secondary storage into RAM, then cache and eventually into the registers.

Table 2.2 summarises the characteristics of the various kinds of data storage in the storage hierarchy. Modern computers are designed with this hierarchy due to the characteristics listed in the table.
To see how registers, memory and second storage work together, let us use the analogy of making a salad. In our kitchen we have:

- A refrigerator where we store vegetables for the salad.
- A counter where we place all vegetables before putting them on the cutting board for chopping.
- A cutting board on the counter where we chop vegetables.
- A recipe that details what vegetables to chop.
- The corners of the cutting board are kept free for partially chopped piles of vegetables that we intend to chop more or to mix with other partially chopped vegetables.
- A bowl on the counter where we mix and store the salad.
- Space in the refrigerator to put the mixed salad after it is made.

The process of making the salad is then: bring the vegetables from the fridge to the counter top; place some vegetables on the chopping board according to the recipe; chop the vegetables, possibly storing some partially chopped vegetables temporarily on the corners of the cutting board; place all the vegetables in the bowl and keep it back in the fridge if not served on the dinner table.

In this context the refrigerator serves as secondary (hard disk) storage. It can store high volumes of vegetables for long periods of time. The counter top functions like the computer’s motherboard - everything is done on the counter (inside the computer). The cutting board is the ALU - the work gets done there. The recipe is the control unit - it tells you what to do on the cutting board (ALU). Space on the counter top is the equivalent of RAM - all required vegetables must be brought from the fridge and placed on the counter top for fast access. Note that the counter top (RAM) is faster to access than the fridge (disk), but cannot hold as much, and cannot hold it for long periods of time. The corners of the cutting board where we temporarily store partially chopped vegetables are equivalent to the registers. The corners of the cutting board are very fast to access for chopping, but cannot hold much. The salad bowl is like a cache memory, it is for storing chopped vegetables to be temporarily removed from the corners of the cutting board (as there is too much) or the salad waiting to be taken back to the fridge (putting data back on a disk) or to the dinner table (outputting the data to an output device).
2. Components of the Computer System

<table>
<thead>
<tr>
<th>Storage</th>
<th>Speed</th>
<th>Capacity</th>
<th>Relative Cost</th>
<th>Volatile</th>
</tr>
</thead>
<tbody>
<tr>
<td>Registers</td>
<td>Fastest</td>
<td>Lowest</td>
<td>Highest</td>
<td>Yes</td>
</tr>
<tr>
<td>Cache</td>
<td>More Fast</td>
<td>Low</td>
<td>Very High</td>
<td>Yes</td>
</tr>
<tr>
<td>RAM/ROM</td>
<td>Very Fast</td>
<td>Low/Moderate</td>
<td>High</td>
<td>Yes</td>
</tr>
<tr>
<td>Hard Disk</td>
<td>Moderate</td>
<td>Very High</td>
<td>Very Low</td>
<td>No</td>
</tr>
</tbody>
</table>

*Table 2.2: Comparison of different types of memory*

Check yourself

1. The fastest memory in a computer is ________.
2. The storage capacity of a single layer DVD is ________.
3. What is cache memory?
4. What is the use of program counter register?
5. What is HDMI?

2.1.5 Input/Output devices

The computer will be of no use unless it is able to communicate with the outside world. Input/output devices are required for users to communicate with the computer. In simple terms, input devices feed data and instructions into the computer and output devices present information from a computer system. These input/output devices are connected to the CPU through various ports or with the help of wireless technologies. Since they reside outside the CPU, they are called peripherals.

a. **Input devices**

An input device is used to feed data into a computer. It is also defined as a device that provides communication between the user and the computer. We will now discuss some input devices in detail.

i. **Keyboard**

Keyboard is the most common input device. It allows the user to input alphabets, numbers and other characters. Keyboard detects the key pressed and generates the corresponding ASCII code which can be recognised by the computer. The standard US keyboard introduced in 1986 has 101 keys. It has a keyboard layout called the
QWERTY design. QWERTY gets its name from the first six letters across in the upper-left-hand corner of the keyboard as shown in Figure 2.22.

![Keyboard Diagram](image)

Fig. 2.22 : Keyboard

Keyboards can be classified as wired and wireless. Wired keyboards are connected to the CPU through a serial, PS/2 port or a USB port. Wireless keyboards are connected to the computer through infrared (IR), radio frequency (RF) or bluetooth connections. Portable flexible keyboards are also available now. New generation keyboards like laser keyboards that project the keyboard layout to any surface are being developed.

ii. Mouse

A mouse is a small hand-held device used to indicate the position of a cursor or its movement on a computer display screen by rolling it over a mouse pad / flat surface. A mouse has one or more buttons and possibly a scroll wheel. Scroll wheel is used for scrolling the screen vertically or horizontally. The different types of mouse are ball, optical and laser mouse. Ball mouse works on the principle of the movement of the ball, whereas optical mouse uses LED and laser mouses use laser beams for sensing the movement. Laser mouse has more precise movements when compared to other types of mouse. Wired mouse, uses serial, PS/2 and USB ports to communicate, whereas a wireless mouse communicates with the computer via radio waves.

![Mouse Image](image)

Fig. 2.23 : Mouse

iii. Light pen

A light pen is a pointing device shaped like a pen. The tip of the light pen contains a light-sensitive element which when placed against the screen, detects the light from the
screen enabling the computer to identify the location of the pen on the screen. Light pens have the advantage of 'drawing' directly onto the screen. They are used by engineers, artists, fashion designers for Computer Aided Designing (CAD) and drawing purposes.

iv. Touch screen

It is an input device that allows the user to operate by simply touching on the display screen. Some computers, tablets, smart phones, etc. have touch-sensitive display screens. It can also be operated using a stylus which gives more precision. Information kiosks at railway stations and bank ATMs also use touch screens as input device.

v. Graphic tablet

A graphics tablet consists of an electronic writing area and a special "pen" that works with it. Graphic tablet allows artists to create graphical images with motions and actions similar to traditional drawing tools. The pen of the graphics tablet is pressure sensitive. Hard or soft pressure on the tablet using the pen can result in brush strokes of different width in an appropriate graphics program.

vi. Touchpad

A touchpad is a pointing device found on the portable computers and some external keyboards. It allows us to move the mouse pointer without the need of an external mouse. Touchpad is operated by using finger and dragging it across the flat surface; as the finger moves on the surface, the mouse cursor will move in that same direction. The touchpad also has two buttons below the touch surface that enables to click.

vii. Joystick

Joystick is an input device used for playing video games, controlling training simulators and robots. Joysticks and other game controllers can also be used as pointing device. The joystick has a vertical stick which can move in any direction. It can be used to control
objects in a video game or to make menu selections by the movement of a cursor displayed on the screen. It has a button on the top that is used to select the option pointed by the cursor.

**viii. Microphone**

A microphone can be attached to a computer to input sound. It accepts sound which is analogue in nature as input and converts it to digital format. The digitised sound can be stored in the computer for processing or playback. A computer loaded with speech recognition software like the one preinstalled in Windows 7, can convert what a person has said into text, which can be saved for word processing. A voice recognition program can process the input and convert it into machine-recognisable commands.

![Microphone](image1.png)

**ix. Scanner**

Scanners can capture information, like pictures or text, and convert it into a digital format that can be edited using a computer. The quality of the image depends on the resolution of the scanner. The resolution of the image scanned is expressed in Dots Per Inch (DPI). The higher the DPI, the better the resolution. The different variants of scanners are flat bed, sheet feed and hand held scanner. A sheet feed scanner can scan a single sheet, whereas flat bed can scan even from a book, but they are not portable. A hand held scanner is portable but the scanning action is not smooth as the scanner is moved manually.

Optical Character Recognition (OCR) software is used to recognise the printed text in an image scanned and convert it into proper text format, which can be edited by a text editor. Advanced OCR system can read printed text in a large variety of fonts but has difficulty with handwritten text. Accurate OCR SDK, Hindi OCR software, Akshara Malayalam OCR, etc. are examples of OCR softwares.

**x. Optical Mark Reader (OMR)**

OMR technology scans a printed form and reads predefined positions, and records the marks on the form. This technology is useful for applications in which large number of hand-filled forms need to be processed quickly with great accuracy, such as objective type tests and questionnaires.

![Scaner](image2.png)

![OMR](image3.png)
OMR sheets are normally used to evaluate multiple choice questions in competitive exams. It consists of bubble-shaped options to mark answers. Candidates are required to darken the correct bubble option using a pen or pencil. OMR readers can recognize these marks and the appropriate software uses this input for evaluation (refer Figure 2.31). For accuracy of results, good quality paper and accurate alignment of printing is essential.

xi. Barcode/Quick Response (QR) code reader

A barcode is a set of vertical lines of different thickness and spacing that represent a number. Barcode readers are devices that are used to input data from such set of barcodes (refer Figure 2.33). Hand-held scanners are commonly seen in shops to scan codes and price information for each of the items so that billing will be easier. Mobile phones with a camera and special software can also be used as a barcode reader.

A QR code is similar to barcodes. Barcodes are single dimensional whereas QR codes are two-dimensional as shown in Figure 2.34. The two-dimensional way of storing data allows QR code to store more data than a standard barcode. This code can store website URLs, plain text, phone numbers, email addresses and any other alphanumeric data. The QR code can be read using a barcode reader or a mobile phone with a camera and a special software installed.

xii. Biometric sensor

A biometric sensor is a device that identifies unique human physical features with high accuracy. It is an essential component of a biometric system which uses physical features like fingerprints, retina, iris patterns, etc., to identify, verify and authenticate the identity of the user. The three major types of biometric sensors are semiconductor sensor, optical sensor and ultrasound sensor. Figure 2.35 shows a fingerprint sensor.

xiii. Smart card reader

A smart card is a plastic card that stores and transacts data. The data card may contain a memory or a microprocessor. Memory cards simply store data, while a microprocessor
card, on the other hand, can add, delete and manipulate information in its memory. The smart card is used in most banking, healthcare, telephone calling, electronic cash payments and other applications.

Smart card readers are used to access data in a smart card. It can be contact type or contactless. A contact type of reader requires physical contact with the cards, which is made by inserting the card into the reader. A contactless type of reader works with a radio frequency that communicates when the card comes close to the reader. Many contactless readers are designed specifically for toll gate payment in transportation applications and person identity applications.

xiv. Digital camera

A digital camera can take pictures and videos and convert them into digital format. Pictures or videos taken using a digital camera are stored inside its memory and can be transferred to a computer by connecting the camera to it.

The quality of the lens, the density of Charge Couple Device (CCD), resolution (measured in megapixel), optical zoom and the software used in the camera determines the quality of the picture. Each picture is made up of thousands of tiny pixels (picture elements) and the camera stores the data about the color of each dot. The quality of the picture is determined by the number of pixels in each picture. Digital cameras have resolutions ranging from 2 mega pixel to 24 megapixels and optical zoom ranging from 3x to 60x.

Web camera is a compact and less expensive version of a digital camera. It is used in computers for video calling, video chatting, etc. It does not have an internal memory. Applications like Skype, Yahoo Messenger, etc. use webcam to capture images. Now, laptops also come with an inbuilt web camera.
b. Output devices

Output devices are devices that print/display output from a computer. Outputs generated by the output devices may be hardcopy output or softcopy output. Hardcopy outputs are permanent outputs which can be used at a later date or when required. They produce a permanent record on paper. The common output devices that produce hardcopy outputs are printers and plotters. Softcopy outputs are electronic and are available on the screen in a digital form. They do not produce a permanent record. A common softcopy output device is the Visual Display Unit (VDU).

i. Visual Display Unit (VDU)

A Visual Display Unit (VDU) is an output device that visually conveys text, graphics and video information. Information shown on a display device is called softcopy because the information exists electronically and is displayed for a temporary period of time. Display devices include Cathode Ray Tube (CRT) monitors, Liquid Crystal Display (LCD) monitors, Thin Film Transistor (TFT) monitors, Light Emitting Diode (LED) monitors, gas plasma monitors.

Some of the characteristics of a VDU are size, resolution, pixel-pitch and response time. VDUs are available in different sizes. The size of a monitor is measured diagonally across the screen, in inches. The resolution of the monitor is the maximum number of pixels it can display horizontally and vertically (such as 800 × 600 or 1024 × 768 or 1600 × 1200). The pixel spacing on the screen is called the dot pitch. A screen with smaller dot pitch produces sharper images. Response time refers to the time taken for a pixel to turn from a state of brightness to a state of darkness and then back again. Monitors, with lesser response time provide better movie viewing experience.

Cathode Ray Tube (CRT) monitor

The Cathode Ray Tube (CRT) monitor resembles television sets of the past. Two types of CRT monitors are available, monochrome and color. A monochrome monitor displays characters and images in a single colour on a dark background. Another variation of monochrome monitor capable of displaying different shades of grey is called a grey scale monitor. A colour monitor uses three different basic colours such as red, blue and green to display 16 to 1 million different colours. These monitors are preferred by some graphic artists for their accurate colour rendering and by some gamers for faster response to rapidly changing graphics.
Flat panel monitor

Flat panel displays are thinner, lighter in weight, consume less power and emit less heat compared to CRT monitors. Flat panel monitors are most commonly used in computers, especially in laptops. Different types of flat panel monitors are LCD Monitors, LED Monitors, Plasma Monitors and OLED Monitors.

**Liquid Crystal Display (LCD) Monitors:** LCD displays consist of liquid crystals sandwiched between two plastic plates. These crystals rearrange to form an image when an electric current is passed through them. A light source at the back of this plate makes the picture visible. This light source can be fluorescent lamp or LED.

**Light Emitting Diode (LED) Monitors:** LED monitors use LED directly behind the liquid crystal display (LCD) in order to light up the screen. This technique is very effective and gives each area of the screen its own light, which can be on or off. LED screens can produce massive contrast ratios making the difference between the lights and the blacks appear almost perfect. This technology is expensive. The advantage of using LED is better color quality, clarity, wider viewing angle, faster refresh rates and power savings.

**Plasma Monitors:** A flat-panel display consists of sandwiching neon/xenon gas between two sealed glass plates with parallel electrodes deposited on their surfaces. When a voltage pulse is passed between two electrodes, the gas lights up as different colours, creating images on a monitor. Plasma monitors provide high resolution but are expensive.

**Organic Light Emitting Diode (OLED) Monitors:** The panel of OLED is made up of millions of tiny LEDs. The O in OLED stands for organic which means there is carbon in the light emitting layer of the panel. OLED screens are thinner and lighter than LCDs and LEDs. They can produce better quality images and have a better viewing angle. OLEDs consume less power, but are very expensive.

LCD projector

An LCD projector is a type of video projector for displaying video, images or computer data on a large screen or other flat surface. It is a modern equivalent of the slide projector or overhead projector. A beam of high-intensity light travels through thousands of shifting pixels in an LCD display. This beam of light then passes through a lens which projects and focuses the image on the surface.
ii. Printer

Printers are used to produce hardcopy output. Based on the technology used, they can be classified as impact or non-impact printers. Impact printers use the typewriting or printing mechanism where a hammer strikes the paper through a ribbon in order to produce output. Dot-matrix printers fall under this category. Non-impact printers do not touch the paper while printing. They use different technologies to print characters on paper. Inkjet, Laser and Thermal printers fall under this category of printers.

Two factors that determine the quality of a printer are its resolution and speed. Resolution is measured in terms of DPI. Speed is measured in terms of number of characters printed in a unit of time and is represented as characters per second (cps), lines per minute (lpm), or pages per minute (ppm).

**Dot Matrix Printer (DMP)**

Dot matrix printers use small electromagnetically activated pins in the print head and an inked ribbon, to produce images by impact. The most commonly used printer heads consists of 9 pins. Certain printers use 24 pins for better print quality. These printers are slow and noisy, and are not commonly used for personal use. The Dot Matrix Printers are widely used at cash counters in shops due to their low printing cost and for the reason that we get carbon copies from them.

**Inkjet printer**

Inkjet printers form the image on the page by spraying tiny droplets of ink from the print head. The printer needs several colours of ink (cyan, yellow, magenta and black) to make colour images. Some photo-quality ink jet printers have more colours of ink. Ink jet printers are inexpensive, but the cost of ink cartridges makes it a costly affair in the long run.

**Laser printer**

A laser printer produces good quality output. The image to be printed is transferred to a drum using a laser beam. The toner powder from the toner cartridge is then sprayed on the drum. The toner powder sticks onto the portions traced on the drum by the laser beam. It is transferred to a paper by rolling the paper over the drum. Through heating the powder is fused on to the paper.
Monochrome and colour laser printers are available. Colour laser printers use multiple colour toner cartridges to produce colour output and are expensive. Laser printers are faster and their speed is rated in pages per minute (ppm).

**Thermal printer**

Thermal printing produces a printed image by selectively heating heat-sensitive thermal paper when it passes over the thermal print head. The coating turns black in the areas where it is heated, producing an image. Thermal printers print quiet and faster than dot matrix printers. They are also smaller, lighter and consume less power, making them ideal as portable printers. Thermal printers are popular as printers at Point-of-Sale terminals.

<table>
<thead>
<tr>
<th>Features</th>
<th>Laser Printers</th>
<th>Inkjet Printers</th>
<th>Thermal Printers</th>
<th>Dot Matrix Printers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printing material used</td>
<td>Ink powder</td>
<td>Liquid ink</td>
<td>Heat sensitive paper</td>
<td>Ink soaked ribbon</td>
</tr>
<tr>
<td>How it prints?</td>
<td>It fuses the powder on the paper through heating.</td>
<td>It sprays liquid ink on paper through microscopic nozzles.</td>
<td>Thermal paper is passed over the thermal print head.</td>
<td>Pins are pushed against ribbon on paper.</td>
</tr>
<tr>
<td>Printing speed</td>
<td>20 pages per minute</td>
<td>6 pages per minute</td>
<td>150 mm per second</td>
<td>30 - 550 characters per second</td>
</tr>
<tr>
<td>Quality</td>
<td>Printing quality is good. Best for black and white.</td>
<td>Printing quality is good, especially for smaller fonts.</td>
<td>Poor quality printing of images. Good quality text printing.</td>
<td>Poor printing quality for images. In terms of text, printing is good.</td>
</tr>
<tr>
<td>Advantages</td>
<td>Quiet, prints faster, high print quality.</td>
<td>Quiet, high print quality, no warm up time, device cost is less.</td>
<td>Quiet, fast, smaller, lighter &amp; consume less power. Portable.</td>
<td>Cheaper to print as ribbon is cheap. Carbon copy possible.</td>
</tr>
<tr>
<td>Disadvantages</td>
<td>More susceptible to paper jams. Toner is expensive. Device itself is expensive.</td>
<td>Ink is expensive, ink is not waterproof, and nozzle is prone to clogging.</td>
<td>Requires special thermal quality paper. Poor quality printing.</td>
<td>Initial purchase is expensive, maintenance is expensive, printing is not fast, makes noise.</td>
</tr>
</tbody>
</table>

*Table 2.3: Comparison of printers*
iii. Plotter

A plotter is an output device used to produce hardcopies of graphs and designs on the paper. A plotter is typically used to print large-format graphs or maps such as construction maps, engineering drawings and big posters. It is used in the design of cars, ships, aircrafts, buildings, highways etc. Plotters are of two types: Drum plotters and Flatbed plotters.

Drum plotter

A drum plotter is also known as roller plotter. It consists of a drum or roller on which a paper is placed and the drum rotates back and forth to produce the graph on the paper. It also consists of a drawing arm that holds a set of coloured ink pens or pencils. The drawing arm moves side to side as the paper is rolled back and forth through the roller. In this way, a perfect graph or map is created on the paper.

Flatbed plotter

A flatbed plotter is also known as table plotter. It plots on paper that is spread and fixed over a rectangular flatbed table. The flatbed plotter uses two drawing arms, each of which holds a set of coloured ink pens or pencils. The drawing arms move over the stationary paper and draw the graph on the paper. Flatbed plotter is very slow in drawing or printing graphs. The large and complicated drawing can take several hours to print.

iv. Three dimensional (3D) printer

A 3D printer is a new generation output device used to print 3D objects. It can produce different kinds of objects in different materials, using the same printer. A 3D printer can print anything from ceramic cups to plastic toys, metal machine parts, stoneware vases, fancy chocolate cakes, etc.

The 3D printing process turns the object to be printed into thousands of horizontal tiny little layers. It then prints these layers from the bottom to top, layer by layer. These tiny layers stick together to form a solid object.
v. Audio output device

The audio output is the ability of the computer to produce sound. Speakers are the output device that produces sound. It is connected to the computer through audio ports. The speaker produces sound by the movement of the diaphragm in the speaker, forward and backward according to the electrical signals coming out of the audio port. For high quality sound reproduction computers use 2.1 (3 speakers), 5.1 (5 speakers) and 7.1 (7 speakers) speaker systems.

2.2 e-Waste

e-Waste refers to electronic products nearing the end of their "useful life". Electronic waste may be defined as discarded computers, office electronic equipment, entertainment device, mobile phones, television sets and refrigerators. The used electronics which are destined for reuse, resale, salvage, recycling or disposal are also considered as e-Waste.

Nowadays electronics is part of modern life - desktops, laptops, cell phones, refrigerators, TVs and a growing number of other gadgets. Every year we buy new, updated equipments to satisfy our needs. More than 300 million computers and one billion cell phones are produced every year. All of these electronics goods become obsolete or unwanted, often within two or three years of purchase. This global mountain of waste is expected to continue growing at 8% per year.

Rapid changes in technology, changes in media, falling prices and planned obsolescence have resulted in a fast-growing surplus of electronic waste around the globe. It is estimated that 50 million tons of e-Waste are produced each year. Only 15-20% of e-Waste is recycled, the rest of these materials go directly into landfills and incinerators. Sale of electronic products in countries such as India and China and across continents such as Africa and Latin America are set to rise sharply over the next 10 years.

2.2.1 Why should we be concerned about e-Waste?

Electronic waste is not just waste. It contains some very toxic substances, such as mercury, lead, cadmium, brominated flame retardants, etc. The toxic materials can cause cancer, reproductive disorders and many other health problems, if not properly managed. It has been estimated that e-Waste may be responsible for up to 40% of the lead found in landfills.
### 2.2.2 What happens to the e-Waste?

Unfortunately, an incredibly small percentage of e-Waste is recycled. Even when we take it to a recycling center it is often not actually recycled - in the way most of us expect.

CRTs have a relatively high concentration of lead and phosphors both of which are necessary for the display. The United States Environmental Protection Agency (EPA) included discarded CRT monitors in its category of “hazardous household waste”. The majority of e-Waste is most often dumped or burned - either in formal landfills and incinerators or informally dumped or burned. These inappropriate disposal methods for electronic waste fail to reclaim valuable materials or manage the toxic materials safely. In effect, our soil, water and air are easily contaminated.

e-Waste should never be disposed with garbage and other household wastes. This should be segregated at the site and sold or donated to various organisations. Considering the severity of the e-Waste problem, it is necessary that certain management options be adopted by government, industries and the public to handle the bulk e-Waste.

<table>
<thead>
<tr>
<th>Chemical</th>
<th>Source</th>
<th>Consequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lead</td>
<td>Found as solder on printed circuit boards and in computer monitor glass.</td>
<td>Lead can cause damage to the central and peripheral nervous systems, blood systems, and kidneys in humans.</td>
</tr>
<tr>
<td>Mercury</td>
<td>Found in printed circuit boards, LCD screen backlights.</td>
<td>Affect a baby's growing brain and nervous system. Adults can suffer organ damage, mental impairment and a variety of other symptoms.</td>
</tr>
<tr>
<td>Cadmium</td>
<td>Found in chip resistors and semiconductors.</td>
<td>Cause various types of cancer. Cadmium can also accumulate in, and harm the kidneys.</td>
</tr>
<tr>
<td>BFRs-Brominated Flame Retardants</td>
<td>Found in printed circuit boards and some plastics.</td>
<td>These toxins may increase the risk of cancer.</td>
</tr>
</tbody>
</table>

*Table 2.4: Hazardous chemicals, its source and consequence*
Realising the growing concern over e-Waste, Central Pollution Control Board (CPCB) of Government of India has formulated "The e-Waste (Management & Handling) Rules, 2011" and are effective from 01-05-2012. These rules shall apply to every producer, consumer, collection centre, dismantler and recycler of e-Waste involved in the manufacture, sale and processing of electrical and electronic equipment or components. The implementation and monitoring of these guidelines shall be done by the State Pollution Control Boards concerned.

Government of Kerala has introduced strict measures for safe collection and disposal of e-Waste through a government order. The government has defined the role of manufacturers, local bodies and the Pollution Control Board (PCB) in safe disposal of e-Waste. Under the Extended Producer Responsibility, manufacturers of electrical and electronic goods will be required to take back used products from consumers directly or through agents or introduce buyback arrangement. They will also have to supply the e-Waste to authorised recycling units. Consumers have been directed to return used products of known brands to the manufacturers or deposit them at the collection centres set up by local bodies. The PCB will be required to identify agencies for recycling or disposal of e-Waste and organise awareness programmes on e-Waste disposal.

2.2.3 e-Waste disposal methods

The following disposal methods can be used for disposing e-Waste.

a. **Reuse:** It refers to second-hand use or usage after the equipment has been upgraded or modified. Most of the old computers are passed on to relatives/friends or returned to retailers for exchange or for money. Some computers are also passed on to charitable institutions, educational institutions, etc. Inkjet cartridges and laser toners are also used after refilling. This method reduces the volume of e-Waste generation.

b. **Incineration:** It is a controlled and complete combustion process in which the waste is burned in specially designed incinerators at a high temperature in the range of 900 to 1000 degree Celsius.

c. **Recycling of e-Waste:** Recycling is the process of making or manufacturing new products from a product that has originally served its purpose. Monitors, keyboards, laptops, modems, telephone boards, hard drives, compact disks, mobiles, fax machines, printers, CPUs, memory chips, connecting wires and cables can be recycled.

d. **Land filling:** It is one of the most widely used, but not recommended methods for disposal of e-Waste. In this method soil is excavated from the trenches made and waste material is buried in it, which is covered by a thick layer of soil.
2.2.4 Students’ role in e-Waste disposal

- Stop buying unnecessary electronic equipments.
- When electronic equipments get faulty try to repair it instead of buying a new one.
- Try to recycle electronic equipments by selling them or donating them to others extending their useful life and keeping them out of the waste stream.
- If you really need to buy new electronics, choose items with less hazardous substances, greater recycled content, higher energy efficiency, longer life span, and those that will produce less waste.
- Visit the manufacturer's website or call the dealer to find out if they have a take back programme or scheme for your discarded electronics.
- If the device is battery-operated, buy rechargeable instead of disposable batteries.
- Buy products with good warranty and take back policies

2.3 Green computing or Green IT

Green computing is the study and practice of environmentally sustainable computing or IT. Green computing is the 'designing, manufacturing, using and disposing of computers and associated components such as monitors, printers, storage devices, etc., efficiently and effectively with minimal or no impact on the environment.'

One of the earliest initiatives towards green computing was the voluntary labelling program known as 'Energy Star'. It was conceived by the Environmental Protection Agency (EPA) in 1992 to promote energy efficiency in hardware of all kinds. The Energy Star label has become a common sight, especially in notebook computers and displays. Similar programs have been adopted in Europe and Asia. The commonly accepted Energy Star symbol is shown in Figure 2.52.

Government regulation is only a part of an overall green computing idea. The work habits of computer users and businesses have to be modified to minimise adverse impact on the global environment. Here are some steps that can be taken:

- Turn off computer when not in use.
- Power-on the peripherals such as laser printers only when needed
- Use power saver mode.
- Use laptop computers rather than desktop computers whenever possible.
- Take printouts only if necessary.

Fig.2.52 : Energy Star label
- Use Liquid Crystal Display (LCD) monitors rather than Cathode Ray Tube (CRT) monitors.
- Use hardware/software with Energy Star label.
- Dispose e-Waste according to central, state and local regulations.
- Employ alternative energy sources like solar energy.

The environmentally responsible and eco-friendly use of computers and their resources is known as green computing.

**How to make computers green?**

The features that are important in making a computer greener include size, efficiency and materials. Smaller computers are greener because they use fewer materials and require less electricity to run. Efficient use of energy is also an important component of a green computer. Smaller computers such as laptops are more energy-efficient than bigger models and LCD screens use much less energy than the older CRT models. The use of hazardous materials such as lead and mercury should be minimised. To promote green computing the following four complementary approaches are employed:

**Green design:** Designing energy-efficient and eco-friendly computers, servers, printers, projectors and other digital devices.

**Green manufacturing:** Minimising waste during the manufacturing of computers and other components to reduce the environmental impact of these activities.

**Green use:** Minimising the electricity consumption of computers and peripheral devices and using them in an eco-friendly manner.

**Green disposal:** Reconstructing used computers or appropriately disposing off or recycling unwanted electronic equipment.

**Check yourself**

1. The environmentally responsible and eco-friendly use of computers and their resources is known as ________.
2. The process of making or manufacturing new products from the product that has originally served its purpose is called ________.
3. Compare dot matrix printers and laser printers.
4. List any two input and output devices each.
2.4 Software

Software is a general term used to denote a set of programs that help us to use computer system and other electronic devices efficiently and effectively. If hardware is said to form the body of a computer system, software is its mind. There are two types of software:

- System software
- Application software

2.4.1 System software

It is a set of one or more programs designed to control the operations of a computer. They are general programs designed to assist humans in the use of computer system by performing tasks such as controlling the operations, move data into and out of a computer system and to do all the steps in executing application programs. In short, system software supports the running of other software, its communication with other peripheral devices. It helps the users to use computer in an effective manner. It implies that system software helps to manage resources of the computer. Figure 2.53 depicts how system software interfaces with user and hardware.

Let us do

1. Conduct a survey in your locality to study the impact of e-Waste on the environment and health of the people and write a report.
2. Discuss the importance of green computing.

![Software with user and hardware interface](image-url)
System software is a set of system programs which aids in the execution of a general user’s computational requirements on a computer system. The following are the components of system software.

a. Operating system
b. Language processors
c. Utility software

**a. Operating system**

Operating system is a set of programs that acts as an interface between the user and computer hardware. The primary objective of an operating system is to make the computer system convenient to use. Operating system provides an environment for user to execute programs. It also helps to use the computer hardware in an efficient manner.

Operating system controls and co-ordinates the operations of a computer. It acts as the resource manager of the computer system. Operating system is the most important system software. It is the first program to be loaded from hard disk in the computer and it resides in the memory till the system is shut down. It tries to prevent errors and the improper use of computer.

**Major functions of an operating system**

The major functions of an Operating System are process management, memory management, file management, security management and command interpretation.

![Fig. 2.54: Operating System as a resource manager](image-url)
i. **Process management**

By the term process we mean a program in execution. The process management module of an operating system takes care of the allocation and de-allocation of processes and scheduling of various system resources to the different requesting processes.

ii. **Memory management**

Memory management is the functionality of an operating system which handles or manages primary memory. It keeps track of each and every memory location to ensure whether it is allocated to some process or free. It calculates how much memory is to be allocated to each process and allocates it. It de-allocates memory if it is not needed further.

iii. **File management**

The file management module of an operating system takes care of file related activities such as organising, naming, storing, retrieving, sharing, protection and recovery.

iv. **Device management**

Device management module of an operating system performs the management of devices attached to the computer. It handles the devices by combining both hardware and software techniques. The OS communicates with the hardware device via the device driver software.

Examples of various operating systems are DOS, Windows, Unix, Linux, Mac OS X, etc.

b. **Language processors**

We know that natural languages are the medium of communication among human beings. Similarly, in order to communicate with the computer, the user also needs to have a language that should be understood by the computer. Computer languages may be broadly classified into low level languages and high level languages.

Low-level languages are described as machine-oriented languages. In these languages, programs are written using the memory and registers available on the computer. Since the architecture of computer differs from one machine to another, there is separate low level programming language for each type of computer. Machine language and assembly language are the different low level languages.

**Machine language:** We know that a computer can understand only special signals, which are represented by 1s and 0s. These two digits are called binary digits. The language, which uses binary digits, is called machine language. Writing a program in
machine language is definitely very difficult. It is not possible to memorise a long string of 0s and 1s for every instruction.

**Assembly language:** Assembly language is an intermediate-level programming language. Assembly languages use mnemonics. Mnemonic is a symbolic name given to an operation. For example ADD for addition operation, SUB for subtraction operation, etc. It is easier to write computer programs in assembly language as compared to machine language. It is machine dependent and programmer requires knowledge of computer architecture.

**High Level Languages (HLL):** These are like English languages and are simpler to understand than the assembly language or machine language. High level language is not understandable to the computer. A computer program written in a high level language is to be converted into its equivalent machine language program. So these languages require a language translator (compilers or interpreters) for conversion. Examples of high level programming languages are BASIC, C, C++, Java, etc.

**Need for language processor**

The programs consisting of instructions to the computer, written in assembly language or high level language are not understood by the computer. We need language processors to convert such programs into low level language, as computer can only understand machine language. Language processors are the system programs that translate programs written in high level language or assembly language into its equivalent machine language.

**Types of language processors**

- **Assembler:** Assembly languages require a translator known as assembler for translating the program code written in assembly language to machine language. Because computer can interpret only the machine code instruction, the program can be executed only after translating. Assembler is highly machine dependent.

- **Interpreter:** Interpreter is another kind of language processor that converts a HLL program into machine language line by line. If there is an error in one line, it reports and the execution of the program is terminated. It will continue the translation only after correcting the error. BASIC is an interpreted language.

- **Compiler:** Compiler is also a language processor that translates a program written in high level language into machine language. It scans the entire program in a single run. If there is any error in the program, the compiler provides a list of error messages along with the line number at the end of the compilation. If there
are no syntax errors, the compiler will generate an object file. Translation using compiler is called compilation. After translation compilers are not required in memory to run the program. The programming languages that have a compiler are C, C++, Pascal, etc.

Figure 2.55 shows process involved in the translation of assembly language and high level language programs into machine language programs

**c. Utility software**

Utility software is a set of programs which help users in system maintenance tasks and in performing tasks of routine nature. Some of the utility programs with their functions are listed below:

- **Compression tools**: Large files can be compressed so that they take less storage area. These compressed files can be decompressed into its original form when needed. Compression of files is known as zipping and decompression is called unzipping. WinZip, WinRAR, etc. are examples of compression tools.

- **Disk defragmenter**: Disk defragmenter is a program that rearranges files on a computer hard disk. The files are arranged in such a way that they are no longer fragmented. This enables the computer to work faster and more efficiently.

- **Backup software**: Backup means duplicating the disk information so that in an event of disk failure or in an event of accidental deletion, this backup may be used. Backup utility programs facilitates the backing up of disk.
- **Antivirus software**: A computer virus is a program that causes abnormality in the functioning of a computer. Antivirus software is a utility program that scans the computer system for viruses and removes them. As new viruses are released frequently, we have to make sure that latest antivirus versions are installed on the computer. Most of the antivirus programs provide an auto-update feature which enables the user to download profiles of new viruses so as to identify and inactivate them. Norton Antivirus, Kaspersky, etc. are examples of antivirus programs.

### 2.4.2 Application software

Software developed for specific application is called application software. It includes general purpose software packages and specific purpose software. GIMP, Payroll System, Airline Reservation System, Tally, etc. are examples of application software.

#### a. General purpose software packages

General purpose software are used to perform operations in a particular application area. Such software is developed keeping in mind the various requirements of its users. They provide a vast number of features for its users. General purpose software is classified as word processors, spreadsheet software, presentation software, database software and multimedia software.

- **Word processing software**: Word Processing software is designed for creating and modifying documents. It helps to create, edit, format and print textual matters easily. Formatting features include different font settings, paragraph settings, bullets and numbering, alignments and more. In addition to this it can check spelling and grammar in the document, insertion of pictures, charts and tables. We can specify headers and footers for every page in the document. The most popular examples of this type of software are MS Word, Open Office Writer, etc.

- **Spreadsheet software**: Spreadsheet software allows users to perform calculations using spreadsheets. They simulate paper worksheets by displaying multiple cells that make up a grid. It also allows us to insert drawing objects in the worksheet and create different types of charts for graphical representation of numerical data. Microsoft Excel, Open Office Calc, Lotus 1-2-3 and Apple Numbers are some examples of spreadsheet software.

- **Presentation software**: The software that is used to display information in the form of a slide show is known as presentation software. Presentation software allows preparing slides containing pictures, text, animation, video and sound
effects. Microsoft PowerPoint and Open Office Impress are examples for presentation software.

- **Database software:** Database is an organised collection of data arranged in tabular form. Database Management System (DBMS) consists of a collection of interrelated data and a set of programs to access those data. The primary goal of a DBMS is to provide an environment that is both convenient and efficient to use in retrieving and storing database information. They provide privacy and security to data and enforce standards for data. Examples of DBMS software are Microsoft Access, Oracle, PostgreSQL, MySQL, etc.

- **Multimedia software:** Multimedia is the integration of multiple forms of media. This includes text, graphics, audio, video, etc. Multimedia software can process information in a number of media formats. It is capable of playing media files. Some multimedia software allows users to create and edit audio and video files. Audio converters, audio players, and video editing software are some forms of multimedia software. Examples are VLC Player, Adobe Flash, Real Player, Media Player, etc.

### b. Specific purpose software

Specific purpose software is a highly specialised software designed to handle particular tasks. These are tailor-made software to satisfy the needs of an organisation or institution. It is also known as customised software. Since customised software is developed for a single customer, it can accommodate that customer’s particular preferences and expectations. Some examples of specific purpose application software are listed in Table 2.5.

<table>
<thead>
<tr>
<th>Application Software</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Payroll System</td>
<td>• Payroll system maintains the details of employees of an organisation and keeps track of their salary details.</td>
</tr>
<tr>
<td>• Inventory Management System</td>
<td>• It is used for tracking inventory levels, orders, sales and deliveries in a business firm.</td>
</tr>
<tr>
<td>• Human Resource Management System</td>
<td>• It is used for managing human resource in an organisation.</td>
</tr>
</tbody>
</table>

*Table 2.5 : Examples of Application Software*
Free and open source software gives the user the freedom to use, copy, distribute, examine, change and improve the software. Nowadays free and open source software is widely used throughout the world because of adaptable functionality, less overall costs, vendor independency, adherence to open standards, interoperability and security.

The Free Software Foundation (FSF) defines the four freedoms for free and open source software:

**Freedom 0** - The freedom to run program for any purpose.

**Freedom 1** - The freedom to study how the program works and adapt it to your needs. Access to source code should be provided.

**Freedom 2** - The freedom to distribute copies of the software.

**Freedom 3** - The freedom to improve the program and release your improvements to the public, so that the whole community benefits.

The following are some of the examples of free and open source software:

**GNU/Linux:** GNU/Linux is a computer operating system assembled under the model of free and open source software development and distribution. It was organised in the GNU project introduced in 1983 by Richard Stallman in the FSF.

---

**Check yourself**

1. Define operating system.
2. Give two examples for OS.
3. A program in execution is called ______.
4. Mention any two functions of OS.
5. Name the software that translates assembly language program into machine language program.
6. Differentiate between compiler and interpreter.
7. DBMS stands for ________.
8. Give two examples for customised software.
9. Duplicating disk information is called ________.
**GIMP:** It stands for GNU Image Manipulation Program. It is an image editing software. It can be used for retouching photographs, creating and editing images. It supports graphic files of different formats and allows converting from one format to another.

**Mozilla Firefox:** It is one of the most popular web browsers created by the Mozilla Corporation. It provides added security features for safe browsing.

**OpenOffice.org:** It is a complete office suite that contains word processor (Writer) to prepare and format documents, spreadsheets (Calc) and presentations (Impress). It works on both Linux and Windows platforms.

### 2.6 Freeware and shareware

Freeware refers to copyrighted computer software which is made available for use free of charge for an unlimited period.

The term shareware refers to commercial software that is distributed on a trial basis. It is distributed without payment and with limited functionality. Shareware is commonly offered in a downloadable format on the Internet. The distribution of this kind of software aims at giving the users a chance to analyse the software before purchasing it. Some shareware works for a limited period of time only.

Table 2.6 highlights a comparison between freeware and shareware:

<table>
<thead>
<tr>
<th>Freeware</th>
<th>Shareware</th>
</tr>
</thead>
<tbody>
<tr>
<td>Freeware refers to software that anyone can download from the Internet and use for free.</td>
<td>Sharewares give users a chance to try the software before buying it.</td>
</tr>
<tr>
<td>All the features are free.</td>
<td>All features are not available.</td>
</tr>
<tr>
<td></td>
<td>To use all the features of the software, user has to purchase it.</td>
</tr>
<tr>
<td>Freeware programs can be distributed free of cost.</td>
<td>Shareware may or may not be distributed freely. In many cases, author's permission is needed to distribute the shareware.</td>
</tr>
</tbody>
</table>

**Table 2.6 : Comparison of freeware and shareware**

1. **Conduct a debate on free software and proprietary software**
2. **Discuss four freedoms which make up a free software.**
2.7 Proprietary software

Proprietary software is a computer program that is an exclusive property of its developer or publisher and cannot be copied or distributed without licensing agreements. It is sold without any access to source code and is therefore not possible to change or improve by the user. Some examples of proprietary software are Microsoft Windows Operating System, MS Office, Mac OS, etc.

2.8 Humanware or Liveware

Humanware or liveware refers to humans who use computer. It was used in computer industry as early as 1966 to refer to computer users, often in humorous contexts by analogy with software and hardware. It refers to programmers, systems analysts, operating staff and other personnel working in a computer system (refer Table 2.7).

<table>
<thead>
<tr>
<th>Humanware</th>
<th>Job Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Administrators</td>
<td>Upkeep, configuration and reliable operation of computer systems; especially multi-user computers such as servers.</td>
</tr>
<tr>
<td>Systems Managers</td>
<td>Ensure optimal level of customer services and maintain expertise in all business unit systems and develop professional relationships with all vendors and contractors.</td>
</tr>
<tr>
<td>System Analysts</td>
<td>Design new IT solutions to improve business efficiency and productivity.</td>
</tr>
<tr>
<td>Database Administrators</td>
<td>Create, monitor, analyse and implement database solutions.</td>
</tr>
<tr>
<td>Computer Engineers</td>
<td>Design either the hardware or software of a computer system.</td>
</tr>
<tr>
<td>Computer Programmers</td>
<td>Write the code that computers read in order to operate properly.</td>
</tr>
<tr>
<td>Computer Operators</td>
<td>Oversee the running of computer systems, ensuring that the machines are running, physically secured and free of any bugs.</td>
</tr>
</tbody>
</table>

Table 2.7: Examples of humanware
Check yourself

1. An example of free and open source software is ______.
2. The software that gives users a chance to try it before buying is ______.
3. What do you mean by free and open source software?
4. Write an example of proprietary software.
5. Give two examples of human-ware.

Let us sum up

A computer system consists of hardware and software. Hardware refers to the visible and tangible parts of computer. Processor, motherboard, peripheral and ports, memory devices, input/output devices, etc. belong to hardware components of computer. Memory is classified into primary and secondary memories. Primary storage consists of RAM, ROM and cache. Secondary storage devices are further classified into magnetic storage, optical storage and semi-conductor storage devices. There are variety of input devices which include keyboard, mouse, light pen, touch screen, graphic tablet, touchpad, joystick, microphone, scanner, OMR, barcode reader, biometric sensor, smart card reader, digital camera, etc. Similarly, there are output devices like visual display units, printers, plotters, audio output devices, etc. The used electronics which are destined for reuse, resale, salvage, recycling or disposal are considered as e-Waste. There are different methods for e-Waste disposal which include re-use, incineration, recycling, land filling, etc. Green computing is the study and practice of environmentally sustainable computing or IT.

Software refers to the intangible or invisible part of the computer which is a set of programs that help us to use computer system and other electronic devices efficiently and effectively. Software is classified into system software and application software. System software include operating system, language processors and utility software. Application software is further divided into general purpose software and specific purpose software. Free and open source software are available which give freedom to use, copy, distribute, examine, change and improve the software. The term freeware refers to software that can be downloaded from the Internet and use for free. Shareware gives users a chance to try the software before buying it. There is one more component associated with computer, the humanware. It refers to humans who use computer at various level.
Learning outcomes

After the completion of this chapter the learner will be able to
• explain the basic organisation of computer system.
• list the use of different types of input and output devices.
• distinguish between system software and application software.
• identify the importance of e-Waste disposal.
• identify the importance of green computing concept.
• classify the different types of software.
• list the functions of operating system.
• use word processor, electronic spreadsheets and presentation software.
• classify the different types of computer languages.
• list the uses of different types of utility software.
• promote open source software.
• explain the term humanware or liveware.

Sample questions

Very short answer type

1. What are the components of a digital computer?
2. Write the main functions of central processing unit.
3. What are the different types of main memory?
4. What is the advantage of EEPROM over EPROM?
5. When do we use ROM?
6. What is an input device? List few commonly used input devices.
7. What do you mean by an output device? List few commonly used output devices.
8. What is a storage device? List few commonly used storage devices.
9. What is the role of ALU?
10. What is a control unit?
11. What are registers? Write and explain any two of them.
12. Differentiate between hard copy and soft copy.
13. What is e-Waste?
14. What is operating system?
15. What is a language processor?
16. Mention the categories of computer languages.
17. What is disk defragmenter?
18. What is proprietary software?
19. What do you mean by open source software?

**Short answer type**

1. Briefly explain any three input devices.
2. Compare CRT with LED monitor.
3. Differentiate RAM and ROM.
4. List and explain e-Waste disposal methods.
5. Enumerate the steps that can be taken for the implementation of green computing philosophy.
6. What do you mean by customized software? Give examples.
7. Distinguish between low level and high level languages.
8. Differentiate compiler and interpreter.
9. Describe the use of electronic spreadsheets.
10. What is utility software? Give two examples.
11. Categorise the software given below into operating system, application packages and utility programs.
   - Linux, Tally, WinZip, MS-Word, Windows, MS-Excel
12. Differentiate between freeware and shareware.
13. What are the four freedoms which make up free and open source software?
14. What do you mean by humanware? Give any two examples.
**Long answer type**

1. Describe in detail the various units of the Central Processing Unit.

2. Briefly explain various types of memory.

3. Explain the classification of printers.

4. "e-Waste is hazardous to our health and environment." Justify the statement. List and explain the methods commonly used for e-Waste disposal.

5. Define the term green computing. List and explain the approaches that you can adopt to promote green computing concepts at all possible levels.

6. List and explain various categories of software.

7. Describe the use of various utility softwares.

8. Define the term 'operating system'. List and explain the major functions of operating system.

9. List and explain general purpose application software with examples.
With the advent of the computer and related technologies, data processing has become simple, accurate, interesting and fast. There are many software tools for handling character and numeric data. The software package for processing numbers and characters in tabular form is generally known as electronic spreadsheet. In this chapter we discuss the basic concepts of an electronic spreadsheet which will be hereafter referred as spreadsheet. Here we use different formulae for various calculations, present the data in a well formatted manner and print the document. The different ways of cell referencing are also discussed here.

3.1 Spreadsheet software

A spreadsheet is an electronic document in which data is arranged in rows and columns in the form of a table. The data stored in the spreadsheet can be manipulated and used in calculations as required. The problem with manual spreadsheets is that if any error is found within the data, all the answers must be erased and recalculated manually. In the case of an electronic spreadsheet, formulae will automatically update the results whenever data is changed. This also helps to answer 'What If' questions, i.e., what will happen to the result if the value of a data is changed? People in business often use this feature of spreadsheet for carrying out business forecasting.
An electronic spreadsheet allows operations like entering, editing, formatting, calculating, sorting, filtering, charting and analysing alpha numeric data. They are used for preparing financial documents, reports, processing information from scientific researches, statistical analysis, etc. Lotus 1-2-3, Quattro Pro, Microsoft Excel, Open Office Calc, etc. are well known examples of spreadsheet packages.

The following are the major features of an electronic spreadsheet:

- stores large volume of data in tabular form like marklists, financial statements from a company, attendance sheet in a class, etc.
- carries out numeric calculations, comparisons and analysis using formulae and functions.
- automatically updates results, if any change is made in the related data.
- provides text formatting features like alignment, borders, merge cells, font setting, etc. and produce formatted reports/documents.
- offers facilities like sorting, filtering, etc.
- creates charts for graphical data analysis.

In this chapter we discuss the features of electronic spreadsheet based on Open Office Calc in detail.

### 3.2 Spreadsheet basics

Electronic spreadsheet allows users to work with spreadsheets. A spreadsheet can contain one or more worksheets. By default, there will be three worksheets in a spreadsheet named **Sheet1**, **Sheet2** and **Sheet3**. Each sheet consists of many rows and columns. We can insert more sheets into a spreadsheet if required.
Let us see how a worksheet looks like.

3.2.1 Rows and columns

A worksheet is organised in rows and columns. We can see a number of rows and columns in the above worksheet as shown in Figure 3.1. At the top of all the rows there is a grey coloured row called the column header and at the left end of all the columns there is a grey coloured column called the row header. The column header displays the column names A, B, C, ..., Z, AA, AB, ...., etc. and row header displays the numbers 1, 2, 3, ..., etc. The total number of rows and columns of the spreadsheet will be different in different versions of the spreadsheet package.

3.2.2 Cell

Cell is the intersection of a column and a row. It is the smallest unit of the worksheet where data and formula can be placed. Each cell has a unique address. It is referred by the combination of the column name and the row number. For instance, the cell address A5 means; the intersection of column A and row 5.

In Figure 3.1, D8 is the currently active cell where the cell pointer points to. Cell pointer is the dark cell-boundary which can be moved anywhere in the worksheet. It is the cell where the next entry would take place.
3.2.3 Range

Range is a group of adjacent cells that form a rectangular area. A range may contain just a single cell, or many cells. A range is specified by the addresses of the first cell in the range and the last cell in the range. For instance, a range starting from B3 to E10 (Figure 3.2) is written as B3: E10, where ':' is the range indicator. The smallest range is a single cell and the largest range is the entire worksheet.

![Fig. 3.2 : Range of cells](image)

3.3 Components of a spreadsheet window

The main components of a spreadsheet window are Menu bar, Toolbars, Formula bar, Sheet tab and Status bar as shown in Figure 3.3. Let us discuss these components.

3.3.1 Menu bar

Menu bar contains pull down menu options like File, Edit, View, Insert, Format, Tools, Data, Window and Help. Each contains various options to perform operations on spreadsheet.

File menu contains menu options that apply to the entire spreadsheet like Open, Save, Export, Print, etc. Edit menu consists of features like Cut, Copy, Paste, Find, Replace, Undo, etc. View menu contains options for displaying toolbars, viewing full screen, etc.
### 3. Data Processing with Electronic Spreadsheet

#### 3.3 Format menu

The Format menu consists of command for formatting cells, columns, rows, sheets, etc.

#### 3.3.2 Toolbars

Toolbars contain icons or short-cut buttons for commonly used menu commands. The two important Toolbars are Standard toolbar and Formatting toolbar. A Standard toolbar consists of icons for saving, opening existing spreadsheets, creating new spreadsheets, cut, copy, paste, print, etc. Formatting toolbar contains icons and listboxes for formatting spreadsheet like changing font, style, size, alignments, etc.

#### 3.3.3 Formula bar

Formula bar consists of Name Box, Function Wizard, Sum Button, Function Button and Input line. On the leftmost side of the formula bar is a small text box called Name Box. It displays the address of the current cell. When a range of cells is selected, the name box displays the range. The Function Wizard button opens a dialog box consisting of the built-in function available in spreadsheet. The Sum button \( \sum \) is used to calculate and display the sum. Clicking the function button inserts an '=' sign in the Input line, that allows the user to enter a formula. Input line displays the contents of the current cell. If the cell contains a formula, it displays the formula, not the resultant value.
3.3.4 Sheet tab

Sheet tab shows the worksheets available in the spreadsheet. We can use Sheet tab option to switch from one sheet to another. It provides an easy way to copy, move, delete, insert and rename the sheets.

3.3.5 Status bar

The Status bar is an area where the current status about the worksheet is displayed. For example, the result of certain operations like sum, average, etc. of a selected range will be displayed here.

Check yourself

1. In a worksheet, ________ is formed when a row meets a column.
2. A worksheet file with one or more sheets is called ________.
3. In a worksheet, D10: H25 is called a ________.
4. The cell having a bold boundary is the ________ cell.
   a. first   b. last   c. current   d. next
5. The user can move from one sheet to another in a worksheet is done using ________ of spreadsheet window.
6. ________ shows the address of the current cell.
7. The short-cut buttons of important commands are present in ________.

3.4 Entering data in a worksheet

We can enter different types of data like numbers, text, date and time or formula in a worksheet. To enter data in a cell, place cell pointer in the desired cell, and then type the data.

To edit the contents of a selected cell, press the function key, F2 or double click in the cell. Editing can also be done by clicking and typing in the Input line box in the Formula bar.
The following are the different types of data that can be entered in a cell.

**a. Numbers**

Worksheets are mainly used for entering and manipulating numeric data. By default, numbers are right aligned as shown in Figure 3.4. To enter a negative number either type a minus (-) sign to the left of it or enclose it in parenthesis. Examples of numbers are 35, 225.75, -50, (105.5).

**b. Text**

Texts are alphanumeric data entered in a worksheet. By default, text is left-aligned in a cell. To enter a number as text, put a single quote (‘) to the left side of the number.

**c. Date and Time**

Spreadsheet recognises a variety of date and time formats. The date elements can be separated using a slash (/) or hyphen (-). Time elements can be separated using colon (:). Some examples are 12/01/2014, 10:00:00 AM.

**d. Formula**

A formula is an equation that begins with an equal (=) sign. The cell containing a formula displays the resultant value of the formula. A formula can be used to show a relationship between cells. It can contain operators. The commonly used operators are +, -, *, / and ^ (exponentiation). A formula can also contain functions. We will discuss about functions in the next chapter. For example, a formula that calculates the sum of the values of the cells A1 and B1, is written as \(= A1 + B1\).
3.5 Working with formula

Let us consider the salary details of the employees of a company ABC Ltd. The salary details consists of Employee number, Name of the employee, Designation, Basic Pay, Dearness Allowance (DA), Provident Fund deduction and Net Salary as shown in Figure 3.5.

![Fig. 3.5 : Salary details of ABC Ltd.](image)

Let us calculate DA and Net Salary of each employee. DA is calculated as 40% of the Basic Pay. Net Salary can be calculated using the formula

Net Salary = Basic Pay + DA - PF

The DA of the first employee is to be calculated and displayed in the cell E3. For this place the cell pointer in cell E3 and enter the formula \(=D3 \times 40/100\) as shown in Figure 3.6. The cell D3 contains the Basic Pay of the first employee. The formula for calculating DA can also be calculated as \(=D3 \times 40\%\).

![Fig. 3.6 : Formula for calculating DA](image)

After pressing the Enter key, the result of the formula is displayed in the cell E3. Now we need to find the DA of other employees. This can be done by copying the formula to other cells in the column E. For this, select the cell E3 and move the mouse pointer to the right bottom corner of the cell. Note that the mouse pointer turns to a thin + symbol. Click and drag downwards to copy the formula to other cells. The result is displayed as in the Figure 3.7.
Now, to calculate the Net Salary, use the formula \( =D3+E3-F3 \) in cell G3 and then copy the formula to the cells below. The result is displayed as in Figure 3.8. Note that the cell contains the result of the formula and the **Input line** in the Formula bar displays the formula as in Figures 3.7 and 3.8.

**3.6 Saving a spreadsheet**

Spreadsheets can be saved using the **Save** option from the **File** menu (File \( \rightarrow \) Save). We can also save using the **Save** button on the Standard toolbar or by pressing **Ctrl+S** keys on the keyboard. In the **Save As** dialog box that appears, choose a folder, enter a file name and then click the **Save** button. The file is saved with the extension .ods. The file extension for the file may differ with package and version. For example, Microsoft Excel uses .xls or .xlsx as extension.

Once the file is saved, selecting the save option again will update the same file. If you need to save the file with a new name, choose the **Save As** option in the **File** menu (File \( \rightarrow \) Save As).

**3.7 Closing and opening spreadsheets**

After finishing the work with the current spreadsheet, we can close it using the **Close** option in the **File** menu (File \( \rightarrow \) Close). If changes are made to the spreadsheet after the last save, the spreadsheet prompts a dialog box as to whether to save the changes.
or not. Note that closing a spreadsheet does not exit the spreadsheet application. To exit a spreadsheet application use File → Exit.

To open an existing spreadsheet, choose File → Open. In the Open dialog box that appears select the file and click Open.

Let us do

The loan details of customers in a finance company are shown in the table. Use these details to find the interest payable. The interest is calculated using the formula Loan Amount × Number of Years × Rate of Interest. Interest is calculated at the rate of 12%.

<table>
<thead>
<tr>
<th>Loan No.</th>
<th>Name</th>
<th>Loan Amount</th>
<th>Years</th>
<th>Interest Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>L301</td>
<td>Rohith</td>
<td>60000</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>L302</td>
<td>Krishna</td>
<td>80000</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>L303</td>
<td>Anoop</td>
<td>10000</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>L304</td>
<td>Bipin</td>
<td>90000</td>
<td>3</td>
<td></td>
</tr>
</tbody>
</table>

3.8 Formatting a spreadsheet

The general appearance and arrangement of data in a spreadsheet is known as formatting. Formatting makes the worksheet attractive. Formatting mainly focuses on numbers, text (font, font size, font colour) and setting alignment, borders and background. The data in a spreadsheet can be formatted in several ways.

3.8.1 Formatting cells

The cell formatting options are available in the Cells menu item of the Format menu (Format → Cells…). It displays a Format Cells dialog box as shown in Figure 3.9. Numbers, font, font effects, alignment, borders, background, etc. can be formatted using Format Cells dialog box. The general appearance and arrangement of data in a cell or a range of cells is known as cell formatting. In the following section we will discuss the different cell formatting features.

a. Formatting numbers

The number formats can be applied to data in the cells using the Numbers tab of the Format Cells dialog box. The appearance of numbers in a cell can be changed as Percentage, Currency, Date, Time, Scientific, etc. The number of decimal places, leading zeros, thousands separator, etc. can also be specified using this option. Note
3. Data Processing with Electronic Spreadsheet

Fig. 3.9: Format Cells dialog box

that the value in the cell is not affected while formatting.

**b. Formatting font**

Font tab of Format Cells dialog box is used to change the font face, size and style (bold, italics) of a cell or a range of cells. Effects like font colour, underline, overline, strike through and shadow can be specified using the Font Effects tab. Some of these options are also available in the Formatting toolbar.

c. **Aligning cell content**

The contents in a cell can be aligned both horizontally and vertically using the Alignment tab of Format Cells dialog box. Indentation can be specified to the text inside a cell. The orientation of the text inside a cell can be mentioned.

d. **Setting borders**

The Borders tab is used to set the borders, its style and colour. The spacing of text from the border can also be specified. A shadow can be given to cells using the Shadow Style option in the Borders tab.

e. **Setting background colour**

A background colour can be given to a cell using the Background tab. A colour set can be removed by selecting the No Fill option in this tab.

The salary details spreadsheet of ABC Ltd. can be given cell formatting to appear as in Figure 3.10.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>ABC Limited</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Emp No</td>
<td>Name</td>
<td>Designation</td>
<td>Basic Pay</td>
<td>DA</td>
<td>PF</td>
<td>Net Salary</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>E101</td>
<td>Rajiv R</td>
<td>Manager</td>
<td>15000</td>
<td>6000</td>
<td>1200</td>
<td>19800</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>E102</td>
<td>Sharma C</td>
<td>Salesman</td>
<td>7500</td>
<td>3000</td>
<td>700</td>
<td>9800</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>E103</td>
<td>Divya S</td>
<td>Clerk</td>
<td>8000</td>
<td>3200</td>
<td>700</td>
<td>10500</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>E104</td>
<td>Jose P</td>
<td>Salesman</td>
<td>7000</td>
<td>2800</td>
<td>600</td>
<td>8200</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>E105</td>
<td>Rahim K P</td>
<td>Salesman</td>
<td>6500</td>
<td>2600</td>
<td>500</td>
<td>8600</td>
<td></td>
</tr>
</tbody>
</table>

Fig. 3.10: Salary Bill of ABC Ltd. after cell formatting
3.8.2 Formatting columns

Column formatting features are available in the **Column** option of the **Format** menu (**Format** → **Column**). The different options in the **Column** submenu helps to set the column width, optimal column width, hide or show columns.

To set the width of a column, select the required column and choose **Width** option from the **Column** submenu. Enter the required width in the dialog box that appears. The **Optimal Width** option is used to resize the width of the column to the minimum required width that suits the contents of the selected cell. The value given in the **Add** box of **Optimal Column Width** dialog box shown in Figure 3.11 adds the specified value to this minimum width for the column. Note that by double clicking on the right border of the column header, the column can be resized to fit the longest entry in the column.

We can hide a column by first selecting a cell in the column to be hidden and then use the menu item **Format** → **Column** → **Hide**. The column will be hidden on the screen, but the data in the column will be used for the calculations in the sheet. Column hiding is generally used before printing. We can verify whether columns are hidden by checking the column header names. A hidden column can be made visible by selecting the adjacent columns and then use the menu item **Format** → **Column** → **Show**.

3.8.3 Formatting rows

The row formatting options are available in the **Format** → **Row** menu. The height of a row or the optimal height of the row can be set using this feature. Options for hiding or displaying are also available here.

To set the height of a row, select the menu option **Format** → **Row** → **Height**. The **Optimal Height**, i.e., the minimum height required for the selected row can be set using **Format** → **Row** → **Optimal Height** menu option. To hide a row, select a cell in the row and then choose menu item **Format** → **Row** → **Hide**. Hidden rows can be identified by verifying the row header names. To make hidden rows visible, select the rows above and below the hidden row and then use the menu option **Format** → **Row** → **Show**.
3.8.4 Formatting sheets

By default, a spreadsheet consists of three worksheets named Sheet1, Sheet2 and Sheet3. A worksheet can be renamed using the menu option Format → Sheet → Rename. This displays a dialog box that prompts the user to enter a new name for the selected sheet. Renaming can also be done by clicking the right mouse button on the sheet name and selecting Rename option from the menu that appears. A sheet can be hidden by selecting the menu item Format → Sheet → Hide. This hides the currently selected sheet. To view the hidden sheets, use the menu option Format → Sheet → Show. The hidden sheets will be displayed in Show Sheet dialog box as shown in Figure 3.12. Select the sheet to be displayed and click OK.

3.8.5 Merge cells

Combining multiple cells into one cell is called merging of cells. Merging is often used when a title is to be centered over a particular section of a spreadsheet. When a group of adjacent cells are merged, only the text in the upper-leftmost box is displayed in the merged cell. The data in the other cells will be lost. The merged cell will have the address of the upper-leftmost cell. Select the cells to be merged and use the Merge Cells option from Format menu (Format → Merge Cells). We can also use the Merge Cell button in the Format toolbar. In our example, we will merge the cells A1:G1. To move the heading to the centre of the salary statement use the Alignment tab of Format Cells dialog box. The result is as shown in Figure 3.13.
Prepare a neatly formatted timetable of your class. Format the cells with proper font type, size and colour (different colour for different subjects). The first row should display the class name in merged form.

Let us do

Check yourself...

1. The function key used to edit the contents of a cell is ________
2. The symbol used in spreadsheet for exponentiation is ________
3. What do you mean by optimal width of a column?
4. How can you hide a worksheet in a spreadsheet?
5. What is merging of cells?
6. Another way to enter the number -55 in a cell is ________

3.9 Inserting cells, rows, columns and worksheets

We can insert cells, rows or columns in a specified position of a worksheet. This feature is often needed while working with spreadsheet. After insertion the column names and row numbers are automatically rearranged. The cell addresses referred in the existing formulae are adjusted accordingly.

a. Inserting cell

We can insert blank cells above or to the left of the active cell on a worksheet. This will shift the cells below in the same column downwards or in the same row to the right. We can also insert rows above and columns to the left of the active cell on a worksheet. To insert a cell, use the Cells… option from the Insert menu (Insert → Cells …). Note that if more than one cell is selected, it will insert the same number of cells selected.

Consider the worksheet given in Figure 3.14. Let us now insert a cell in the position B4. Select B4 and choose Cells from the Insert menu. In the Insert Cells dialog box, choose the option Shift cells down. The result is displayed as in the Figure 3.15.
b. Inserting row

To insert a single row, select the row or a cell in the row above where a new row is to be inserted. For example, to insert a new row above row 4, click a cell in row 4. To insert multiple rows, select the same number of rows above where the rows are to be inserted. Rows can be inserted using the Rows option of Insert menu (Insert → Rows).

c. Inserting column

To insert a single column, select the column or a cell in the column immediately to the right of the new column to be inserted. For example, to insert a new column to the left of column B, click a cell in column B. To insert multiple columns, select the same number of columns immediately to the right of the new columns to be inserted. For example, to insert three new columns, select three columns. Columns can be inserted using the Columns option of Insert menu (Insert → Columns). We can also right click the column name and choose Column option from the popup menu.

Let us insert a new column Gross Salary in our Salary Bill example before the PF column. Select the column F, choose Column option from the Insert menu and type 'Gross' as the column heading. The worksheet will now appear as in Figure 3.16. Gross Salary is the sum of Basic Pay and DA. Type the formula for calculating Gross Salary =D3+E3 in the cell F3 and copy it to the cells below.

![Fig. 3.14 : Insert Cells dialog box](image1)

![Fig. 3.15 : Worksheet after cell insertion](image2)

![Fig. 3.16 : Pay Bill after inserting a new column](image3)
d. Inserting a worksheet

A worksheet can be added to a spreadsheet using the menu item Sheet ... from the Insert menu. To insert a sheet, select the sheet before or after which the new sheet or sheets are to be inserted from the Sheets tab. Choose Insert → Sheet... It will display the Insert Sheet dialog box as in Figure 3.17. We can specify the position of the sheet, number of sheets, name of sheet, etc. in this dialog box.

![Insert Sheet dialog box](image)

3.10 Deleting cells, rows, columns and worksheets

Spreadsheet provides us the facility to delete the desired number of cells, rows, columns or worksheets. Select the cell, row or column to be deleted. Choose Delete Cells ... option from Edit menu (Edit → Delete Cells...). If cells are selected the Delete Cells dialog box as shown in Figure 3.18 appears. The dialog box displays options to Shift cells up, Shift cells left, Delete entire row(s) and Delete entire column(s). Choose an option and click OK.

![Delete Cells dialog box](image)

If a range of cells are to be deleted, select from the options Shift cells up or Shift cells left in the Delete Cells dialog box based on requirement.

If the entire row or multiple rows are selected by clicking the row headers, the Delete
Cells option of the Edit menu will delete the entire rows. Similarly if entire column or columns are selected, the Delete Cells option will delete the entire columns. Note that Delete Cells dialog box will not be displayed in these cases.

It is possible to remove a worksheet permanently from the workbook. From the Edit menu, select Delete option from the Sheet sub menu (Edit → Sheet → Delete). This will prompt a confirmation dialog box for deleting the selected sheet.

3.11 Editing features in spreadsheets

Spreadsheets provide various editing features to fill a range with a value or a series of values, copy or move a cell or range of cells, delete the contents of cells, etc. These easy to use features enhance the usage of various data manipulation operations in a spreadsheet.

3.11.1 Filling a range

A range of cells can be filled with a value or a series. To fill a range of cells with the same value, enter the value in a cell and select the range of cells in which the values are to be filled. Select the menu item Fill from Edit menu and choose the appropriate direction.

To fill a range of cells with a series of values, type the starting value and then select the range of cells to be filled. Choose the Edit → Fill → Series option. A dialog box as in Figure 3.19 appears. This dialog box allows to set direction, series type, start value, end value and increment value. Choose the appropriate option and click OK.

Fig. 3.19 : Fill Series dialog box

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>01/01/2014 Friday</td>
<td>A</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>2</td>
<td>01/01/2014 Sunday</td>
<td>B</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>4</td>
<td>05/01/2014 Tuesday</td>
<td>C</td>
</tr>
<tr>
<td>4</td>
<td>4</td>
<td>8</td>
<td>07/01/2014 Wednesday</td>
<td>D</td>
</tr>
<tr>
<td>5</td>
<td>5</td>
<td>16</td>
<td>09/01/2014 Thursday</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>6</td>
<td>32</td>
<td>11/01/2014 Friday</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>7</td>
<td>64</td>
<td>13/01/2014 Saturday</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>8</td>
<td>128</td>
<td>15/01/2014 Sunday</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>9</td>
<td>256</td>
<td>17/01/2014 Monday</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>10</td>
<td>512</td>
<td>19/01/2014 Tuesday</td>
<td></td>
</tr>
</tbody>
</table>

Fig. 3.20 : Filling Series examples
A shortcut way to fill cells is to click on the Fill Handle in the lower right hand corner of the cell and drag it in the direction to be filled. If the cell contains a number, the number will fill in series. If the cell contains a text, the same text will fill in the direction you choose (Figure 3.20).

### 3.11.2 Copying and moving cells

The contents of a cell or a range of cells can be copied to another cell in the worksheet. For this, select the range and then choose **Copy** from the **Edit** menu. The contents of the cell are copied to the special memory area called clipboard of the operating system. Select the destination cell and choose **Paste** option from **Edit** menu. The contents are pasted to the new location from the clipboard. The **Paste Special** option in the **Edit** menu given in Figure 3.21 allows advanced paste options. Formulae, text, numbers, formatting, etc. can be selectively copied using this feature.

The contents of a cell or a range of cells can be moved to another cell in the worksheet. For this, select the range and then choose **Cut** option from the **Edit** menu. Select the cell to which the contents are to be moved and choose **Paste** option from the **Edit** menu. Here also the contents are copied to the clipboard and then moved to the new location. The contents can also be moved by dragging the selected cells.

### 3.11.3 Deleting cell contents

The contents of a cell can be deleted using the menu option **Delete Contents…** from the **Edit** menu (Edit → Delete Contents…) or using

---

**Fig. 3.21 : Paste Special dialog box**

**Fig. 3.22 : Delete Contents dialog box**
Delete key on the keyboard. This displays a **Delete Contents** dialog box as shown in Figure 3.22. Using this option the text, numbers, formula, formats, etc. can be deleted in the selected range. The **Delete all** option deletes the entire content of the cells within the selected range.

### 3.12 Freezing rows and columns in a worksheet

Freezing locks a specified number of rows at the top of a spreadsheet or a specified number of columns on the left of a spreadsheet or both. While scrolling inside the sheet, the frozen columns and rows always remain in view. Freezing is the act of making a selected set of columns or rows immovable while scrolling the worksheet. To freeze rows, click on the row header below the rows to be frozen. Select **Freeze** option from **Window** menu (Window → Freeze). Similarly, to freeze columns, click on the column header to the right of the columns to be frozen and select the **Freeze** option from the menu. After freezing rows 1 and 2, the Pay Bill worksheet will appear as in Figure 3.23 when scrolled 2 rows down. Note that in the figure, rows 3 and 4 have moved up and rows 1 and 2 remain frozen as we have scrolled down.

![Fig 3.23 : Pay Bill after freezing rows 1 and 2](image)

#### Check yourself

1. How do you insert a cell in a worksheet?
2. What are the two methods of moving a range in a worksheet?
3. The act of making a column or row immovable is referred ________.
4. How can you fill the same value in a range of cells?
5. What is the difference between deleting a cell and deleting cell contents?
3.13 Cell referencing

Every cell in a spreadsheet has a cell reference which acts as an address of the cell. These references can be used in formulae to perform various calculations. When the data in a cell which is referenced elsewhere is changed, the formula which contains the reference will be recalculated to reflect the change.

When a cell is referenced in a formula, the reference (cell address) can either be typed in the formula or the mouse can be used to click on the cell to create a reference to it. Any cell reference entered in a formula will be colour coded. The formula will show different colours for different references and the cells will be outlined with the same colour used in the formula as shown in Figure 3.24.

In Figure 3.24, the formula for calculating Net Salary, = D3 + E3 - G3 is in the cell H3. Note that the cells D3, E3 and G3 are outlined with the same colour as that of the reference in the formula. The two different types of references are relative and absolute. They behave differently when copied or filled to other cells.

3.13.1 Relative cell references

Most of the references in a spreadsheet are relative. Relative cell references are cell references that adjust and change when copied or used with AutoFill feature. In relative referencing, the cell addresses get adjusted automatically with reference to the current cell during copying of the formula.

In Figure 3.25, the formula for calculating Net Salary, = D4 + E4 - G4 is in the cell H4.
In relative references, cell references will move to be in the same positions relative to the new cell. Consider the Figure 3.24. When the Net Salary in cell H3 is copied to cell H4, the references in the formula changes as $= D4 + E4 - G4$ as in Figure 3.25. This is because D3, E3 and G3 are relative references and they move to the same relative positions in the next row namely, D4, E4 and G4. Relative references are convenient when the same calculation is to be repeated across multiple rows or columns.

### 3.13.2 Absolute cell references

Sometimes you do not want references to change when you copy a formula to a different cell. In such cases you can go for absolute referencing. Absolute references remain constant, no matter where they are copied. To make a reference absolute, put a Dollar ($) sign before both the row and column parts of the reference. To make an absolute reference to cell A3, use $A$3 in the formula.

In our Salary Bill example, we calculated DA as 40% of the Basic Pay. Percentage of DA of employees varies periodically. Each time a change occurs, we need to change the formula of DA and drag and copy it to other cells. To avoid this, we can store the percentage of DA in cell D2 as in Figure 3.26. All the cells in the DA column have to refer to the cell D2 irrespective of the position of the cells to calculate the DA. This can be done by making the cell D2 as absolute ($D$2) in the formula. Now the formula for calculating DA is $= D4 * D2 / 100$ as shown in Figure 3.26.
Now drag the formula in the cell E3 to the cells below. Note that the cell reference $D$2 remains the same in all the copied cells. Now the Salary Bill appears as in Figure 3.27. When the percentage of DA changes, the cell D2 needs to be updated and the calculated DA of all employees changes automatically.

### 3.14 Page formatting and printing a worksheet

After creating a worksheet, we may require its hard copy. Before printing a worksheet we need to format the worksheet. Various print formatting features allow to select the paper size, set margins, print range, etc. The **Print Preview** option in the **File** menu displays how the page appears in the printout. We will discuss the different print formatting features of a spreadsheet.

#### 3.14.1 Print ranges

Print ranges allow to print only a specific part of the data or selected rows or columns on pages. To define a print range or modify an existing print range, select the range of cells to be printed and then choose **Format** → **Print Ranges** → **Define**. The **Print Preview** will display only the defined range. A defined print range can be removed by using the option **Format** → **Print Range** → **Remove**. This removes all the defined print ranges on the sheet.

If a sheet is printed on multiple pages, we can setup certain rows or columns to repeat on each printed page. Consider the Salary Bill of ABC Ltd. as shown in Figure 3.27. If this worksheet consisted of salary details of many employees, it has to be printed in many pages. It would be better if the first three rows are repeated on each page. This can be done using the option **Format** → **Print Range** → **Edit**. To select the rows or columns to repeat, use the **Shrink** button against each option in the **Edit Print Ranges** dialog box that appears. Select the rows or columns to repeat using the cursor and then press the button again. Figure 3.28 displays the **Edit Print Ranges** dialog box.

![Edit Print Ranges dialog box](image)
3.14.2 Headers and footers

Headers are text appearing on the top of every page in a document. Footers are text appearing at the bottom of each page. The text can be page numbers, name of the document, date/time of creation of the document, author name, etc. They are useful when the document is printed. Headers and footers can be given to a spreadsheet using the Headers & Footers... option of the Edit menu (Edit → Headers & Footers...). A Header/Footer dialog box appears as in Figure 3.29. The headers and footers can be chosen from the list of predefined items like, page number, author, etc. or customised according to users requirements.

![Header/Footer dialog box](image)

**Fig 3.29 : Header/Footer dialog box**

3.14.3 Page breaks

If the contents of a worksheet are lengthy, the spreadsheet software automatically inserts page breaks depending on the paper size while printing. Page breaks can be inserted manually in a worksheet to ensure proper page organisation. A row page break inserts a break above the active cell and a column page break inserts a page break to the left of the active cell. Row page break is available at Insert → Manual Break → Row Break and column page break is available at Insert → Manual Break → Column Break.

To remove a manual page break, select the cell below the row break or the cell to the right of the column break. Now choose Edit → Delete Manual Break → Row Break or Edit → Delete Manual Break → Column Break.
3.14.4 Page style setting

The paper size / format, page orientation and margins can be set using this option. The paper sizes can be A4, Legal, Letter, etc. or customised according to users need. The page orientation can be portrait or landscape. The margins can be adjusted manually. Page styles can be set using the Format → Page... menu option. Figure 3.30 displays the Page Style dialog box.

3.14.5 Printing a spreadsheet

The Print option of File menu can be used to print a spreadsheet. We can select the printer in which the spreadsheet is to be printed, the range to be printed, the number of copies, the pages to be printed, etc. using the General tab of the Print dialog box as shown in Figure 3.31. The Page Layout tab of Print dialog box allows to select the number of pages to be printed on each sheet and the order in which the pages are to be printed. A preview of the page is also available in this dialog box.

3.14.6 Export as PDF

Calc can export documents to PDF (Portable Document Format), which allows the file to be viewed on any platform. PDF is a popular format for transferring files to others. Note that once a sheet is converted to PDF format, it is not easily editable. A worksheet can be exported to the PDF format using the menu option File → Export as PDF... In the PDF Options dialog box shown in Figure 3.32, the range of pages to be converted to PDF, the quality of the images, etc. can be specified.
Check yourself

1. What is a cell reference?
2. What do you mean by header and footer in a spreadsheet?
3. What is a print range?
4. How can you insert a manual page break?
5. What is the advantage of exporting a worksheet to PDF format?

Let us sum up

We have now discussed the various operations that can be performed with the help of spreadsheet package. The different components of the spreadsheet window and its uses have been familiarised. It is an excellent tool for storing huge volume of data (text, numbers, date and time, formula). The data entered in a cell can be formatted, formulae can be inserted and many calculations can be done easily. The data in the cells can be formatted using different font styles, sizes, colours, borders, etc. The appearance of the different types of data, the width and height of columns and rows can be set. The cells in the worksheet can be merged using the merge feature. A
range can be selected, copied or moved to other locations. Cells, rows, columns or worksheets can be inserted or deleted based on requirements. A range of cells can be filled with values using the Fill Series option in the spreadsheet. Columns or rows can be made immovable (freezed). Different types of cell references while copying formulae, are also discussed in this chapter. Data in a worksheet can be printed after applying the different print formatting features. Spreadsheet can be exported to the PDF format, to use it on other platforms.

Learning outcomes

After the completion of this chapter the learner will be able to
• identify the features available in electronic worksheets.
• identify the need for spreadsheet package in numeric data processing.
• store data in a spreadsheet and analyse.
• format the contents of a spreadsheet.
• apply formula for calculations and create series.
• save the file permanently and retrieve it later.
• insert / delete / hide / freeze rows and columns.
• identify the use of relative and absolute referencing.
• use printing facility to take printouts of worksheets.
• familiarise with exporting worksheet to the PDF format.

Lab activities

1. Given a manual worksheet containing the details of students in a class with Reg.No, Name, Age and Marks for 6 subjects. Create an electronic worksheet to calculate the total mark and percentage (Max.Mark for each subject is taken as 100). Use formula to calculate the total mark and percentage of marks for the first student. Then copy the formula to the succeeding rows to complete the marklist.

<table>
<thead>
<tr>
<th>Reg.No</th>
<th>Name</th>
<th>Age</th>
<th>M1</th>
<th>M2</th>
<th>M3</th>
<th>M4</th>
<th>M5</th>
<th>M6</th>
<th>Total</th>
<th>Percentage</th>
</tr>
</thead>
<tbody>
<tr>
<td>5460</td>
<td>Rajeev</td>
<td>16</td>
<td>60</td>
<td>55</td>
<td>48</td>
<td>75</td>
<td>65</td>
<td>50</td>
<td>5460</td>
<td>54%</td>
</tr>
<tr>
<td>5461</td>
<td>Binoy</td>
<td>17</td>
<td>80</td>
<td>90</td>
<td>62</td>
<td>70</td>
<td>60</td>
<td>45</td>
<td>5461</td>
<td>45%</td>
</tr>
<tr>
<td>5462</td>
<td>Rahul</td>
<td>17</td>
<td>78</td>
<td>82</td>
<td>60</td>
<td>55</td>
<td>45</td>
<td>30</td>
<td>5462</td>
<td>30%</td>
</tr>
<tr>
<td>5463</td>
<td>Parvathi</td>
<td>16</td>
<td>70</td>
<td>85</td>
<td>40</td>
<td>50</td>
<td>55</td>
<td>40</td>
<td>5463</td>
<td>40%</td>
</tr>
</tbody>
</table>
2. Create the following worksheet and perform the operations as directed.

Find out the values for the blank cells using appropriate formula

1. Total sales of each salesman
2. Commission for each salesman (10% of sales amount)
3. Total sales of each quarter
4. Total sales of the company in all three quarters
5. Total commission paid by the company.

<table>
<thead>
<tr>
<th>Salesman Code</th>
<th>Qtr1</th>
<th>Qtr2</th>
<th>Qtr3</th>
<th>Total Sale</th>
<th>Commission</th>
</tr>
</thead>
<tbody>
<tr>
<td>S1001</td>
<td>4000</td>
<td>3500</td>
<td>5000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>S1002</td>
<td>5000</td>
<td>4000</td>
<td>3000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>S1003</td>
<td>4000</td>
<td>2000</td>
<td>2500</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

3. Create a multiplication table using a spreadsheet as given below:

*Hint:* Use formula to fill the Answer column, use fill handle to fill first, second, third and fourth columns

<table>
<thead>
<tr>
<th>Number 1</th>
<th>Multiply</th>
<th>Number 2</th>
<th>Equal to</th>
<th>Answer</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>*</td>
<td>5</td>
<td>=</td>
<td>5</td>
</tr>
<tr>
<td>2</td>
<td>*</td>
<td>5</td>
<td>=</td>
<td>10</td>
</tr>
<tr>
<td>..</td>
<td>..</td>
<td>..</td>
<td>..</td>
<td>..</td>
</tr>
<tr>
<td>12</td>
<td>*</td>
<td>5</td>
<td>=</td>
<td>60</td>
</tr>
</tbody>
</table>

**Sample questions**

**Very short answer type**

1. The symbol used for absolute cell reference is _____.
2. The file extension of Calc worksheet file is _____.
3. The default alignment of the text data entered in a cell is _____.
4. The smallest range in a worksheet is _____.
5. The cell address of the very first cell in a worksheet is _____.
6. The range indicator symbol in Calc is _____.
7. By default, ______ number of worksheets are present in a workbook.
8. The Save, Print commands are available in ______ menu of the worksheet window.

**Short answer type**

1. How do you define a range of cells in a worksheet?
2. Write any four application areas where electronic spreadsheet can be used. Recollect from your real-life experience.
3. How will you insert a column in a worksheet?
4. What are the methods of copying data from one place to another in a worksheet?
5. Suppose you need to hide the column F temporarily. How will you do that?
6. What is meant by 'freezing' rows or columns? What is its advantage?
7. Rahul wants to combine the cells from B5 to B10. How can he do it?

**Long answer type**

1. Explain the main components of a worksheet window.
2. Explain the different types of cell referencing.
3. Explain the different printing features available in a spreadsheet.
We discussed the basic concepts of a spreadsheet in the previous chapter. We saw how data is entered in cells and how a cell is referred. We also learned how to add a formula to a cell so that simple calculations can be done. This chapter introduces various built-in functions available in a spreadsheet. These functions make calculations simpler and comparisons possible. Sorting and filtering are the two powerful features of a spreadsheet that make it an ideal tool for data analysis. Charts can also be used in the spreadsheet to provide information in a graphical form.

4.1 Functions

In this section we will learn different built-in functions available in a spreadsheet. For this, let us plan to prepare the marklist of the first mid-term examination. The columns in the mark list are Roll Number, Name, scores of six subjects including English, Second Language, Sociology, Journalism, Communicative English and Computer Application. There are columns for Total, Percentage and Result also.

In the last chapter we learned how to prepare a work sheet. For preparing the mark list, create a table with column headings as RollNo, Name, English, Lang, Sociology, Journalism, Comm. Eng, Comp. Appln., and Total as shown in Figure 4.1
To find the total marks, place the cursor in the cell I3, where you want to display the total marks of the first student as shown in Figure 4.1. Click the **AutoSum** button in the **Formula Bar**. Now you can see \( =\text{SUM}(C3:H3) \) in the cell I3. Here, \( C3:H3 \) is the range of cells used to calculate the **SUM** (refer Figure 4.2).

![Fig. 4.1 : Marklist showing scores in each subject](image)

To find the total marks, place the cursor in the cell I3, where you want to display the total marks of the first student as shown in Figure 4.1. Click the **AutoSum** button \( \Sigma \) in the **Formula Bar**. Now you can see \( =\text{SUM}(C3:H3) \) in the cell I3. Here, \( C3:H3 \) is the range of cells used to calculate the **SUM** (refer Figure 4.2).

![Fig. 4.2 : Calculation of Total using AutoSum feature](image)

Press **Enter** key if the range shown is correct. This will calculate and display the total marks of the first student in the cell I3 as shown in Figure 4.3.
4. Data Analysis using Spreadsheet

How can you calculate the total marks of all other students? It is very simple. The total marks for all students can be calculated and displayed using the following steps.

1. Select cell I3.
2. Move the mouse pointer to the bottom-right corner of the cell. See that the mouse pointer changes to thin + symbol.
3. Click and drag downwards to copy the formula in all cells. The total marks are now displayed in all the cells.

Actually **SUM** is a built-in function used in spreadsheets. Now we will discuss about functions and its usage in detail.

Spreadsheet provides many built-in functions that help to do a variety of tasks easily. Usage of functions saves a lot of time and effort. The real power of spreadsheet lies in the availability of large number of built-in functions for various purposes. Each function has a name. They perform some specific operations and the result is displayed in the cell. A function makes use of values or cell references, just like a simple formula. The numbers or cells used for calculations are placed in brackets after the name of the function. Functions are considered as pre-defined formula in spreadsheets.

In order to use a function, click the button in the toolbar after selecting the appropriate cell. A **Function Wizard** dialog box will be displayed as in Figure 4.4.
The built-in functions in spreadsheet are mainly categorised as Mathematical functions, Statistical functions, Logical functions and Text functions.

### 4.1.1 Mathematical functions

The function **SUM** calculates the total of numbers given as `number1`, `number2`, `number3`, … as shown in the **Function Wizard** (refer Figure 4.4). This method is used when the total is to be found for values stored in non adjacent cells. But in the case of values in adjacent cells we can select a range of cells as discussed below.

The range of cells that is to be used by the function can be selected by the button present in **Function Wizard** dialog box. You can type the range of cells directly as `C3:H3` within the brackets that follow the function name as `=SUM(C3:H3)`. This statement calculates the sum of the values in the cells ranging from `C3` to `H3`.

Let us now try to compute the percentage of marks and display it in the column next to the total marks in the mark sheet.

---

**Eventhough SUM function is available under the category Mathematical functions found in the Function Wizard, almost all spreadsheet software also provides an AutoSum( ∑) button in the formula bar. This is because SUM is the most commonly used function in spreadsheet.**
In the last chapter we learned to insert formula in a cell. The total marks scored by the first student is displayed in the cell I3 as indicated in Figure 4.3. You know that the formula for calculating the percentage of marks is

\[ P = \frac{\text{Marks Scored}}{\text{Maximum Marks}} \times 100 \]

If the maximum mark for each subject is 50 the formula to be inserted in the cell J3 is

\[ = \frac{I3}{300} \times 100 \]

Press Enter key, the percentage of marks obtained by the first student is displayed in the cell J3. Copy the formula to the cells below to find the percentage of marks for all the students as shown in Figure 4.5.

You can see that the percentage of the student ‘Arun K’ is displayed as 81.3333333 in Figure 4.5. Do you think that it will be better if the percentage is rounded to the nearby integer? Or with exactly one or two decimal places? Here the function ROUND helps us do this. Go to the cell K3 and click the insert function button. In the Function Wizard, select Mathematical from the Category drop down box. Double click on the ROUND function.

Figure 4.5: Marklist with percentage

Figure 4.6 displays the structure of ROUND function as given in the Function Wizard. ROUND function rounds a number to the specified number of decimal places. ROUND function requires two values, the number to be rounded and a count. number can be a cell address which contains the number to be rounded (here it is the percentage of total marks) . count is the number of digits to be displayed after decimal point. In this
example, we need to round the percentage of total marks to the nearest integer value. For this we fix count as 0. The result is shown in Figure 4.7.

Let us try to use the **ROUND** function for displaying the percentage of total marks in the rounded format at column K where the formula to calculate the percentage is entered. This can be done by using the formula for percentage as the first argument in the **ROUND** function as given below.

\[
= \text{ROUND} \left( \frac{I3}{300} \times 100, 0 \right)
\]
Now, if we compare the actual percentage of total marks obtained for each student and their rounded percentage of total marks, ‘Arun K’ will lose 0.33333333 percentage when it is rounded. Students ‘Alex Paul’, ‘Asha P’ and ‘Joby’ will also lose the same percentage due to rounding of actual percentage to the nearest integer using the `ROUND` function. That means 0.5 and above rounds to the next higher number and others to the next smaller number. Suppose you want to round the value to the next higher integer always. You can use the **ROUNDUP** function as shown in Figure 4.8.

![Fig. 4.8 : ROUNDUP function](image)

The arguments needed for the **ROUNDUP** function are the same as **ROUND** function but the only difference is that **ROUNDUP** function rounds to the next higher number. For example 81.33333333 will be rounded to 82 in our mark list. The result of **ROUNDUP** function is shown in Figure 4.9.

![Fig. 4.9 : Result of ROUNDUP function](image)
Similarly you can find another function named **ROUNDDOWN** in the function wizard. You can try this function and observe the difference in output.

**COUNTIF** function counts the number of occurrences of values in a list that matches a criteria. Now let us consider that we need to find the number of students who have scored more than 80 percentage or more marks in the class. The function

```
=COUNTIF(K3:K12, “>=80”)
```

gives the number of students who have scored 80 percent or more. The first argument specifies the range of values and the second argument specifies the criteria. Note that the criteria should be specified in double quotation marks. Refer Figure 4.10.

![Fig. 4.10 : COUNTIF function](image)

Table 4.1 summarises the mathematical functions with their syntax and description.

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUM ( )</td>
<td>SUM(Number1, Number2, Number3, ...)</td>
<td>Calculates the total of a set of numbers or adds all numbers in the range of cells. Number1, Number2, ..., Number30 are up to 30 arguments whose sum is to be calculated. A range of cells can be entered by cell reference as SUM(StartCell:EndCell).</td>
</tr>
<tr>
<td>ROUND ( )</td>
<td>ROUND(Number, Count)</td>
<td>Rounds the given number to a specified number of decimal places. Count is the number of decimal places to which the value is to be rounded.</td>
</tr>
</tbody>
</table>
4. Data Analysis using Spreadsheet

Check yourself

1. What is a function?
2. Name the function used to calculate the total of a set of cells.
3. The syntax of ROUND function is _______.
4. Differentiate between ROUNDUP and ROUNDDOWN functions.
5. Write the function to display the number 67.8675 as 67.86.
6. What does COUNTIF function do?

Let us do

- Prepare a table containing the name and age of all students in your class using a spreadsheet. Find the number of students who have age greater than 17 and age less than 15 using functions.
- Prepare a table containing the name and height of all students in your class using a spreadsheet. Find the average height of students in the class and then round the average height correct to 2 decimal places using functions.

Table 4.1 : Mathematical functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ROUNDUP ( )</td>
<td>ROUNDUP (Number, Count)</td>
<td>Rounds the given number up to a specified number of decimal places. Count is the number of decimal places to which the value is to be rounded.</td>
</tr>
<tr>
<td>ROUNDDOWN ( )</td>
<td>ROUNDDOWN (Number, Count)</td>
<td>Rounds the given number down to a specified number of decimal places. Count is the number of decimal places to which the value is to be rounded.</td>
</tr>
<tr>
<td>COUNTIF ( )</td>
<td>COUNTIF (Range, Criteria)</td>
<td>Counts the number of values in the range that meets the specified criteria.</td>
</tr>
</tbody>
</table>
4.1.2 Statistical functions

Statistical functions operate on a set of data and give summarised results. Spreadsheet provides a number of statistical functions. A few of them are discussed in this section.

Consider the example of preparing the marklist that we discussed in the previous section. Let us try to find the average of each subject and display it at the bottom row of the mark entries. Subjectwise average is calculated for a particular subject by adding marks of all students and dividing it by the number of students. But in a spreadsheet, instead of performing this calculation you can directly use the statistical function **AVERAGE**. The **Function Wizard** for the function **AVERAGE** is shown in Figure 4.11.

![Function Wizard for AVERAGE](image)

**Fig. 4.11 : AVERAGE function**

The **AVERAGE** function calculates the average of a set of numbers. You can give number1, number2, number3, etc. Instead of specifying each number, average can also be calculated for the numbers in a range of cells as shown in Figure 4.12.

Here the function **AVERAGE** calculates the average value of the numbers stored in the cells from C3 to C12.

Suppose you want to display the maximum mark and minimum mark in each subject and also the number of students who appeared for the class test in each subject in the marklist. Here you can make use of the functions **MAX**, **MIN** and **COUNT**.

The function **MAX** returns the maximum value from a set of numbers. You can specify individual numbers number1, number2, number3, … or a range of values in this function.
The **MIN** function returns the minimum value within a set of numbers. The function syntax is same as **MAX**.

![Fig. 4.12 : AVERAGE function for range of values](image)

**COUNT** function counts how many values are there in the list of arguments. It can also count number of values within the specified range as shown in Figure 4.13.

The subject average, subject top score, subject minimum and the number of students appeared for each subject obtained with the help of various statistical functions are shown in Figure 4.14. The syntax of different statistical functions are summarised in Table 4.2.
Fig. 4.14: Results of statistical function

1. Which function is used to find the highest value in a range of cells?
2. The function used to find the lowest value from a set of numbers is _______.
3. Name the function to find number of values in a range of cells.
4. Write the function to display the average of 30, 50, 40, 48.
5. How do you display the number of students with value 'A' in the range D3: D13?

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVERAGE</td>
<td>AVERAGE(Number1, Number2, Number3, …)</td>
<td>Calculates the average of a given set of numbers. Number1, Number2, … must be numerical values. It can also calculate the average of numbers in a range of cells. It is given as AVERAGE(StartCell:EndCell).</td>
</tr>
<tr>
<td>MAX</td>
<td>MAX(Number1, Number2, Number3, …)</td>
<td>Gives the maximum value in a list of numbers. It can also return the maximum value in a range of cells.</td>
</tr>
<tr>
<td>MIN</td>
<td>MIN(Number1, Number2, Number3, …)</td>
<td>Gives the minimum value in a list of numbers. It can also return the minimum value in a range of cells.</td>
</tr>
<tr>
<td>COUNT</td>
<td>COUNT(Value1, Value2, Value3, …)</td>
<td>Counts the number of values in the list of arguments. Value1, Value2, Value3, … are values. It can also count the number of values in a range.</td>
</tr>
</tbody>
</table>

Table 4.2: Statistical functions
4.1.3 Logical functions

Logical functions are used for checking a test condition. Consider a situation where you need to display a result 'Pass' or 'Fail' for each student, depending on the mark or percentage of marks scored. For this, a particular condition is to be tested. Let us consider that a student has passed if he/she gets a total mark of 40% or more. So the condition will be based on the percentage of total score.

The logical function IF is used to test a condition. If the condition is true, then one action is taken; if the condition is false, then another action is taken. Figure 4.15 shows the structure of IF function in the Function Wizard.

The structure of an IF function is:

\[ =IF \text{ (Test, Then\_value, Otherwise\_value)} \]

IF function has three parts - Test, Then\_value and Otherwise\_value as indicated in Function Wizard (Figure 4.15). We can specify a condition that is to be evaluated in Test. Here the condition can be evaluated as True or False. If the condition is True, Then\_value is displayed and if the condition is False Otherwise\_value is displayed as the result.

In this example, the percentage of the first student is in the cell K3. In order to find whether a student is 'Pass' or 'Fail' in the cell L3, we need to specify the condition \( K3 \geq 40 \) in Test. If the condition is True, then we print 'Pass' as the result. It is given in the Then\_value. If K3 is less than 40, the result should be displayed as 'Fail'. It is
Through the above example, we decided whether a student is considered as ‘Pass’ or ‘Fail’ based on the percentage of the total mark. Usually a student is decided ‘passed’ if he/she scores pass marks in all the subjects. In this case, instead of checking the total percentage, we have to check the marks of each subject. Here the function **AND** comes to our help. The **AND** function allows to check many conditions. It will return True, if all the conditions are evaluated to be True; otherwise it will return False. Here a student who scores 20 or more in all subjects is considered ‘Pass’. The structure of the **AND** function is shown in Figure 4.17.

Through the above example, we decided whether a student is considered as ‘Pass’ or ‘Fail’ based on the percentage of the total mark. Usually a student is decided ‘passed’ if he/she scores pass marks in all the subjects. In this case, instead of checking the total percentage, we have to check the marks of each subject. Here the function **AND** comes to our help. The **AND** function allows to check many conditions. It will return True, if all the conditions are evaluated to be True; otherwise it will return False. Here a student who scores 20 or more in all subjects is considered ‘Pass’. The structure of the **AND** function is shown in Figure 4.17.

**Fig. 4.16 : Marklist with result**

Through the above example, we decided whether a student is considered as ‘Pass’ or ‘Fail’ based on the percentage of the total mark. Usually a student is decided ‘passed’ if he/she scores pass marks in all the subjects. In this case, instead of checking the total percentage, we have to check the marks of each subject. Here the function **AND** comes to our help. The **AND** function allows to check many conditions. It will return True, if all the conditions are evaluated to be True; otherwise it will return False. Here a student who scores 20 or more in all subjects is considered ‘Pass’. The structure of the **AND** function is shown in Figure 4.17.
Using **AND** function we can test up to 30 conditions. The maximum number of conditions that can be tested may change depending on the version of the spreadsheet package used. Each condition can return either True or False. In our example the **AND** function can be specified as

\[ =\text{AND} (\ C3>=20, \ D3>=20, \ E3>=20, \ F3>=20, \ G3>=20, \ H3>=20 ) \]

The result will be True if the scores of all subjects are greater or equal to 20. If the score of any subject is less than 20, the function will return False. We can say that a student has passed if **AND** function returns True and failed if the **AND** function returns False.

The **OR** function is another logical function. The result of **OR** function will be True, if any of the conditions is True and will be False if all the conditions are False. In our example, a student fails if he scores less than 20 marks for any of the subjects. So the result of a student can be determined using the **OR** function as

\[ =\text{OR} (\ C3<20, \ D3<20, \ E3<20, \ F3<20, \ G3<20, \ H3<20 ) \]

Here the result will be true if the score of any of the subject is less than 20. That is if **OR** function returns True, we can say the student is failed, and if it is False the student is passed.

The **NOT** function is used in situations where we need to get the reverse of logical test. That is, if the condition is evaluated to true, **NOT** function returns False, otherwise it returns True.

The logical functions in spreadsheet give either True or False as result. The syntax of the different logical functions are given in Table 4.3.

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IF ( )</td>
<td>IF (Test, Then_value, Otherwise_value)</td>
<td>If the condition is True, Then_value is returned; else Otherwise_value is returned.</td>
</tr>
<tr>
<td>AND ( )</td>
<td>AND (Logical value1, Logical value2, …..)</td>
<td>Returns True if all the conditions are True; otherwise returns False.</td>
</tr>
<tr>
<td>OR ( )</td>
<td>OR (Logical value1, Logical value2, …..)</td>
<td>Returns True if any of the condition is True; returns False if all the conditions are False.</td>
</tr>
<tr>
<td>NOT ( )</td>
<td>NOT(Logical value)</td>
<td>Reverses the value of its argument. That is, if test condition evaluates to True, then NOT returns False and if the test returns False, NOT returns True.</td>
</tr>
</tbody>
</table>

*Table 4.3: Logical functions*
Check yourself

1. The function used to test a condition is_______.
2. Multiple test conditions can be combined with _______functions.
3. Which function is used while combining more than one test conditions and the result will be true if any of the condition is true?
4. Name the category of functions which returns either TRUE or FALSE as result.

4.1.4 Text functions

There are many text or character manipulation functions in a spreadsheet. The important text manipulation functions are explained below.

**UPPER**

It converts a text to the upper case (capital letters). Only the lower case (small letters) letters in the text are converted to the upper case. Other characters in the text remain in the same form. Here we can give a text as the argument. The argument can be a cell address also. The structure of **UPPER** function in the Function Wizard is shown in Figure 4.18.

**LOWER**

The **LOWER** function converts a text to the lower case. Here only the upper case letters in the given text are converted to the lower case.

![Fig. 4.19 : LEN function](image_url)
4. Data Analysis using Spreadsheet

Check yourself

1. Which function converts an input text into capital letters?
2. Name the function that converts an input text into small letters.
3. The function used to find the number of characters in a cell is ________.

4.1.5 Nested functions

Spreadsheet allows you to include one function inside another function. This is often required to perform many calculations in a single formula and to produce the desired output. Placing a function inside another function is called nesting of functions.

Consider Figure 4.14, which shows the results of statistical functions. The subject averages are 31.7, 39.8, 34.4, 35.2, 31.2 and 35.111. It would be better if we round...
these values. Here subject average is calculated using the AVERAGE function. As you have already learned, the ROUND function is used to round a number to the specified number of decimal places. We can use the AVERAGE function inside the ROUND function. The function can be written as

\[ = \text{ROUND} \left( \text{AVERAGE} \left( C3:C27 \right), 0 \right) \]

Now the results will be 32, 40, 34, 35, 31 and 35.

In the case of nested function, the inner function is evaluated first and the outer function operates on the result of the inner function.

Now let us assign grades to each subject. For this let us insert one column each after every mark column. We have already discussed how columns can be inserted in the previous chapter. Grades can be calculated based on the marks scored in each subject using the following criteria.

<table>
<thead>
<tr>
<th>Marks</th>
<th>Grade</th>
</tr>
</thead>
<tbody>
<tr>
<td>40 or more</td>
<td>A</td>
</tr>
<tr>
<td>Below 40 and 30 or more</td>
<td>B</td>
</tr>
<tr>
<td>Below 30 and 20 or more</td>
<td>C</td>
</tr>
<tr>
<td>Below 20</td>
<td>D</td>
</tr>
</tbody>
</table>

It is clear that grades cannot be calculated by testing a single condition. The IF function we learned earlier has three parts; A Test, Then_value and Otherwise_value. Consider the case of the first subject (English). In the Test part, you can specify \( C3 \geq 40 \). Then_value will be 'A' because if the mark is above or equals 40, the grade is 'A'. The Otherwise_value is not a grade. Here we need to test another condition \( C3 \geq 30 \). For this we require another IF function in the Otherwise_value part. To include a function in another function click \( f3 \) button displayed to the left of each item in the Function Wizard. As shown in Figure 4.21 the function to find grade can be written as

\[ =\text{IF} \left( C3 \geq 40, \text{"A"},\text{IF} \left( C3 \geq 30, \text{"B"},\text{IF} \left( C3 \geq 20, \text{"C"}, \text{"D"} \right) \right) \right) \]

This can be explained as: if \( C3 \geq 40 \), then the grade is 'A'. Otherwise, check if \( C3 \geq 30 \). If this is true, then the grade is 'B'. Otherwise check if \( C3 \geq 20 \). If true, then the grade is 'C' otherwise grade is 'D'.

![Fig. 4.21 : Nested IF functions](image-url)
In the example of the mark list that we discussed, a student is considered passed if he/she has got 20 marks or more in all the subjects. Earlier, you have seen that the function \textbf{AND} or \textbf{OR} can be used to test more than one condition. These functions will however return True or False as result. Here you have to check whether the mark of each subject is greater than or equal to 20. If we are using an \textbf{AND} function for checking the marks of individual subjects, it will return True if all the test conditions are True otherwise returns False. So if an \textbf{AND} function is used in the \textbf{Test} part of the \textbf{IF} function, we can test multiple conditions. The result 'Pass' can be specified in the \textbf{Then\_value} and 'Fail' will be specified in the \textbf{Otherwise\_value}. As we have already learned, the text given in the \textbf{Then\_value} will be displayed, if the \textbf{Test} is evaluated to True and the text in the \textbf{Otherwise\_value} will be displayed if the \textbf{Test} is evaluated to False. So this will give the desired result.

How will you include an \textbf{AND} function in the \textbf{IF} function? In the test section of the \textbf{IF} function, click on the button and select \textbf{AND} function. Now you can set multiple conditions. The function in the formula bar will be displayed as

\[
\text{=IF ( AND ( C3>=20, E3>=20, G3>=20, I3>=20, K3>=20, M3>=20 ) , "Pass", "Fail")}
\]

This nested function, will give you the result as 'Pass' if all the conditions mentioned inside \textbf{AND} function are evaluated to true. The same thing can be done using \textbf{OR} function. Figure 4.22 refers to the nesting of \textbf{IF} and \textbf{AND} functions.

From the above discussion it is clear that you can include one function inside another. This feature makes a spreadsheet a powerful tool for data processing. The final mark list is displayed as in Figure 4.23.
4.2 Data manipulation

A spreadsheet is often used to store a large volume of data. It can hold thousands of records. Usually a column in a sheet contains the same type of data except the column heading. The data under the column heading 'Mark' will store only numbers that represent marks scored by students. The data under the column heading 'Date of birth' will be dates and so on. The data presented in this structure is referred to as a data table. The mark list is a data table because each column in the mark list contains same type of data. It is not practical to scroll through the entire worksheet each time to find a particular record. Sorting and filtering are two powerful features available in spreadsheet that can be applied in these situations. Sorting allows us to organise the data in specific order where as filtering finds out records with a specific condition.

4.2.1 Sorting

Consider the marklist in Figure 4.23. In order to prepare a rank list, the student with highest total comes in the first row, the second highest total in the second row and so on. It is not easy to find the student record with highest total by scrolling through the sheet, cutting the row and pasting it as the first row. Then find the student with the next highest mark and make it the second row, and so on.

Sorting allows us to arrange the data in a table either in ascending or descending order of one or more columns. To get the rank list, sort the mark list in the descending order (highest values comes first) of total. The following steps are used for sorting

1. Select the entire table
2. Click Data $\rightarrow$ Sort from the menu bar. This will display a Sort dialog box as in Figure 4.24.
3. Select the column from the Sort by drop down list. (Select the column as column O, the column of Total marks).

Let us do

- Calculate the grades of other subjects in the example of marklist preparation.
- Find whether a student is ‘Pass’ or ‘Fail’ by using OR function inside IF.
4. Now choose either **Ascending** or **Descending** option. (Here we choose **Descending** because the data must be sorted in the descending order of total marks).

5. Click **OK**.

The ranklist is shown in Figure 4.25.

To consider the data in a range of cells as a table, the following points are to be noted.

- Do not leave a blank row between column heading and the data, as the blank row and blank column indicates the end of the table.
- The column headings given at the top of each column must be in a single cell and make it unique (preferably) within a worksheet.
In the Ranklist example, you have sorted the data based on a single column, named 'Total'. If the total of two students is the same, who will get the priority? Here you can use the option **Then by** in the **Sort** dialog box. That is, if there are more than one rows with the same data in the column specified for sorting, **Then by** is used to specify which column is to be considered next for sorting.

This can be better explained by taking your Class Register as an example. Consider that the Class Register is being prepared. Before giving Roll Number, all the students have to be ordered in the following way. Students who have chosen Malayalam as the Second Language comes first, and then those who have chosen Hindi. In each language, boys come first, then girls. At last the names of the boys and girls in
each Second Language section are sorted separately in the alphabetical order. The Sort dialog box is shown in the Figure 4.26. In this dialog box, give Sort by as ‘Sec. Language’, the first Then by as ‘Gender’ and the second Then by as ‘Name’. Now click OK button and observe what happens.
The sorted list is given in Figure 4.27. Now the Roll Numbers can be given.

4.2.2 Filtering
Filtering allows us to display only data that meets some criteria. Filtering temporarily hides the data in a spreadsheet that does not meet the condition. In our Marklist example we have scores of each student in each subject, grades, total marks and the result. Now let us prepare a list of students who have passed using the filtering feature in spreadsheet. There are two types of filtering Autofilter and Standard Filter.

a. Autofilter
Autofilter displays a dropdown list containing all the values in each column and allows to filter the rows based on values in the list. The steps for filtering using Autofilter are given below

1. Select the entire table.
2. Click on the Data menu.
3. Select Autofilter from the Filter option.
A drop down arrow appears in each column. Click on the arrow in the column for which we want to specify the condition. In the case of 'Result' column, the screen will appear as in Figure 4.28.

The drop down list in the 'Result' column displays 'Fail' and 'Pass'. We will select 'Pass' because we need to get the list of passed students. The result of using Autofilter option is shown in Figure 4.29.

Observe the result carefully. Row numbers are not in order. This indicates that some rows were filtered out. This is because they do not satisfy the specified filter condition. We have specified 'Pass' as the filter criteria.
Autofilter allows selection of records that display identical values in the specified column. Here the filter condition is tested for equality. That means it will display the records that contain the specified value in the column in which Autofilter is applied. It hides the rows from the result that do not satisfy the criteria.

In addition to filter data based on the values in the column, Autofilter permits to filter top 10 rows. The top 10 filter works only with numbers. It will display top 10 rows without sorting.

To display all records again, select the All entry in the Autofilter combo box. To cancel data filter and display all data, reselect choose Data → Filter → AutoFilter again.

b. Standard filter

Standard Filter is used when the data is to be filtered based on a range of values in particular data fields (column). It can also be used when multiple conditions are to be used for filtering. These multiple conditions can be combined with either a logical AND or a logical OR operator.

Suppose you need the list of students whose percentages are above 75 and who got 'A grade' in English.

This cannot be done by the Autofilter, as there are two conditions and one of the conditions does not depend on equality. Standard Filter can be used in this situation. The first condition is Percentage above 75. The second condition is grade of English should be 'A'. Both the conditions should be satisfied. Connect the conditions with AND operator. The Standard Filter window is shown in Figure 4.30.
To remove a filter, click inside the area where the filter was applied, then choose Data → Filter → Remove Filter.

Check yourself

1. Arranging data based on ascending or descending order of one or more column is known as _______.
2. 'Sort' option is available in ________ menu.
3. How can we display the data in a table that meets a specified condition?
4. More than one conditions can be specified in ________ filter.

Create a table containing the salary details (Employee No, Name, Designation, Salary) of employees in a company. Sort the details of employees in the ascending order of their name.

Display the details of employees whose Salary is above 10,000 and Designation is 'Accountant'. 
4.3 Charts

It is much easier to understand data when it is presented graphically. Charts are graphical representation of numeric data. Charts make it easier for users to compare and understand statistical data. They can be used for data analysis. Charts can present data entered into the worksheet in a visual format using a variety of graph types.

Charts are constructed with the numeric data entered in the worksheet. The data can be individual numbers in a worksheet or a data series within a column or a row. This section explains how you can create simple charts from the data.

The following are sales details of ABC Ltd. during the four quarters of a year. Carry out the following steps to create a chart.

1. Select the data range.
2. Select Chart from the Insert menu or click on the chart icon on the Tool bar. This will display Chart Wizard.
3. Choose a Chart Type. There are many types of charts in spreadsheet like Column, Bar, Line, Pie, etc. Select Column type.
4. Click on the Data Range. The selected range will be displayed. Ensure it is correct. If needed, make the necessary changes.
5. Click Chart Elements and give titles for graph, X axis and Y axis. Here Chart Title is given as 'Sales Report', titles for X-axis is 'Quarters' and Y-axis is ‘Amount’.
6. Click Finish.

4.3.1 Chart elements

A chart has many elements. Some of these elements are displayed by default, others can be added as needed. Here are some standard chart elements.
1. **Chart Area**: It includes the entire chart and all its elements.

2. **Chart Title**: A chart title is the descriptive text for a chart.

3. **X-Axis Title**: A title given to the X-axis data range.

4. **Y-Axis Title**: A title given to the Y-axis data range.

5. **X-Axis Category**: These are the categories of the data which have been plotted. These are taken from the first column or first row of your data range.

6. **Y-Axis Value**: This is the data range marked to plot the data series.

7. **Data Labels**: The values of the data series plotted.

8. **Legends**: A legend is a box that specifies the colour, symbol or pattern assigned to the data series.

### 4.3.2 Chart types

Spreadsheet provides various types of charts to help you to display data in different ways as per the need of the viewers. The type of the chart is determined by the type of the data you are using and presenting. You can create a new chart or can change the existing chart type.

**a. Column charts**

This type of chart is commonly used to compare values across categories. They are best for charts that have relatively small number of data. They represent data in vertical columns. It is easy to understand and is the default chart type. They give very effective results to analyse the data of the same category on a defined scale.

**b. Bar charts**

Bar charts are used to show comparisons between individual items. To make a bar chart the data should be arranged in the form of rows and columns on a worksheet.

The composition of column or bar can be stacked in more than one colour to represent the contribution of each portion of the category to the total for that category.
c. Line charts

Data represented in columns or rows in a worksheet can be plotted with the help of line chart. Line charts can be used to display continuous data over time with respect to a common scale. Thus, Line charts are the best for viewing data trends at equal intervals of time. The horizontal axis (x-axis) is used to represent the category data and all the value data is distributed uniformly along vertical axis (y-axis). It is ideal for representing large data that show trends or changes over time where you want to focus on continuity.

d. Pie charts

Pie chart is used to display how much each part contributes to a total value. It is very useful in a situation where one has to show the relative proportions. It offers greater visual clarity. In case of pie chart only one data series is used. If more than one data series are selected, spreadsheet uses the first series.

When we create a pie chart, the spreadsheet totals the data points in the series and then divides the values of each data point into the series total to determine how large each data point's pie slice should be. It is effective where there is small number of data points. Generally, there can be maximum of five or six data points or slices in a pie chart. If the points are more in number then it becomes very difficult to interpret the chart. Besides, it is very important to note that the values to be used in the pie chart

![Fig. 4.34(a) : Column chart](image)

![Fig. 4.34(b) : Bar chart](image)

![Fig. 4.34(c) : Line chart](image)

![Fig. 4.34(d) : Pie chart](image)
must be all positive. If there are some negative values, in that case the negative values will be automatically converted into positive values. Figure 4.34 displays different types of charts.

Now let us consider the sales details of ABC Ltd. displayed in Figure 4.35. Here the data of sales done by three salesmen in the four quarters of the year is given.

Let us draw a column graph with these data. We have three series of data corresponding to each salesman. The range is selected as A3 to D7. Then follow the steps used to create a chart mentioned earlier. On clicking the Finish button the chart will be displayed as in Figure 4.36.

Compare this chart with chart in Figure 4.33. In the previous chart there is one column corresponding to each quarter. Now there are three columns corresponding to each salesman. How do you identify the column of a particular salesman? Here the colour legend comes to help. The legend is shown in the right side of the chart. It tells which is the colour used to represent each salesman.

Try the same data with other types of charts. This data is not suitable for Pie chart as this contains three series for each quarter. Pie chart can deal only with one series of data.
Chart Wizard contains more options than we discussed. They are beyond our scope. Still you can experiment with options available in Chart Type, Data Range, Data Series and Chart elements.

Check yourself

1. The graphical representation of numeric data is known as __________.
2. The type of chart that supports only one data series is
   a) Column   b) Bar   c) Line   d) Pie
3. Which chart is used to show the upward or downward trends in value over time?

Let us do

- Prepare a column chart that shows the comparative study of each subject in the mark list.
- Tabulate the data of survey related to the source of drinking water in your locality and draw a pie chart.

Let us sum up

In this chapter we have familiarised ourselves with the spreadsheet. A large amount of data can be entered in multiple sheets of a workbook. We can perform different calculations by entering expressions or formula in a cell to perform calculations. In the first section of this chapter we saw that there are many built-in functions available in a spreadsheet that make calculations even simpler and comparisons possible. These functions are categorized into different groups. We have discussed only a few functions in the spreadsheet. A discussion on all the functions available in a spreadsheet is beyond the scope of this book. Sorting and filtering are powerful features of the spreadsheet that makes it an ideal tool for data analysis. In this chapter we also learnt charts. There are different types of charts in a spreadsheet. Charts can be used to provide information in a pictorial form. They make it easy to understand facts.
Learning outcomes

After the completion of this chapter the learner will be able to

- identify the use of different mathematical functions - SUM, ROUND, ROUNDUP, ROUNDDOWN and COUNTIF.
- identify the use of different statistical functions - AVERAGE, MIN, MAX and COUNT.
- identify the use of different logical functions - IF, AND, OR and NOT.
- identify the use of different text functions UPPER, LOWER and LEN.
- sort data in a spreadsheet.
- identify the use of Filtering.
- compare different types of charts.

Lab activities

1. Prepare the salary bill of employees of an organisation with following information using a spreadsheet: Employee Code, Name of Employee, Designation, Basic Pay, DA, GrossPay, PF, Net Pay. DA is calculated as 55% of the Basic Pay. GrossPay = Basic Pay + DA. NetPay = GrossPay - PF. The amounts should be rounded to the nearest rupee. (Use functions whereever possible.)

2. Prepare a table containing the sales of 10 salesmen. The table consists of Serial No, Name, District, Actual Sales Amount, Expected Sales Amount, Difference in Sales and Bonus. Bonus is calculated as if Actual Sales Amount exceeds Expected Sales Amount, then Bonus is 5%, otherwise Bonus is 3% of Actual Sales Amount.

   a. Sort this table with highest to lowest Bonus. If Bonus is same, sort with highest to lowest Actual Sales Amount.

   b. Filter the salesman in such a way that only those salesmen who have Bonus more than 10000 and have a positive Difference in Sales are displayed.

Sample questions

Very short answer type

1. What is a function?

2. __________ function is used to calculate the total of a set of cells.
3. The syntax of ROUND function is _________.
4. Name the function that is used to find highest value in a range of cells.
5. Which function is used to find number of values in a range of cells?
6. Which charts are considered suitable for viewing data trends at equal intervals of time?

**Short answer type**
1. Differentiate between ROUNDUP and ROUNDDOWN functions
2. How does a function differ from a formula?
3. Explain different mathematical functions.
4. How do you display the number of students with value 'A' in the range D3:D13?
5. Write the function to display the number 67.8675 as 67.86.
6. Explain logical functions.
7. What do you mean by nesting of functions?
8. What is sorting?
9. How do you sort a table of data based on a column?
10. Explain different types of filtering.

**Long answer type**
1. Explain the elements of a chart.
2. Write the steps to create a chart.
Key concepts

- Starting presentation software
- Creating a presentation
- Adding new slides
- Formatting a slide
  - Text formatting - Character, Paragraph
  - Bullets and numbering
  - Setting the background - Slide, Object
- Adding images to the slide
- Slide masters
- Duplicating and deleting slides
- Inserting a table in a slide
- Inserting a sound file
- Inserting a video clip in a slide
- Inserting hyperlinks
- Adding action objects
- Drawing figures in the slide
- Views of slides
  - Normal
  - Outline
  - Notes
  - Handout
  - Slide Sorter
- Using slide animation effects
- Slide transitions
- More presentation settings
- Printing a presentation

Presentation Software

You were familiarized with the presentation software in the previous classes. We use the presentation software for making a presentation with the help of graphs, pictures, sounds, videos, etc. A presentation program helps both the speaker and the viewer. The presenter can easily convey ideas, and the viewers can grasp the ideas better than in mere speech. Thus if we are able to present our ideas graphically with sound and visual effects, it will be more effective and productive. This chapter introduces slide preparation and slide layout facilities available in the presentation software. We will also discuss various formatting features like adding text, images, tables, background, fonts, animations, sound, videos, etc. in the presentation software.

Open Office Impress and Microsoft PowerPoint are the two popular software available for preparing a presentation. Most of the tools available in these software are similar.

5.1 Starting presentation software

Presentation software is used to demonstrate a concept or subject in front of others with the help of pictures, audio and video. A presentation is composed of several slides. Presentation software consists of an editor to create attractive slides that
contain graphics and a facility for slide show. Presentation tool facilitates the creation of presentations on any particular topic like uses of Internet, global warming, social networking, etc.

Let us prepare a presentation to give awareness about the importance of saving our environment from various threats. Before we start, we should have a clear idea about the content and the structure of the presentation. The first slide in the presentation usually contains the title of the presentation and details of the presenter. The second slide gives an introduction to the topic. More details about the subject are included in the succeeding slides. The contents in these slides can be presented with the help of bulleted lists, images, tables, audio and video. Instead of presenting the matter in paragraphs, it would be better if they are presented in the form of a bulleted list. After the contents are presented, it will be better to conclude them in the presentation.

In this chapter, we use Open Office Impress as a tool for creating the presentation. Note that there may be changes in the features available depending on the software and its version. When we open Impress, a dialog box showing the Presentation Wizard as in Figure 5.1 appears on the screen.

![Presentation Wizard dialog box](image)

The three options in this dialog box are Empty presentation, From template and Open existing presentation.
The **Empty presentation** option is selected by default and then the **Create** button at the bottom of the wizard is clicked. The window as in Figure. 5.2 is displayed.

![Fig. 5.2 IDE of presentation software](image)

Let us discuss the different components of this window. On the top of this window there is a **Title Bar** with the name of the presentation on it. Below this, a **Menu Bar** containing menus like **File, Edit, View, Insert, Format, Tools, Slide Show**, etc. are shown. The different **ToolBars** like Standard, Presentation, Drawing, etc. are displayed below it. The **Toolbar** consists of icons for frequently used commands. On the right side of the window we can see the **Tasks** pane. Different slide layouts, master pages, table designs, custom animation, slide transitions, etc. are available in this **Tasks** pane. On the left side there is the **Slides** pane. It shows the different slides used in the presentation. The **Status Bar** is shown at the bottom of the window. At the centre of this window is the working area on which we can insert text, picture, sound, etc. This window together with all these components is called the Integrated Development Environment (IDE) of the presentation.

### 5.2 Creating a presentation

Let us start creating a simple presentation with Open Office Impress. This section describes the procedure for this. Suppose you open Impress and opted **Empty presentation**, the first slide of our presentation appears.
Designing the first slide

Let us give our presentation the title 'Save our Planet - Earth'. By default, the design of the first slide consists of provisions to add a title and a text. Click on the provision given for the title and enter heading of our presentation. Similarly, the name and class of the presenter can also be entered in the box below. After entering the title the slide appears as in Figure 5.3.

Saving a presentation

Now, we can save this file in a folder. For this, click the Save icon in the Standard toolbar or press the shortcut keys Ctrl + S. While saving the file for the first time, the Save As dialog box appears as in Figure 5.4. In this dialog box choose the folder and specify a file name. Click the Save button. Now the file is saved.
Opening a presentation

To open an existing presentation, choose File → Open or Ctrl + O. An Open dialog box appears. Select the file that we want to open and click Open.

5.3 Adding new slides

While designing presentation, we may need to add more slides. Let us now add a slide that introduces the topic. Use the menu item Insert → Slide to add a slide. Here, we choose the Title Only layout from the predefined layouts in the Tasks pane (refer Figure 5.5).

Entering text in a slide

In this slide we introduce the topic. Here, we will have a heading and a narration about the topic. There are two ways to add text in a slide. Text can be typed directly in the text element in a slide or using the Text tool in the Drawing toolbar.

By directly typing the text in the slide

Here, text can be added directly to the title object and the body object. For entering a text, click on the object as described in Section 5.2. Enter the title as 'Our Earth'.

By using a Text tool

1. Click on the Text icon \[\text{T}\] on the Drawing toolbar.
2. Click and drag to draw a box for the text on the slide.
3. Type the contents in the text box and click outside the textbox to deselect it.
Check yourself

1. Name any two popular presentation software.
2. The text tool is available in the ______ toolbar.
3. Give the names of different components of presentation software IDE.
4. Write the shortcut key to open a file.

5.4 Formatting a slide

Formatting a slide is a way in which its contents are arranged and presented. Let us discuss the methods available in presentation software for making the slides more attractive. The appearance of slides can be enhanced by formatting the text or by setting the background of the slide.

5.4.1 Text formatting

Appropriate text formatting can give a presentation a consistent look and feel. Applying effects to the text in a slide is called text formatting. Text formatting can be classified as character formatting, paragraph formatting and list formatting.

a. Character formatting

Setting the font face, size, colour and other effects to the characters in the slide is called character formatting. Character formatting options are available in Format → Character menu or clicking the character button in the Text Formatting toolbar. A Character dialog box is displayed as shown in Figure 5.7.

The Font tab of Character dialog box can be used to select the desired font face, style (Regular, Bold, Italic and Bold Italic) and the size of the font. Font Effects tab is used to specify a font colour, gives effects like embossed, engraved, outlined, shadow, etc. It can also be used to specify the style and colour of underline,
overline and strikethrough. The **Position** tab provides facility to make a text superscript or subscript. In addition, it allows to set the spacing between the characters.

**b. Paragraph formatting**

These formatting features apply to a paragraph of text. Indentations, spacing, alignment and tab setting can be done using this feature. Select **Format** → **Paragraph** menu item or click the paragraph button on the Text Formatting toolbar to view the **Paragraph** dialog box as in Figure 5.8.

Indentation of the text, spacing before and after the paragraph and spacing between lines of a paragraph can be set using **Indents & Spacing** tab of the **Paragraph** dialog box. Alignment of a paragraph can be selected from **Alignment** tab. Tab stops can be set using **Tabs**.

After applying the character and paragraph formatting, the presentation appears as in Figure 5.9.
5.4.2 Bullets and numbering

Bullets and numbering allow to present a list of items in the slide attractively. **Bullets and Numbering** can be accessed using the menu item **Formatting → Bullets** or using Bullets and Numbering icon in the Formatting toolbar.

In our presentation about the earth, let us add a new slide about the issues that affect our environment. For this, we add a new slide and select a layout that contains bullets. Type the points in the bulleted list. To change the format of the bullets, select the list of items and then click the Bullets and Numbering icon. The **Bullets and Numbering** dialog box as in Figure 5.10 appears.

The **Bullets and Numbering** dialog box contains five tabs namely, **Bullets, Numbering type, Graphics, Position** and **Customize** for formatting the lists. The **Bullets** tab is used to set the style of the bullet. To use a more attractive graphical bullet, choose a suitable bullet from the **Graphics** tab. **Numbering type** tab provides option to select the different numbering styles available. **Position** tab allows to set indent, width of numbering and alignment of the different levels of...
5.4.3 Setting the background

We can set different background styles to slides, to make the presentation more beautiful. The background styles can be set for a slide or an object in the slide.

a. Setting slide background

The background of a slide can be given a colour, gradient, hatching pattern or bitmap. This can be done using the menu option Format → Page and then select the Background tab from the Page Setup dialog box as in Figure 5.12.

Setting background colour

A uniform colour can be set as the background of a slide using the Color option in the Fill dropdown box. Choose the desired colour from the list of colours displayed below and then click OK button as in Figure 5.13(a). This will display a confirmation dialog box as in Figure 5.13(b). This prompts a message to the user stating whether the background setting is to be applied for all the slides in the presentation or to the current slide.

After setting the background colour our presentation appears as shown in Figure 5.14.
Applying gradient fill

A gradient fill provides a smooth transition from one colour to another. A gradient fill can be applied to the background of a slide using the Gradient option in the Fill dropdown box as shown in the Figure 5.12. Then select a gradient style from the list as in Figure 5.15. When the OK button is clicked, the confirmation dialog box is displayed as in Figure 5.13(b).
Fine lines are used in graphic arts to show shading. The process of decorating a slide using such lines is known as hatching. To apply a hatching pattern to the slide, select the Hatching item from the Fill list as in Figure 5.12.

Setting a bitmap as the background

A bitmap image can be used to fill the background of a slide. Choose the Bitmap option in the Fill dropdown box as in Figure 5.12.

b. Setting background of an object

We can set the background of an object or an area in a slide with a uniform colour, a gradient, a hatching pattern or an image. This can be done using the Format → Area menu item. An Area dialog box as in Figure 5.16 is displayed.

To set a background colour of a selected object, choose the Area tab. Select an appropriate colour for the object and click OK button.
In the same way, a gradient, hatching pattern or a bitmap image can be set as the background of an object. The Shadow tab is used to set shadow to an object. The percentage of transparency of an object can be set using the Transparency tab. Figure 5.17 shows the slide after applying gradient to the title object.

**5.5 Adding images to a slide**

Images can convey a message effectively to the audience. The effect of our presentation can be enhanced by inserting suitable images to it. In our presentation about earth, let us add a new slide that displays images of the various types of pollutions that affect our environment.

After adding a new slide, select a layout that has a title and facility to add 4 images. In each of the 4 content boxes in the slide, we can add images by clicking Insert Picture and browse to add images. Our new slide is displayed as shown in Figure 5.18.

Another method of inserting images to a
slide is by selecting Insert → Picture from File menu option. Let us give a background image to our first slide using the above method. In the Insert Picture dialog box that appears, browse and select an image. The selected image will be added to the slide. Note that this image will hide other objects in the slide. To send it to the back of other objects, right click on the image and choose Arrange → Send to Back. Image and other objects in the slide can be resized and re-positioned by clicking and dragging. The new appearance of the first slide is as in Figure 5.19.

5.6 Slide masters

A slide master controls the basic formatting of all the slides in a presentation. A slide master has a defined set of characteristics for background colour, graphics (logos, decorative lines, etc.) and placement and formatting of text. A slide master is also called a template.

5.6.1 Applying slide master

Slide masters are available in the Master Page section of the Tasks pane. Select a suitable slide master from the available list. This will change all the slides in the presentation according to the formatting defined in the slide master. After applying the template, our presentation appears as in Figure 5.20.

![Fig. 5.20: After applying Slide Master](image)

5.6.2 Loading additional slide master

Sometimes in a presentation we may need to mix multiple slide masters. For example, we may need an entirely different layout for the first slide of the presentation. The Slide Design dialog box makes this possible. It is available at Format → Slide Design menu option. Figure 5.21 displays the Slide Design dialog box. In this dialog box use the
Load button to select an appropriate template. Click OK button to apply the template to current slide (Figure 5.22). Templates can also be selected at the time of creating a new presentation. The Presentation Wizard shown in Figure 5.1 allows you to create a presentation from a list of existing templates.

Check yourself

1. What do you mean by gradient?
2. Name the different text formatting options in presentation software.
3. How do you add new slides to your presentation?
4. How can you insert an image in a slide?
5. Which of the following controls the basic formatting of all the slides in a presentation?
   a) Gradient  b) Hatching Pattern  c) Slide Master  d) Bitmap fill

- Make five different slides based on any topic that you have studied this year and give suitable background colour, text etc.

Let us do
5.7 Duplicating and deleting slides

Duplicating a slide means making a copy of the same slide. To duplicate a slide, right click on the slide which is to be duplicated in the Slides pane. From the popup menu choose Duplicate Slide. A copy of the selected slide is inserted as the next slide.

To delete a slide, right click on the slide in the Slides pane and select Delete Slide from the popup menu. The selected slide will be removed from the presentation.

5.8 Inserting a table in a slide

Tables are powerful tools to convey structured information quickly. Hence table is an important tool in presentations. In our presentation about earth, let us insert a table to list the important days related to environment.

![Insert Table dialog box](Fig 5.23(a) : Insert Table dialog box)

A table can be easily inserted into a slide using Insert Table menu item. From the Insert Table dialog box, select the number of rows and columns (Figure 5.23(a)).

The table inserted on the slide can be resized and positioned by dragging it. When a table is selected, a Table toolbar is displayed (Figure 5.23(b)). This toolbar contains tools for merging, splitting, giving colours, borders, alignments, etc. to the cells of a table. This toolbar also consists of buttons for inserting or deleting rows and columns, setting table properties, etc. The Tasks pane shows various predefined styles of tables from which we can select a suitable style. A Tasks pane can also be used to create a table. This can be done by clicking a suitable design from the Table Design tab in the Tasks pane. The important days related to environment can be presented using a table as in Figure 5.24.

![Table toolbar](Fig 5.23(b) : Table toolbar)

![Days to Remember](Fig. 5.24 : A slide with table)
5.9 Inserting a sound file

At times, it may be necessary to play sound during the presentation. In our presentation, let us insert a poem 'Bhoomikkoru Charamageetham' by Prof. O.N.V. Kurup. This poem is stored as bhoomi.wav. Let us now create a new slide to insert this poem. In this slide, first insert an image of Prof. O.N.V. Kurup. Now we can insert the sound file. A dialog box as in Figure 5.25 is displayed when we select Movie and Sound option of Insert menu. Click Open button after selecting the audio file. The new slide is displayed as in Figure 5.26.

![Fig. 5.25 : Open dialog box to select sound files](image)

We can see that the sound file is inserted in our slide in the form of a sound icon. It is set to begin automatically when the slide comes on the screen. If we do not want the sound icon to appear on the screen, you can drag it off the slide. It will be still active but will not be visible on the slide.

5.10 Inserting video clip in a slide

A video clip can be inserted into a slide in the same way as we insert a sound file. Select the movie file from the Open dialog box that appears, when we choose Insert → Movie and Sounds menu. Let us include a video on pipe compost in our presentation. The new slide with the video clip is shown in the Figure 5.27.

![Fig. 5.26 : Slide with sound file](image)

![Fig. 5.27 : Slide with video clip on pipe compost](image)
Remember that whenever we need to move our presentation to other computers, both the presentation and the folder with the movies and sound files must be copied together. Otherwise, the presentation software will not play the audio or video. This is because the presentation software loses its link to the specified file in the new computer.

5.11 Inserting hyperlinks

A hyperlink can be inserted into a slide. When we click on the hyperlink, it leads the viewer to some other documents or slides. To insert a hyperlink, or to customise the appearance of a hyperlink, select **Insert → Hyperlinks** from the menu. The **Hyperlink** dialog box shown below (Figure 5.28) opens.

![Hyperlink dialog box](image)

**Fig. 5.28 : Dialog box for creating or editing hypertext**

On the left hand side, select one of the four types of hyperlinks:

- **Internet**: Used to hyperlink to a web page in the Internet, normally starting with `http://`.
- **Mail & News**: Create or edit hyperlink for email or news address.
- **Document**: The hyperlink points to a document, sections of a document or to another slide in the presentation.
- **New document**: The hyperlink creates a new document of the selected type.

The right part of the dialog box changes according to the choice made for the hyperlink type. A full description of all the choices and their interactions is beyond the scope of this chapter.
5.12 Adding action objects

In the presentation we can add actions, such as going to another slide, play audio or video, etc. to an object in a slide. The object can be a shape like a text box or an image. When the user clicks on it or points to that object, the action will be applied.

5.12.1 Adding a button to move to the first slide

1. Select a slide to insert a button.
2. Choose the Rectangle tool from the Drawing toolbar and drag it on the slide to a suitable place such as the lower-right corner of the slide.
3. Right-click on the rectangle and select Interaction from the popup menu (Figure 5.29). The option Interaction is also available in the Slide Show menu. An Interaction dialog box appears as in Figure 5.30.
4. Select Goto first slide from the dropdown box for Action at mouse click and click OK.

5.12.2 Applying interaction method to play audio and video

If we want to play an audio file or a video file during our presentation, we can use an interaction button. The button can be created as explained in the previous section. For this select the object which is to act as the interaction button. Then choose the menu

Fig. 5.29 : Adding action button

Fig. 5.30 : Interaction dialog box
5. Presentation Software

item **Slide Show → Interaction**. In the **Interaction** dialog box that appears (refer Figure 5.30), select **Go to document** item for **Action at mouse click** setting as in Figure 5.30. Then browse the sound or movie file that we want to play. Remember that all the file types that are listed in the dialog box are not supported by the presentation software.

### 5.13 Drawing figures in the slide

Presentation allows us to draw figures in a slide. There are many drawing tools available in **Drawing** toolbar which is generally displayed below the slides in normal view. Different shapes, lines, curves, etc. can be used to draw figures in our slide. In our last slide we will draw a happy earth using symbol shape in the **Drawing** toolbar. It is shown in Figure 5.31.

![Figure 5.31: Slide with a drawing](image)

### 5.14 Views of the slides

The presentation has five different workspace views from which we can choose. Each view is designed to perform certain tasks easier. The different views are:

- Normal view (Slide view)
- Outline view
- Notes view
- Handout view
- Slide Sorter view

The different views can be selected from **View** pane shown in Figure 5.32.

![Figure 5.32: Slide view pane](image)
5.14.1 Normal view

It is the main view for creating individual slides. It is used to design and format various objects in the slide. The whole slide is visible on the screen when normal view is used. This is the default view in a presentation.

5.14.2 Outline view

Outline view contains all the slides of the presentation in their numbered sequence. It shows titles, bulleted lists and numbered lists for each slide in outline format. Use this view to edit titles and text, rearrange the order of items in a list, etc. Outline view (Figure 5.33) shows only the text in the slides. No graphs or tables can appear in this view.

![Fig. 5.33 : Outline view](image)

![Fig. 5.34 : Notes view](image)
5.14.3 Notes view

Notes view allows us to add notes to each slide. In Notes view each slide is displayed as a combination of a preview of the slide and a text box to add notes below it. This view enables the presenter to make notes regarding each slide. Notes can be shown on the printout but they will not be shown on the screen during the presentation. Figure 5.34 shows the Notes view of our third slide.

5.14.4 Handout view

Handout view is for setting up the layout of a printed handout. Click the Handout tab in the workspace, and then choose Layouts in the tasks pane. We can then choose to print 1, 2, 3, 4, 6 or 9 slides per page. The thumbnails of slides will appear in the chosen format. They can be re-arranged by dragging. We can add headers and footers to the handout. Figure 5.35 shows the handout view.

![](image)

Fig. 5.35 : Handout view with layout

5.14.5 Slide Sorter view

Slide Sorter view shows a thumbnail of each slide in the order they are to be displayed at the time of the slide show. This view is used to rearrange the order of slides or add transitions between selected slides. Slide Sorter view can be used to work with a single slide or group of slides. The number of slides displayed in a row can be changed using the slides per row box in the Slide view toolbar. Using Slide Sorter view we can add new slide, delete or rename a slide. Also we can change the layout of the slide. All these options are available in the popup menu appeared in response to a right click on the thumbnail of the slide.
a. Changing the order of slides in a presentation using Slide Sorter view

To move a slide in a presentation using the Slide Sorter view,

1) Click on the slide. A thick border is shown around the slide.
2) Drag and drop it to the required position.

Suppose our aim is to move the fifth slide 'Days to Remember' to the last position. Click on the slide, drag and drop it to the last position. After sorting, the Slide Sorter view appears as in Figure 5.36.

![Slide Sorter view](image)

**Fig. 5.36 : Slide Sorter view**

b. Selecting and moving groups of slides

To select a group of slides, click on the first slide then hold the Ctrl key pressed and then click other slides. Then drag it to the needed position.

5.15 Using slide animation effects

Animations can make a presentation more lively and memorable. Animations are applied to individual elements on a slide like title, text, image or individual bullet point in a list. Animation effects need to be applied from Normal view so that we can select individual objects on a single slide.

**Applying an animation effect**

In Normal view, choose the desired slide. Select the text or object to animate. When an object is selected a coloured handle appears around the object. Then choose Custom Animation from the Task pane as in Figure 5.37.
Click the Add button. The Custom Animation dialog box appears as in Figure 5.38. Choose an effect from one of the pages of this dialog, and choose the speed or duration of that effect. In our presentation 'Save Earth', select the title and click the Add button from the Custom Animation pane. From the Entrance tab of the dialog box, select Fly In and click OK.

There are five tabs in the Custom Animation pane as shown in Figure 5.38. Each tab contains many effects. You can experiment with different effects.

### 5.16 Slide transitions

Slide transitions are defined as special effects that play when we display a slide during a slide show. Roll down from top or Fly in from left are some slide transitions. They add dynamic styles to a slide show, smoothing the transition between slides. We play sound or specify the speed of transition in the Modify transition section of the Slide Transition pane.
We can add transitions, in Slide Sorter view or in Normal view. To see the effect of a selection, we need to be in Normal view and select the Automatic preview checkbox on the Slide Transition page of the Tasks pane as in Figure 5.39.

We can apply a single type of transition to all slides in the presentation or apply a different transition to each slide. Some of the slide transition settings are given below:

**5.16.1 Automatic slide transition**

We can set up a slide show to run automatically, either unattended or while you speak. To set the default time for slides to be displayed before changing to the next slide, go to the Slide Transition pane, choose Automatically after in the Advance slide section, set a time and click the Apply to All Slides button as in Figure 5.39.

**5.16.2 Rehearse timings**

While giving a talk using a presentation, the time required for presenting each slide may differ. The timing for each slide can be determined only after taking a rehearsal. Presentation software provides a facility to set different timings for different slides. This option is available at Slide Show → Rehearse Timings in the Menu bar. On selecting this, the slide show begins in full-screen mode, and a timer appears in the lower left-hand corner of the screen. When we want to advance to the next slide, click the timer. Continue this process for all slides in the presentation. It records the display time for each slide. Save the presentation. When we show the slides next time, the time for displaying of slides will be changed to match what we have set when rehearsing.

**5.17 More presentation settings**

During presentation there may be a situation where we need to repeat the entire presentation or play background music throughout the presentation. Let us discuss these features below:

**5.17.1 Auto-repeat presentation**

Before an audience or in a seminar, we may have to make a presentation regarding the events. Such a slide show should auto-repeat until the event starts. For this, open the
5.17.2 Background sound for a presentation

We can use the Slide Transition pane to set a sound or a song to be played throughout the presentation.
Select the slide in which the sound is to be inserted. In the Modify transition section of the Slide Transition pane (refer Figure 5.39), choose Other Sound ... from the Sound dropdown box. Select Loop until next sound checkbox if we want the sound to restart once it is finished. Do not select the Apply to all slides button as it will re-start the music at every slide change.

5.18 Printing a presentation

Keeping a printed copy of the presentation will be helpful to the presenter during a presentation as a reference. A hard copy of the presentation may be given to the audience for future reference. Presentation software provides many options for printing a presentation such as a single slide per page, multiple slides on one page, slide with notes, outline or handout. The slides can be printed in their original colour, grayscale or
in black and white. For printing a presentation, choose **File → Print** to display the **Print** dialog box (refer Figure 5.41).

Choose the required settings from the options and click the **Print** button. A preview of the page to be printed is also available in this dialog box.

**Check yourself**

1. To remove a transition effect select ________ item in the list on the slide transition page in the Tasks pane.
2. Define the term slide transition.
3. Give any three items present in the slide transition pane.
4. What do you mean by action button in a slide?
5. Write the steps to insert a transition effect to slide of a presentation you have created.

**Let us do**

- *Suppose you get a movie file that shows working of a laser printer. Insert this movie file on the slide and play it by clicking the picture of that printer.*

**Let us sum up**

An effective presentation helps to convey ideas to the audience better than a mere speech. Presentation software enables presenting the topic with the help of pictures, sounds, videos and animations. Slides can be prepared and its content can be formatted by inserting text boxes, setting the background colour and patterns. The various built-in templates called master pages can be used to make the presentation attractive. Formatting can be done to a particular area in the slide or to the entire slide. The different styles of bullets and numbering available can be used if required. Facilities to insert images or draw pictures on the slides are available in presentation software.

Presentation software provides different slide views that support the presenter. Tables inserted in a slide can be formatted using different built-in formats available or can be customised. Movies and sound can be inserted in the slides. Different built-in transition effects can be set to slides. Animations given to the objects in the slide make a presentation attractive. We can create hyperlinks in a slide that provides links to documents or websites. Various printing options are available to print the slides, notes, handouts, etc.
Learning outcomes

After the completion of this chapter the learner will be able to

• identify the use of presentation software and its features.
• create slides by entering text and formatting it.
• insert various objects like images, tables, audio, video, etc.
• make the slides attractive using transitions and animation.
• identify the different slide views and its use.
• familiarise with various printing options.

Lab activities

1. Create a presentation on the ‘Importance of growing vegetables’. Give proper formatting to background and text of slides. Insert pictures, tables, etc. that encourages growing vegetables. Presentation should consist of at least 8 slides.

2. Design a presentation on ‘Blood donation’. Give a suitable template for your presentation. Links to different websites should also be given in the slide. Presentation should consist of at least 8 slides.

3. Design a presentation on the topic 'Input and Output Devices'. Complete the presentation by inserting pictures of these devices in the slides and set timings for transitions according to their content.

Sample questions

Very short answer type

1. What are the two different ways of inserting a text into a slide are?
2. How can you insert an image into a presentation?
3. Name the view that helps to change the order of slides.
4. What is a hatching pattern?

Short answer type

1. What are the different types of numbering possible in presentations?
2. What do you mean by hatching? Write the steps to insert a hatching pattern to slides?
3. Discuss the different ways of inserting a sound file to a slide.
4. How can you play background music in presentation?
5. Explain how tables can be inserted into slides.
6. What do you mean by rehearse timings in slide transition?
7. Give the steps to insert action buttons in a slide. Explain its use.
8. What do you mean by hyperlink? How do you insert hyperlinks in a slide?

**Long answer type**

1. Explain the different slide views.
2. Explain the IDE of a presentation software.
6 Getting Started with GIMP

All of us would like to use beautiful images in documents, posters and presentations we prepare. For this we search the Internet and download appropriate images. But at times the images we download may not be exactly as the one we have in our minds. The possibility of easily editing or changing an image can make a large difference to a document or presentation we prepare. We may want to change the background of an image, add an image to another one or rotate a part of an image, to make it suitable for our needs. Image editing software helps us to create attractive images that suit any situation, be it the background image of a presentation or a poster, a background picture of a stage or a huge advertisement board.

6.1 Image editing

Image editing is the editing or manipulating of an image or a graphic. Image editing can be done using image editing software. Tasks that can be done with image editing software include resizing, cropping, coloring, combining and altering digital images to suit the imagination of its creator. Images taken with a digital camera or those which are scanned from a printed photograph can be used for this purpose.

Image editors can also be used to remove scratches, wrinkles, dirt and imperfections from images. They can be used to sharpen or blur images. Lines and other
shapes can be drawn with brushes of different color, size, shape and pressure. Digital images also can be rotated clockwise or anti-clockwise or flipped horizontally or vertically. Text in different font styles can be inserted into images and conversions can easily be done from one image format to another. Graphic artists, photographers and web designers are among the people who regularly work with image editing software.

Image editors can be broadly grouped into raster graphics editors, vector graphics editors and 3D modelers.

Raster images are stored in a computer in the form of a grid of picture elements or pixels. These pixels contain information regarding the color and brightness of the image. Pixels can be changed in groups or each one separately, by sophisticated algorithms within the image editors. These types of editors are primarily referred to as bitmap graphics editors, which are often used to alter photographs and other raster graphics. Raster images are resolution dependent. Therefore when you scale a raster image (change the size), you are actually shrinking or stretching the pixels themselves, resulting in significant loss of clarity and the image gets blurred. GIMP, Photoshop and gThumb Image Viewer are raster graphics editors for viewing and editing images.

Vector images are created mathematically using formulas of geometry. Each element is created and manipulated mathematically. Vector images are based on vectors (paths) which lead through locations called control points. Vector objects are made up of basic geometric shapes such as points, lines and curves. They can be modified more easily because they contain descriptions of the shapes. The relationship of the shapes is expressed as a mathematical equation which allows the image to be scaled up or down in size without losing quality. Vector images can be rasterised to any particular size. Vector graphics software, such as Adobe Illustrator, Corel DRAW and Inkscape are used to create and modify vector images like company logos, desktop icons, etc.

Table 6.1 presents a comparison between raster and vector images.

<table>
<thead>
<tr>
<th></th>
<th>Raster</th>
<th>Vector</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Raster image is made up of pixels.</td>
<td>Vector image is created mathematically</td>
</tr>
<tr>
<td></td>
<td>Quality of raster images decreases as they are scaled.</td>
<td>using formulas.</td>
</tr>
<tr>
<td></td>
<td>Raster images are capable of displaying any colour.</td>
<td>Vector images can be scaled to any size</td>
</tr>
<tr>
<td></td>
<td></td>
<td>without losing quality of image.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Vector images do not permit colour editing to</td>
</tr>
<tr>
<td></td>
<td></td>
<td>the extent as possible with raster images.</td>
</tr>
</tbody>
</table>
3D modelers (3D computer graphics software) allow users to create and alter 3 dimensional models using the 3D mesh. Users can add, subtract, stretch and change the 3D mesh according to their wish. Models can be viewed from a variety of angles simultaneously. It can be zoomed in and out. 3D modelers are used in a wide variety of industries. The medical industry uses them to create detailed models of organs. In movies they are used to create and manipulate characters and objects. 3D modeling software is used to create objects for video games. 3D Studio MAX is a comprehensive and versatile 3D application used in film, television, video games and architecture. Animation Master is a modeling and animation software that is easy to use. K-3D is a GNU based modeling, animation and rendering software available on GNU/Linux.

Figure 6.1 displays a snapshot of different image editing software.

### Table 6.1: Raster-Vector comparison table

<table>
<thead>
<tr>
<th>Raster images</th>
<th>Vector images</th>
</tr>
</thead>
<tbody>
<tr>
<td>Often large files.</td>
<td>Relatively smaller in size.</td>
</tr>
<tr>
<td>Used in web and print.</td>
<td>Converted to raster images before they are used for web and printing.</td>
</tr>
</tbody>
</table>

6.2 GIMP

The GIMP is the acronym for GNU Image Manipulation Program. The GIMP is an application suitable for tasks such as retouching of photographs, composing and authoring images. Its capabilities as an image manipulation program make it a worthy competitor to other similar programs such as Adobe Photoshop or Corel PHOTO-PAINT. The
first edition of GIMP was developed by Peter Matis and Spenser Kimpel in California University in 1996. It is now available in different versions for Linux, Mac and Windows operating systems. Most Linux distributions include GIMP as a standard application.

The following is a short overview of some of the features and capabilities offered by the GIMP.

- Full suite of painting tools including brushes, pencil, airbrush, cloning, etc.
- Multiple undo/redo.
- Selection tools including rectangle, ellipse, free, fuzzy, bezier and intelligent.
- Transformation tools including rotate, scale, shear and flip.
- Supports multiple layer facility.
- Supports file formats like GIF, JPEG, PNG, TIFF, and BMP.
- Advanced scripting capabilities.

**Making a simple GIMP project**

Let us see how we can use GIMP to design a poster on 'Anti-Smoking Campaign' using different photographs, logos and texts. To create a poster, you need to perform the following operations in GIMP.

### 6.3 Canvas creation

The canvas is the container part of the GIMP to hold and manipulate pictures. To create a new canvas for the poster, click on **New** in **File** menu as shown in Figure 6.2. It displays a **Create a New Image** dialog box as shown in Figure 6.3. Give a suitable...
image/canvas size say, 600 pixels as the width and 800 pixels as the height of the image. The image size can also be selected in different units like millimeters, centimeters, inches, etc. We can also select a preset image size from the template.

![Fig. 6.3: Create a New Image dialog box](image)

**Color settings for a canvas**

The background colour of the poster can be set using the background and foreground option in the colour palette. When a new canvas is created, by default, the colour in the palette becomes the background colour of the canvas. To change the background color of the poster, perform the following steps.

- Click on the background colour icon in the **ToolBox.** Here, by default, foreground is black and background is white.
- Select a suitable color for the canvas from the color area of the colour palette.

![Fig. 6.4: Color palette](image)
palette as shown in Figure 6.4 and click the OK button.

- Select **Bucket Fill** tool from the **Toolbox**.
- Click on the canvas to fill the background colour (Figure 6.5).

When you use a **Gradient** tool (which you have learned in the previous classes), you need to use more than one colour in the canvas. In such situations, the foreground which is available in the colour palette can also be made use of, along with the background colour.

**6.4 Saving images**

When the canvas is ready, the GIMP project has to be saved. To save, select **Save** option from the **File** menu. Choose a location in your computer to save the project using the **Save** dialog box that appears. Give a proper file name, say 'Poster', and press **Save** button. The project will be saved in your computer with the extension **.xcf**. XCF (Experimental Compact Facility) is the native format of GIMP project files.

To reset all user settings in GIMP, use the menu item **Edit -> Preferences**. From the Preferences dialog box that appears, Choose **Window Management**. Click **Reset Saved Window Positions** to **Default Values**. Now click **OK** and then restart GIMP.

**6.5 Layers in GIMP**

For preparing the poster on 'Anti-Smoking Campaign', we require pictures related to anti-smoking. We can collect pictures from Internet, resource CD's, etc. and store them in the folder **Images**. The pictures should be in GIMP supported formats like jpg, tif, png, bmp, etc.
Our poster is to be designed using the pictures we have collected. These pictures have to be opened in GIMP and then aligned to our canvas on different layers. Only then the different images can be manipulated separately.

A layer can be compared to a transparency on which images are applied and stacked on or below other images. In an image editing software, a layer is the term used to describe the different levels at which you can place an object or an image. Each layer can have different images and effects. Using image editing software you can stack, merge or define layers while creating a digital image. Layers allow you to go back and make changes within a layer. Consider the following two images (Figure 6.6).

![Fig. 6.6 : Pictures collected](image1)

Assume that, in the second image, the lungs are drawn in a transparent sheet. When the second sheet is placed on top of the first one, the image will look as shown in Figure 6.7. In GIMP, we treat the second image as a layer.

![Fig. 6.7 : Combined image](image2)

![Fig. 6.8 : Layers dialog](image3)
We can create any number of layers for an image and different images can be drawn into these layers. When the images are placed in different layers, they can easily be modified, without affecting the images on other layers. Layers are controlled through Layers dialog (Figure 6.8).

If the Layers dialog is not visible on the screen, you can use the menu item Windows → Dockable dialogs → Layers. You can also use the shortcut key Ctrl+L to make the Layers dialog visible on the screen.

There are a number of icons at the bottom of the Layers dialog. These icons are used for various operations on layers. The use of each icon in the layers dialog is given as follows.

1. Create new layer.
2. Move layer up.
3. Move layer down.
4. Create duplicate copy of a layer.
5. Anchor the floating layer.
6. Delete a layer.

Now let us see how layers can be used in the editing of an image. For this first of all, consider our canvas (poster.xcf) as shown in Figure 6.9.
You can see the **Layers** dialog on the right side (Figure 6.9). Now we can create a new layer in this canvas. For this, click the leftmost icon (Create new layer) on the bottom of the layers dialog or using the **Layer** menu. Then you will get a dialog box as shown in Figure 6.10. We can change the Layer name as *Human* as shown in the figure and click the **OK** button. Make sure that in the **Layer Fill Type** options **Transparency** is selected. Now the **Layers** dialog will look as shown in Figure 6.11. The **Layers** dialog displays two layers, the **Background** layer at the bottom and the '**Human**' layer on top.

### 6.6 Creating a simple GIMP project

Now, to this new layer you can copy the image of the human which you have already downloaded. For this, the picture of the human has to be opened at first (body.png). Let us see how this image can be opened in GIMP.

Click **Open** in the **File** menu and select the image file from the folder 'Images' in your computer. Now picture appears as shown in Figure 6.12.
We need to add the whole image (body.png) to our canvas. For this click the menu item Edit → Copy to copy the image. Then activate the canvas by clicking on it. We need to copy the image to the 'Human' layer in our canvas. Ensure that the 'Human' layer in the Layers dialog is selected. Then use the menu item Edit → Paste. The image of the body is copied into the canvas as shown in Figure 6.13.

![Fig.6.13 : Image copied to the canvas](image)

How does the image appear now? You can see that the 'Human' image is larger than its background. The 'Human' layer can be resized to match the background. This can be done using the Scale tool available in the Toolbox. The Scale tool helps us to resize an image. To scale the active layer of the canvas, select Tools → Transform Tools → Scale or Scale tool from Toolbox. When you click on the image a Scale dialog box (Figure 6.14) is opened. This can be used to change the width and height of the image. The image can also be resized by using the handles that appear on the corners and borders of the image. After resizing, click the Scale button to complete the process.

![Fig.6.14 : Scale dialog box and picture](image)
While scaling the image, you might have noticed that the image gets distorted due to improper resizing. This problem can be avoided by keeping the aspect ratio. The aspect ratio will constrain the scaling that the height/width ratio of the layer will be kept constant. The **Linking Chain** icon in the **Scale** dialog box should be clicked for keeping the aspect ratio. (See Figure 6.15)

![Fig.6.15 : Scale dialog box](image)

Now, let us have a look at the **Layers** dialog. (See Figure 6.16). You can see that the pasted image is shown in the **Layers** dialog as a floating selection. In order to paste this layer on the 'Human' layer, click the **Anchor the Floating Layer** icon which is at the bottom of the **Layers** dialog.

![Fig.6.16 : Before anchoring](image)

![Fig.6.17 : After anchoring](image)

A floating selection (sometimes called a ‘floating layer’) is a type of temporary layer which is similar in function to a normal layer. Before you work on any other layers in the image, a floating selection must be anchored. Anchoring is attaching a floating layer to a normal (non-floating) layer, which was active previously (See Figure 6.17).
To reposition the scaled image in the 'Human' layer, use the **Move** tool. This tool is available in the **Tools → Transform Tools → Move** menu. You can also use **Move** tool in the **Toolbox**. To move the image, click on the image and drag. Note that all manipulations in GIMP is done on the active layer. Therefore, before editing, we should make sure that the image to be manipulated is in the active layer of the **Layers** dialog. Also, note that while using move tool the **Move the active layer** option of the **Tool Toggle** is selected. (See Figure 6.18). Now the canvas appears as shown below (Figure 6.19).

![Tool Toggle in Tool Box](image1.png)

![Picture after moving](image2.png)

**Fig. 6.18 : Tool Toggle in Tool Box**  **Fig. 6.19 : Picture after moving**

We can complete the poster by adding more images or its specific parts. To add a specific portion of an image, there are various selection tools available in GIMP. Now let us open the image 'Lungs.jpg' as shown in Figure 6.20.

For our poster we need only the image of lungs without its white background. How will you select the lungs without its white background? You can use the **Fuzzy Select** tool for this purpose. Select white background using the **Fuzzy Select** tool and then, by inverting the selection, only the image of lungs can be copied.

![Lungs picture](image3.png)

**Fig. 6.20 : Lungs picture**
The **Fuzzy Select** tool is used to select similar colours on the current layer. After selecting the tool, set the appropriate **Threshold** (here we use 66) in the tool options of fuzzy tool. **Threshold** determines how many similar colours should be selected on the borders of a selection.

Then click on the white background of the image, lungs. All the areas similar to white color in the clicked region will be selected. Now we can inverse this selection to select the image of the lungs. For this, select the menu item **Select → Invert**. On clicking this, the image of the lungs will be selected as shown in the Figure 6.21.

Now paste the image of lungs which you have copied to a new layer in our canvas in the same way as you copied the 'Human' image. Scale and move the image if necessary, to place it in the appropriate location on the canvas as in Figure 6.22.
Similarly, open the 'Icons.jpg' image (Figure 6.23) and use appropriate selection tools to select the 'No Smoking' image and place it in the suitable location on the canvas as shown in Figure 6.24.

![Fig. 6.23 : Icons picture](image)

![Fig. 6.24 : Icon pasted in the canvas](image)

You can improve the layout of our poster by including more images that you have saved in your folder. For this you may use more selection tools. Let us familiarise more selection tools.

**Check yourself**

1. GIMP stands for ________.
2. What do you mean by image editing?
3. The default extension of a GIMP image is ________.
4. What are different types of image editors?
5. What is scaling in GIMP?

**6.7 Selection tools**

GIMP offers a good range of selection tools that allow you to make quick, simple and more advanced selections. Selection tools are designed to select regions from the active layer so that we can work on them without affecting the unselected areas. The different selection tools available in GIMP are **Rectangle Select**.
Ellipse Select, Free Select, Foreground Select, Fuzzy Select, By Color Select and Intelligent Scissors (Figure 6.25). The different selection tools are described below.

a. Rectangle Select

The Rectangle Select tool is designed to select rectangular regions of the active layer. It is one of the most basic selection tools with which a portion of a picture in rectangle shape can be selected. Rectangle selection tool can be accessed using the menu, Tools → Selection Tools → Rectangle Select option or from the Toolbox using icon.

b. Ellipse Select

The Ellipse Select tool is designed to select circular or elliptical regions from an image. To make a selection, use the menu item, Tools → Selection Tools → Ellipse Select. This can also be done using the icon in the Toolbox. When this tool is selected, the mouse pointer turns into a circle icon as it is brought over an image. Now click and drag it to get an elliptical (or a circular) selection area within a rectangular box.

c. Free Select (Lasso Tool)

The Free Select tool or Lasso Tool allows you to create a selection by drawing it free-hand with the mouse pointer, holding down the left mouse button. When you release the mouse button, the selection is closed by connecting the current pointer location to the start location with a straight line. Free Select is available at Tools → Selection Tools → Free Select and also in the Toolbox.

d. Foreground Select

Foreground Select is used for finer selection of pixels in an image. Foreground Select is available at Tools → Selection Tools → Foreground Select or using Toolbox . Initially Foreground Select works just like the Free Select tool discussed before. A portion of an image can be selected in a similar way as in the case of Free Select tool. When the mouse is released, the area other than the selected area gets covered with a blue mask (Figure 6.26).

Now the mouse pointer turns to a paint brush icon. Use this paint brush to draw a continuous line on the selected area in such a way that the line passes over the colours to be selected (Figure 6.27).
The colour or thickness of the line is not important. When you release the mouse button all the non-selected areas are covered with a blue mask (Figure 6.28). Press Enter key to get the desired selection (Figure 6.29).

![Fig.6.28 : Non-selected areas in blue mask](image1)

![Fig.6.29 : Final selection](image2)

e. Fuzzy Select (Magic Wand)

The **Fuzzy Select** (Magic Wand) tool is designed to select areas of the active layer or image based on color similarity. This tool is popularly used for selecting objects of the same colour with sharp edges. We have already seen how this tool is used for selecting the white spaces in the 'Lungs.jpg' image.

- **To remove all selections from the canvas, use Select → None from the menu or press Shift+Ctrl+A.**

f. By Color Select

**By Color Select** option is similar to **Fuzzy Select**. The difference is that with the **Fuzzy Select** tool only contiguous areas based on colour similarity can be selected whereas with **By Color Select**, all the regions in an image where there are similar colours can be selected. The similar areas need not be contiguous for **By Colour** selection. **By Color Select** can be accessed at **Tools → Selection Tools → By Color Select** or from the Toolbox.

- **It is much easier in Gimp to move the actual selection marquee once you have made it. For this, make a selection, then click the Move tool. Make sure that the Move option is set to Selection in the panel and you can now drag the selection into a new position. This works for circles, rectangles as well as selections made using **Free Select** tool.**

- **To merge all layers, right click on any of the layers in the Layers dialog and choose Flatten Image.**
g. Intelligent Scissors

**Intelligent Scissors** has some features common to Lasso tool and Path tool and it also possesses some features that are its own. It is useful when you are trying to select a region defined by strong color-changes at the edges. To use **Intelligent Scissors**, you click to create a set of 'control nodes', also referred to as anchors or control points, at the edges of the region you are trying to select. This produces a selection area in the form of a continuous curve, passing through these control nodes. The Intelligent Scissors is available at Tools ➔ Selection Tools ➔ Intelligent Scissors or in the Toolbox.

### 6.8 Adding text to images in GIMP

Let us consider the poster which you prepared before. You need to insert a slogan against smoking in the poster. You can use the Text tool for this purpose. The Text tool is used to add text to an image in GIMP. The text is inserted as a new layer in the canvas. Let us see how this tool can be used.

![GIMP Text Editor](image)

*Fig. 6.30: GIMP Text Editor*

Text tool is available at Tools ➔ Text and is also available in the Toolbox icon. Select the Text tool and click on the canvas. A **GIMP Text Editor** appears. You can set the font type, size, colour and alignment of the text in the tool options of the Text tool (Figure 6.30).

Type the slogan 'Say NO to Tobacco' in the GIMP Text Editor and press the Close button. This slogan then appears in a new layer in our canvas. See the Layers dialog (Figure 6.31).
Now, if necessary, scale and move the slogan to a suitable place on the canvas by using appropriate tools.

To edit an entered text, select the **Text** tool from the **Toolbox**. Make sure that the text layer is the active layer. Click on the text to select the contents and click again to open the **GIMP Text Editor** for editing the content. In cases where the text is modified using other tools, GIMP asks for a confirmation to edit the contents in a **Confirm Text Editing** dialog box (Figure 6.32). Use the **Edit** button to continue editing.

Our poster for the anti-smoking campaign is now ready (Figure 6.33). You can modify the poster to by adding more slogans or phrases.

![Image of poster](Fig.6.32 Poster - final form)

![Image of GIMP text editor](Fig.6.33 Poster - final form)
6.9 Exporting images in GIMP

The poster that we have created has to be pasted on a notice board or published in a website. For this the poster has to be converted to a common format that supports image viewers, printing and publishing software. The export facility in GIMP provides options to export the image from a GIMP project to various other image file formats. GIMP is considered as one of the best image conversion software. Let us see how GIMP converts our poster to other image formats such as jpg, png, bmp, etc.

To convert the GIMP project file (‘Poster.xcf’) to another format use the **Save As** option from the **File** menu. In the dialog that opens, click the **Select File Type** to open the list of file types and then scroll down and click on appropriate format you need before clicking the **Save** button. In some versions, images can be converted to other formats using the **File → Export to** option.

---

**Check yourself**

1. Name the tool used to select circular areas in an image.
2. What is the use of the selection tool?
3. A GIMP image can be exported to png format using _____ option.
4. What is the difference between **Fuzzy Select** and **By Color Select**?

---

**Design a collage for the youth festival in your school.**

Let us do

6.10 Transform tools

Transform tools are mainly used to alter the appearance of an image or a particular element of an image. Transform tools change the size, position and angle of the image. The different transform tools available are **Align**, **Move**, **Crop**, **Rotate**, **Scale**, **Shear** and **Flip**. Let us discuss the different transform tools available in GIMP in detail here.

6.10.1 Align

The **Align** tool is useful to align the image layers with various image objects. GIMP's align and distribute tools allow you to arrange objects. Arrangement of objects can be
done in two ways - align relative to an object or selection, distribute according to an offset value.

Aligning will line up the contents of two or more layers based on either the edges or center of its content. The alignment will be done relative to the target item specified. The different align options are **Top Edges**, **Middle**, **Bottom Edges**, **Centers**, **Left Edges** and **Right Edges**.

The distribute tools allow us to take the contents of multiple layers and space them out equally based on offset values specified. Distribution is also done relative to the target item specified. The different distribute options available are distribute **Top Edges**, **Vertical Centers**, **Bottom Edges**, **Left Edges**, **Horizontal Centers** and **Right Edges**.

Let us now see how the **Align** tool works with the help of an example. This tool can be used to align different layers. Select **Align** tool in the **Toolbox** or from **Tools → Transform Tools → Align**. Let us begin with a new image. Select a new canvas with size 300 X 500 pixels as shown in Figure 6.34. Copy an image of a flower to this canvas as a new layer. By default, the size of a layer will be the same as the size of the canvas. When you select a layer, a yellow dotted line appears around the layer showing the layer boundary. If you want you can change the size of the layer. You can make the size of this layer same as the size of the flower. For this, after selecting the layer, click the menu item **Layer → Autocrop Layer**. Now the size of the new layer is changed to fit the size of the image in that layer. You can see a yellow border line around the flower. This shows the layer boundary. See Figure 6.35.

![Fig.6.34: Layer showing image of a flower](image-url)
The **Layers** dialog now shows the two layers. See Figure 6.36. Make three duplicate copies of this layer and move the image in each layer as shown in Figure 6.37. For creating duplicate layers, right click on the layer to be duplicated in the **Layers** dialog and select **Duplicate Layer** or use the menu **Layer → Duplicate Layer**.

Now, let us align all these pictures. For this, select the **Align** tool from the **Toolbox**. Then click the topmost flower. Holding down the **Shift** key, select the flowers one by one from top to bottom. After selecting, the image will be as shown in Figure 6.38. Note the four small squares at the corners of each of the image. This shows that the image is selected for alignment. To deselect an image, click the image, while keeping the **Shift** key pressed.
The lower portion of the Toolbox will be as shown in the Figure 6.39. Now click the Relative to drop down list. You will have the options as shown in the Figure 6.40. Here you can choose from the different alignment options. You can choose the First Item from this list of options. After that, click the button , which is just below the Relative To drop down list.

![Tool Options](image1)

*Fig. 6.39 : Tool Options*

When you click the button, the left edges of all the images will be aligned to the left edges of the first selected image as shown in Figure 6.41.

You can try other options and observe the changes. Now let us see how to distribute these images evenly. For this you must know the height of each flower. Here the flower is of 90 pixels high. So, in the Offset box, enter the value 100 as shown in Figure 6.42. Then click the button. When you click this button, the top edge of the second image will be moved 100 pixels away from the top edge of the first image. The top edge of the third image will be moved 100 pixels away from the top edge of the second image and so on. The image after the distribution will be as shown in Figure 6.43.

![Align options](image2)

*Fig. 6.40 : Align options*

![Images aligned to the first flower](image3)

*Fig. 6.41 : Images aligned to the first flower*
In the Figure 6.43 you can see that all the images are evenly distributed. Now let us set 35 as the offset value and press the button. The images will be distributed as shown in the Figure 6.44. When you press the button, right edge of each image is moved 35 pixels away from the right edge of the previous image.

You can set different values as the offset and try clicking the different buttons below the Distribute options in the Toolbox and observe the changes in the image.

Let us now try to align the picture in another way. Consider the image with flowers in different layers as shown in Figure 6.45.
Select the background layer by clicking it in the **Layers** dialog. Now select the **Rectangle Select** tool from the **Toolbox**. Make a small selection in the background as shown in Figure 6.46. Now let us align the entire flowers to the selection. For this click the **Align** tool in the **Toolbox**. Select the flowers one by one from top to bottom by clicking them. Make sure that the **shift** key is down while clicking each flower. Then click the **Relative To** drop down list and select **Selection** from the list of options. Then click the **button. All the images will be aligned to the left edge of the selected area as shown in Figure 6.47.

![Fig. 6.45 : Flower image](image)

Thus you can align the image or layers to any location on the image.

### 6.10.2 Move

The **Move** tool is used to move layers or selections. While moving a layer or text, make sure that the **Move the Active Layer** option of **Move** tool is selected. We have moved layers and text when we designed the 'Anti-smoking Campaign' poster.

![Fig. 6.46 : Selection using Rectangle Select tool](image)

![Fig. 6.47 : Images aligned to the right](image)
6.10.3 Crop

The Crop tool is used for cropping or clipping an image. It works on all the visible and invisible layers of the image. To crop an image, select the Crop tool from Toolbox or from Tools → Transform Tools → Crop. See the image Figure 6.48. Suppose you need to keep only the first parrot in the figure and discard the rest. For this, select the Crop tool from the Toolbox. Draw a rectangle around the first parrot as shown in the Figure 6.49.
From the figure, you can see that the rectangle does not cover the parrot properly. This will not be a problem. You can easily change the dimensions of the selected area by dragging any one corner of the selected region. When you move the mouse pointer to different regions of the selection, you can see that the cursor changes to different shapes. This shows that you can change the selection by dragging it. Drag the top right corner of the selection so that the selection completely covers the parrot, as shown in Figure 6.50.

Once you are satisfied with the selection, double click the selected region or press the Enter key. You will get the cropped image as shown in Figure 6.51. You can see that the size of the canvas is now changed to the size of the cropped image. Note that, since cropping makes changes to the original image, it is always better to take a duplicate copy of the image (Image → Duplicate).

6.10.4 Rotate

Rotate tool is used to rotate an entire layer or only a selected portion of an image. You can rotate an image using Rotate tool in the Toolbox or using Tools → Transform Tools → Rotate.

First of all, let us see how to rotate a complete layer. Look at the following image (Figure 6.52). The image has two layers. The first layer is the 'Background' layer with the green colour and the second layer is the 'Bud' layer with a transparent background. When you hide the ‘Background’ layer, you will see the image as shown in Figure 6.53.

The check pattern in the background shows that it is transparent. Almost all image editing software use this pattern to represent transparency. Now, make the two layers visible as in Figure 6.52. Then select the New layer by clicking it in the Layers dialog. Then select the Rotate tool from the Toolbox. Click on the image. Then you will get a
Rotate dialog box as shown in Figure 6.54. You can drag the image clockwise or anti-clock wise to rotate the image. The Rotate dialog box will display the angle of rotation. You can drag the slider just below the box to set the angle, or you can directly enter the angle of rotation in the box provided. Once you are satisfied with the angle, click the Rotate button in the dialog box. You will get the image as shown in Figure 6.55.

Now let us see how to rotate only a selected portion of a layer or image. See the image in Figure 6.56. Let us try to rotate only the head of the bird. Select the head portion of the bird using the Ellipse Select tool as shown in Figure 6.57.
Now select the **Rotate** tool from the **Toolbox**. Then rotate the selected region slightly towards the clockwise direction as shown in Figure 6.58 (a). Click the Rotate button in the **Rotate** dialog box (Figure 6.58 (b)). You will get the image as shown in Figure 6.59.

The rotated image is displayed as a new floating layer. To fix this floating layer to its background, click the anchor icon in the **Layers** dialog. This fixes the rotated image. Floating layer is created only when an image without layers is rotated. Note that when a separate layer is rotated, as in the previous example, a floating layer will not be created.

After rotating, you can see that the head does not properly join the body of the parrot at the left and right sides. You can use the **Clone** tool and **Bucket Fill** tool which you have learned in the high school classes to fill this area as shown in Figure 6.60. You can also see a cut edge around the rotated region. This can be removed by using **Smudge** tool and finally you will get the parrot as shown in Figure 6.61. Observe the difference between the parrots in Figure 6.56 and that in 6.61.
6. Getting Started with GIMP

6.10.5 Scale

We have used the Scale tool for designing the poster for 'Anti-Smoking Campaign'. The Scale tool is used to scale layers or selections on the image. We can specify the Height and Width in the Scale dialog box for scaling. The image can also be resized using the handles at the borders of the image. Press the Scale button to complete scaling.

Aspect ratio is the ratio of height to width. If this ratio is altered, the image will get distorted. The aspect ratio can be kept constant using the Linking Chain icon in the Scale dialog box.

6.10.6 Shear

Shear tool is used to shift one part of an image, a layer or a selection to one direction and the other part to the opposite direction. For instance, a horizontal shearing will shift the upper part to the right and the lower part to the left. Shearing distorts the image according to the horizontal and vertical co-ordinates specified.

Shear tool can be accessed from the Toolbox or from the Tools → Transform Tools → Shear. Let us consider the image of a bird (Figure 6.62).
To change the angle of the bird's direction using the Shear tool, select the tool, click on the image in the canvas and the Shear dialog box appears (Figure 6.63).

In the dialog box, type appropriate Shear magnitude for x and y coordinates. Note that you cannot shear both ways at the same time. If you need to do so, use the shear tool twice. The resultant image is shown in Figure 6.64.
6.10.7 Flip

The Flip tool provides the ability to flip layers or selections either horizontally or vertically. You can use this tool to create reflections. Flip tool can be accessed using the Flip tool in Toolbox or through the Tools menu.

Consider the image given below (Figure 6.65). You can see a bird in the canvas. Note that this canvas consists of two layers, one for the background and the other for the bird. Our aim is to take a reflection of the bird and keep it on the other side, so that the image looks like two birds sitting face to face.

Here first of all you have to duplicate the ‘Bird’ layer. For this, right click on the layer in the Layers dialog and select Duplicate Layer from the menu that appears. Note that a new layer is created above the bird layer in the Layers dialog. But the image in the duplicate layer cannot be seen as this duplicate is exactly above the original layer in the canvas. Now select the Flip tool and click on the image to create the reflection. Use the Move tool to arrange the birds to a proper position as shown in the Figure 6.66.
The effectiveness of a presentation, poster or any piece of graphic art can be enhanced using a suitable image. An image received may not be what we exactly require. This image can be edited using the different image editing software available. The different types of image editors like raster, vector and 3D modelers can be used to manipulate photographs, logos and characters in movies. GIMP is a popular GNU based raster graphics editor.

GIMP can be used to create and manipulate images using layers. The background colour of a canvas can be set and images can be copied on to it. The image created can be saved and exported to other popular image formats. Texts can be inserted to images in various fonts to make the graphic attractive. Parts of an image can be selected in a variety of shapes using different types of selection tools available in GIMP. The transform tools available in GIMP allow altering the appearance of an entire image or a part of it.
Learning outcomes

After the completion of this chapter the learner will be able to

• use GIMP software for simple image editing and image format converting.
• identify the role of layers in image editing software.
• identify various selection tools in GIMP to perform various operations.
• insert text in an image.
• use the various transform tools for manipulating images.
• use the saving and exporting options available in GIMP.

Lab activities

1. Design an identity card for your school with school logo and your photo. The reverse of the identity card should provide the address details.
2. Design a name slip with your photo in it.
3. Design a badge for the guests of your school annual day.
4. Download the picture of a lion and using it create an image of two lions standing face to face.
5. Download the picture of a KSRTC bus. Take 5 copies of the bus and arrange them as if they are ready for their inaugural run. Resize the bus if required.
6. Download the pictures of a bus and a tiger. Select and copy the image of the tiger and place it as a graphic painted on bus.
7. Download the picture of rose. Create a rectangular border of roses for a banner to welcome plus one students.

Sample questions

Very short answer type

1. Classify the following software and give suitable headings.
   CorelDRAW, GIMP, Photoshop, Inkscape, 3D Studio MAX
2. What do you mean by scaling? How can you avoid distortion of images while scaling?
3. How does Fuzzy Select work?
4. What do you mean by anchoring?

**Short answer type**

1. Compare raster and vector graphics.
2. Ravi is designing a logo for his company. Suggest an image editing software for this purpose. Justify your suggestion.
3. List the features of GIMP image editor.
4. What is a layer in GIMP? Explain the advantages of using layers.
5. How will you delete the white background of a flower image?
6. What is Foreground Select in GIMP? How can this be done?

**Long answer type**

1. What are the functions of an image editing software? List and explain the different categories of image editors with examples.
2. Explain any five selection tools available in GIMP.
3. Write short notes on any three transform tools in GIMP.
Advanced Tools for Image Editing

In the previous chapter you learned the use of some of the basic tools of GIMP. We have already discussed the use of layers in creating an image, how to use various selection tools to select a portion of an image, etc. In addition to these tools, GIMP provides a lot of very powerful tools, that make image editing very easy. In this chapter, we will discuss some of these tools.

### 7.1 Paths tool

Paths tool is used to create straight lined and smooth curved vector shapes and paths. This tool is very much useful to create different types of patterns, to select a portion of an image in different shapes from an already existing picture, etc.

Let us see how to use the Paths tool. Select the Paths tool from the Toolbox. The Paths tool is available in the menu Tools -> Paths. When the Paths tool is selected, the mouse cursor changes into a pointer (arrow) with a curve. Left click on the canvas to create the first point on the path. Move the mouse to a new point and left click the mouse to create another point linked to the previous point. When you move the mouse pointer to a new location to add new point, you can see that the mouse pointer has a little + symbol next to the curve. This shows...
that the clicking will add a new point. You can create any number of points like this as shown in Figure 7.1(a). When you want to close the figure, press the Control (\texttt{Ctrl}) key while clicking the first point.

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{fig7_1.png}
\caption{Fig. 7.1(a) Fig. 7.1(b)}
\end{figure}

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{fig7_2.png}
\caption{Fig. 7.2(a) Fig. 7.2(b)}
\end{figure}

In Figure 7.1(a) you can see that the points are not equally distributed. To distribute them equally, simply move the mouse pointer to one point. Then the mouse pointer will change its shape to cross arrow indicating that the point can be moved now by dragging it. You can drag each point to any location on the canvas. Move all the points so that it will look as shown in Figure 7.1(b).

Now, move the mouse pointer close to a line segment. Then the mouse pointer will change its shape to cross arrow. This shows that you can drag the line segment to change its shape from a straight line to a curve. Drag an edge of the figure as shown in Figure 7.1(c). When you drag the edge, the line segment bends and curves. You can see a new line segment starting from the point, showing the direction of the bend. This
line segment is called direction line. At the end of the direction line, you can see a square symbol. This square symbol is called the handle of the direction line. You can drag this handle to modify the shape of the curve. Each point on the path is also called an anchor point.

Drag the two handles so that the figure will look as shown in Figure 7.2(a). Modify the other edges also so as to get the image as shown in Figure 7.2(b). If you are satisfied with the shape of the figure, you can make a selection along the drawn path. For this, right click on the canvas. You will get a menu item as shown in Figure 7.3. Select the menu item **Select → From Path**. On clicking the menu item, the path will be made as a selection as shown in Figure 7.4.

This selection provides you with many options. You can select the **Blend** tool from the Toolbox. Then choose a gradient colour scheme and fill the selected region by dragging inside the region. You will get a coloured flower as shown in Figure 7.5.
You can copy and paste the selected region to some other layers. Fill the selection with different colours. If you want, you can change the size of the flower by **Scaling** tool. Figure 7.6 is obtained by copying the given flower into different layers and then changing the colour and size.

### 7.1.1 Adding and removing anchor points from a path

Consider a path with three anchor points as shown in Figure 7.7(a). To add one more anchor point in this path, move the mouse pointer on a line segment and press the **Ctrl** key down. Now you can see that the mouse pointer has a + symbol. This shows that you can add a new anchor point at this location. Now keeping the **Ctrl** key down, click on the line. You will get an anchor point at the clicked location as shown in Figure 7.7(b). Drag this anchor point as shown in Figure 7.7(c). You can see that the two line segments on either side of this new point have a slight bend. This is due to the direction lines on that point. If you want to remove this bend, you can delete the direction line. To do this, move the mouse over the handle in the direction line. Press the **Ctrl** and **Shift** keys together. Now you will see a minus (−) symbol on the mouse pointer. This minus symbol shows that you can remove this handle on clicking it. Click the handle by holding the **Ctrl** and **Shift** keys down. You can remove the two direction lines by doing like this. You will get the path as shown in Figure 7.7(d).
How can you remove an anchor point? Simply move the mouse pointer on the anchor point, press the `Ctrl` and `Shift` keys down and then click the anchor point. It will be removed from there. Figure 7.7(e) is the path obtained after removing the topmost anchor point from the path in Figure 7.7(d).

### 7.1.2 Selecting a portion of an image using Paths tool

Using Paths tool, you can select any part of an image in any shape. Consider an image in Figure 7.8. Suppose you want to copy a portion of this image to a new canvas. Use the Paths tool to draw the path along the boundary of the portion to be copied to the new canvas. Figure 7.9 shows the image after drawing the path.

Right click this path and select the menu item **Select → From Path**. The same thing can be done by clicking the **Selection from Path** button in the Toolbox. The portion of the image is selected as shown in Figure 7.10. Now you can press **Ctrl+C** to copy the selected portion and paste this to a new canvas as shown in Figure 7.11. After pasting the image to the new canvas, the size of the pasted image is scaled to make it as shown in the Figure 7.11.
In the previous chapter, you learned the use of selection tools. But in some situations, the Paths tool will help you to select a portion of an image more accurately than the selection tools.

### 7.1.3 Paths dialog box

After drawing a path, if you select any other tool from the Toolbox, the path will disappear from the screen. You may think that the path is gone for ever. But it remains in the image in a hidden form. You can make the path visible or hide it easily using the Paths dialog box.

Draw a path on the canvas as shown in Figure 7.12. Now click any of the selection tools from the Toolbox. You will see that the path has disappeared from the canvas. To view this path again, you can make use of the Paths dialog box. To get this dialog box, select the menu item Windows → Dockable Dialogs → Paths. Then you will get the dialog box as shown in Figure 7.13. This dialog box is very much similar to Layers dialog box. Each path we draw on the canvas has an entry in this dialog box. There is an eye icon at the left side of each entry. Just like layers, you can click on this eye icon to make the path visible or invisible. The Paths dialog box in the figure does not have the eye icon at the left side. It means that the path is hidden. To make it visible, simply click at the leftmost side on this entry. You will see the eye icon appearing there (Figure 7.14). At the same time, the path will be made visible on the canvas.
7.1.4 Aligning text to a path

You can align a text along a path. This is another advantage of using the Paths tool. To begin with, let us select the Text tool from Toolbox and type a text on the canvas as shown in Figure 7.17. Then draw a path on the canvas using Paths tool as shown in Figure 7.18.
Select the **Text** tool again from the **Toolbox** and click on the typed text. You will see that the path has disappeared from the canvas. To make the path visible, open the **Paths** dialog box and click at the left side of the path entry in it. Select the text typed by clicking on it. Now the lower portion of the **Toolbox** has a button named **Text along Path** as shown in Figure 7.19. Click on this button. The same feature is also available in the menu **Layer → Text along Path**. You will see that a copy of the text entered is aligned onto this path as shown in Figure 7.20.

![Fig. 7.19 : Toolbox options](image1)

When you look at the **Paths** dialog box, you will see one new entry there (Figure 7.21). This entry shows that the text aligned to the path forms a new path. You can see that the text aligned is not filled with any colour. It is only an outline. GIMP treats this text outline as a path. This new path is displayed in the **Paths** dialog box as a separate entry. Right click on this new entry in it. From the popup menu you can select the menu item **Path to Selection** as shown in Figure 7.22. On selecting this, you

![Fig. 7.20 : Text aligned to path](image2)

![Fig. 7.21 : Path dialog box](image3)

![Fig. 7.22 : Paths dialog box menu](image4)
can see that the aligned text outline will be made a selected region in the canvas. Now you can colour the selected area using **Bucket Fill** tool or **Blend** tool. If you use **Gradient Fill** tool, you will be able to fill the selected region as shown in Figure 7.23. Before applying the fill tool, select the ‘Background’ layer from the **Layers** dialog box.

The canvas displays two copies of the text (Figure 7.23). You can remove the first copy of the text by using **Layers** dialog. The **Layers** dialog will display the text that is entered at the beginning as a separate layer as shown in Figure 7.24. You can hide this layer by clicking on the eye icon in it. Then the layer is hidden and the image will be as shown in Figure 7.25.

Now, the canvas displays two paths. To remove these paths, you can use the **Paths** dialog box. Click on the eye icon against each path entry in it. After clicking the eye icons, **Paths** dialog box will be as shown in Figure 7.26.
After making the paths invisible, the canvas will be as shown in Figure 7.27. If you want, you can resize this text so as to form the image in Figure 7.28 using the Resize tool.

![Text after removing path](image1)

![Using Resize tool](image2)

**Check yourself**

1. Which is the tool used to create straight lined or curved paths?
2. Each point in the path is called _______
3. Each anchor point has _______ number of direction lines.
4. What will you do to add a new anchor point on a line segment?
5. To remove an anchor point or handle, click on it, while keeping the ______ and _____ keys down.
6. What can be used to make a path visible or invisible?

In case the Tool Options in the Toolbox is not visible, double click on any tool in the Toolbox. The Tool Options dialog box appears as a new window.

Now, this Tool Options window has to be docked to the Toolbox window. For this, move the mouse just below the Title bar of the Tool Options dialog box. See that the mouse pointer turns to a pointed finger. Now drag the Tool Options window and drop to the tool option area in the Toolbox window.
7.2 Managing colours in GIMP

There are different ways to select and manage colours in GIMP. We will discuss some of them in the following sections.

7.2.1 Selecting colours in GIMP

You have already used the colour palette for changing colours in GIMP. Now we will discuss the various methods for selecting colours in GIMP. The lower portion of the Toolbox displays two rectangles as shown in Figure 7.29. The upper rectangle represents the foreground colour and the lower rectangle represents the background colour. When you click on the upper or lower rectangle to change the foreground or background colour, you will get the dialog box as shown in Figure 7.30.

The color dialog box can display the colours in five different ways. They are:

1. GIMP
2. CMYK
3. Water Color
4. Wheel
5. Palette

**a. GIMP:** Click the leftmost button on the top of the color dialog box to use the GIMP style for selecting colour. Figure 7.30 shows the color dialog box after clicking the leftmost button.

You can select a colour by clicking on the vertical color bar as shown in the figure. The left side square region shows the various shades of the selected colour. Now, you can click anywhere in this square region to select a proper shade of the selected colour. A rectangle just below the square region shows the selected colour. Finally, click the OK button to confirm the selection.
b. **CMYK**: Click the second button on the top of the color dialog box for using the CMYK style. Figure 7.31 shows the color dialog box in CMYK style. This model uses four colour components to represent a colour. They are Cyan, Magenta, Yellow and Key (black). This style is widely used in printing purpose. The rectangular region at the left side has four sliders representing the colours Cyan, Magenta, Yellow and Black. You can drag the slider to increase or decrease a particular component of colours.

![Drag the sliders to increase or decrease a component of colours.](image1)

**Fig. 7.31: Color dialog box - CMYK**

---

**c. Water Color**: This style can be used to mix one colour with another colour just like an artist mixes different colours to form a new colour. To use this, click the third button on the color palette. Then the color dialog box will be as shown in Figure 7.32.

![Click the left mouse button here to add a tint of green colour to the already selected colour.](image2)

**Fig. 7.32: Color dialog box - Water Color**
Suppose you have selected one colour, for example yellow. If you want to mix a light tint of another colour, for instance green with this yellow colour, click the left mouse button at the green colour in the large square colour region. You can keep on clicking the left mouse button to add the tint of green colour again and again. To remove the tint of green colour from the selected colour, you can right-click the mouse.

d. **Wheel**: To use this, click the fourth button in the color dialog box. Then the color dialog box will be as shown in Figure 7.33. Here, all the colours will be displayed in the form of a circular wheel. You can select a colour from this wheel by clicking it. Then the triangle at the center shows various shades of the selected colour. You can click inside this triangle to select a particular shade of the selected colour.

e. **Palette**: Palette option offers a wide range of colours. GIMP has a large number of predefined colour palettes. You can view the colours available in the active palette by clicking the fifth button in the color dialog box. After clicking this button, the color dialog box will be as shown in Figure 7.34.
Figures 7.36 and 7.37 show the colours available in various palette boxes after selecting them from the Palettes dialog box.

On clicking the Palette button, the color dialog box shows the default colour palette. The GIMP has a large number of colour palettes. To use the colour palettes, first of all you should make the Palettes dialog box visible. For this, use the menu item Windows → Dockable Dialogs → Palettes. On clicking this menu item, you will get the Palettes dialog box as shown in Figure 7.35. This Palettes dialog box shows a number of palettes predefined in GIMP. When you click on a palette in this Palettes dialog box, the colour dialog box will display the various colours available in this palette. You can easily select a colour from this palette, by clicking on the colour from the color dialog box.
7.2.2 Picking a colour from an image

You can pick a colour from an image or from any other place on the GIMP screen. For this click the **Color Picker** tool on the color dialog box. You can see this tool in Figure 7.38. The same picker tool is available in the main **Toolbox** also. When you click this tool, the mouse pointer will be changed into the shape of a filler. You can click on an image or anywhere on the GIMP screen to select the colour at that spot.

![Color Picker tool](image)

*Fig. 7.38: Color Picker tool*

7.3 Colour schemes

There are two types of colour schemes: subtractive colour scheme and additive colour scheme. When an artist paints a picture, he may mix a number of colours to make new colours. Here he is using the subtractive colour method. When an artist uses a computer to create a picture, he is using the additive colour method to create colours.

7.3.1 Subtractive colour

When you mix colours for painting or in the printing process, you are using the subtractive colour method. In this method, the colour mixing begins with white and ends with black. As one adds colour, the resultant colour gets darker and tends to blacken. Here absence of any colour is represented by white and the presence of all the colours is represented by black.

CMY method is the most popular subtractive colour method used in photography. It uses Cyan, Magenta and Yellow colours to generate all other colours (Figure 7.39).
CMYK is the subtractive colour method used in colour printing (Figure 7.40). Even though the black colour can be made by mixing Cyan, Magenta and Yellow, to reduce the cost of these colours, this method uses black colour also. The black colour is also called the Key colour and hence the name CMYK.

7.3.2 Additive colour

This method is used in computer and television screens to display pictures. The colours we see on the computer screen are created by using Red, Green and Blue (RGB) lights in the additive colour method. In this method, mixing begins with black and ends with white (Figure 7.41). As one adds colour, the resultant colour gets lighter and tends to become white. In this method, the absence of colour is represented by black and presence of all the colours is represented by white. Red, Green and Blue are the primary colours in light. This method uses these three components (RGB) to generate any colour (Figure 7.42).
The following table gives a comparison of subtractive and additive colour methods.

<table>
<thead>
<tr>
<th>Subtractive Colour Method</th>
<th>Additive Colour Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Used in colour printing</td>
<td>Used in computer and Television screens</td>
</tr>
<tr>
<td>Mixing begins with white and ends with black</td>
<td>Mixing begins with black and ends with white.</td>
</tr>
<tr>
<td>Use Cyan, Magenta and Yellow colour components to create colours</td>
<td>Use Red, Green and Blue components to create colours.</td>
</tr>
<tr>
<td>Absence of colours is white</td>
<td>Absence of colour is black</td>
</tr>
<tr>
<td>Presence of all the colours is black</td>
<td>Presence of all the colours is white</td>
</tr>
</tbody>
</table>

*Table 7.1: Colour scheme comparison*

**Check yourself**

1. In the subtractive colour method, the mixing of colours begins with _______ and ends with _______ colours.
2. In the additive colour method, the presence of all the colours is _______ colour.
3. In the subtractive colour method, the absence of all the colours is _______ colour.
4. CMY colour method is used in __________.
5. CMYK colour method is used in __________.
7.4 Setting the brightness and contrast of an image

When you take a photograph in insufficient light, the picture may appear too dark. The darkness of the picture can be reduced by setting the brightness and contrast of the picture. For setting brightness and contrast, you have to choose the menu item **Tools → Colour Tools → Brightness-Contrast**. You can effectively use brightness and contrast to give proper light to a dark photograph. Figures 7.43 and 7.44 show two photographs before and after applying the brightness and contrast.

![Fig. 7.43: Before applying Brightness-Contrast](image1)

![Fig. 7.44: After applying Brightness-Contrast](image2)

Drag these sliders to increase or decrease Brightness/Contrast

When you select the menu item **Tools → Color Tools → Brightness-Contrast**, you get a dialog box as shown in figure 7.45. You can set the brightness and contrast in this dialog box by dragging the sliders of **Brightness** and **Contrast**. While moving, one can preview the changes in the picture. When you are satisfied with the changes, click **OK** button.

![Fig. 7.45: Brightness-Contrast dialog box](image3)
7.5 Colour balancing

The Colour Balance option allows us to correct an image by balancing the colors. To change the colour balancing, use the menu item Colors → Color Balance. On clicking this menu, you will get the Color Balance dialog box as shown in Figure 7.46.

![Color Balance dialog box](image1)

Drag the Cyan, Magenta and Yellow sliders to change the colour balance.

Fig. 7.46 : Colour Balance dialog box

![Before applying colour balance](image2)

**Fig. 7.47 : Before applying colour balance**

![After applying colour balance](image3)

**Fig. 7.48 : After applying colour balance**

On the Color Balance dialog box, select Shadows, Midtones or Highlights as the Range to Adjust. Selecting Shadows affects darker pixels, Midtones affects medium range of pixels and Highlights affects bright pixels. After selecting the range, you can move the sliders Cyan, Magenta and Yellow to adjust the colour balance.
Figures 7.47 and 7.48 show the same image before and after applying colour balance as in Figure 7.49. When you have placed the three sliders in the appropriate positions for colour balancing, you can save this setting. For this, click the ‘+’ button which is at the right side of the **Color Balance** dialog box. This will prompt us to enter a name for the settings, as shown in Figure 7.50. You can give a suitable name and click **OK** button. Later, if you want to apply the same colour balancing for any other image, you can get this from the preset drop down list of the color balance dialog box. See Figure 7.51.

### 7.6 Filters

Filter is a very powerful tool that can modify an image in different ways. You can add various effects in an image using filters. Filters can be applied to a complete layer or only to a selected region. If a portion of an image is selected before using the filters, then filtering will be applied to the selected region only. Following are the important and most commonly used filters available in GIMP.

#### 7.6.1 Blur

These filters blur images in a variety of ways.

- **Gaussian Blur**: When you use this filter, the image will have an out of focus effect. It will blur the sharp edges with the background. Use the menu item **Filters \(\rightarrow\) Blur \(\rightarrow\) Gaussian Blur** for this.
When you click this menu item, you will get a **Gaussian Blur** dialog box where you can specify the **Blur Radius**. Fig. 7.52 and 7.53 shows the image before and after applying **Gaussian Blur** respectively.

b. **Simple Blur**: This can be used to blur the image a little bit. It will simply soften the image without prompting a dialog box. Use the menu item **Filters → Blur → Blur** for this. The image in Figure 7.54 is obtained by applying simple blur to the image in Figure 7.52.

c. **Motion Blur**: It blurs the image in a specific direction at each point. You can create a sense of motion in the image using this. Use the menu item **Filters → Blur → Motion Blur** for this. When you click the menu item, you will get a dialog box where you can specify the blur type such as **Linear**, **Radial** or **Zoom** and also the **Blur Parameters** such as **Length** and **Angle**. Figure 7.55 shows the image after applying **Motion Blur**.

d. **Pixelize**: It will blur the image into a set of large squares. Use the menu item **Filters → Blur → Pixelize** for this. You can specify the size of the square in the dialog box that comes in. Fig. 7.56 shows the image after applying this filter.

e. **Selective Gaussian Blur**: In this method, only pixels that are similar to each other are blurred. It is useful to reduce grains in photos without blurring the sharp edges. Use the menu item **Filters → Blur → Selective Gaussian Blur** for this. Figure 7.57 shows the image after applying **Selective Gaussian Blur**. You can see that the grains of the background have been blurred without blurring the edges of the rose flower.
7.6.2 Sharpen

This filter is used to sharpen the edges of an image. When you sharpen an image, you will get a better clarity in the image. This is the reverse of blur filter. Use the menu item Filters \(\rightarrow\) Enhance \(\rightarrow\) Sharpen for this. Figures 7.58 and 7.59 show the images before and after applying this filter.

![Fig. 7.58 : Before applying Sharpen](image)

![Fig. 7.59 : After applying Sharpen](image)

7.6.3 Distorts

These filters transform the image in different ways. There are a number of options available in this category. Following are the most commonly used Distorts filters. They are available in the menu item Filters \(\rightarrow\) Distorts.

a. Emboss: This filter stamps and carves the image, giving it an appearance of a relief with bumps and hollows. The bright areas in the image are raised and the dark ones are carved (refer Figure 7.61).
b. Mosaic: This filter cuts the image into many polygons which are slightly raised and separated by joints to create the appearance of a mosaic (refer Figure 7.62).

c. Ripple: This filter displaces the pixels of the image to create waves or ripples as on a reflection on disturbed water. Figure 7.63 is the image obtained after applying Ripple filter to the image in Figure 7.60.

d. Shift: This filter shifts all pixels horizontally or vertically. Fig. 7.64 is the image obtained after applying the Shift filter to the image in Figure 7.60.

e. Waves: With this filter you can get an image similar to the concentric waves created when a stone is thrown into water. Figure 7.65 is the image obtained after applying the Waves filter to the image in Figure 7.60.

f. Wind: This filter will generate thin black and white lines in the image to create a windy effect. Figure 7.66 is the image obtained after applying the Wind filter to the image in the figure 7.60.
b. Lightning Effects: This filter simulates the effect when you light up an image with a spot. Figure 7.69 shows the image after applying the Lightning Effects filter. You can change the colour of lightning from the dialog box that comes in. The given image uses white colour for giving the lightning effect.

Fig. 7.67 : Image before applying Light and Shadow filter
Fig. 7.68 : After applying Lens Flare

Fig. 7.69 : After applying Lightning Effects
Fig. 7.70 : After applying Supernova
c. **Supernova**: This filter creates a big star reminding a supernova. Figure 7.70 shows the image after applying the **Supernova** filter. You can change the supernova colour from the dialog box that comes in. The given image has used yellow colour for giving the supernova effect.

GIMP provides a number of other filters also in this category. You can try out these filters and observe the changes in the image.

### 7.5.5 Artistic

These filters are used to create artistic effects in the image. Following are some of the commonly used filters in this category. These filters are available in the menu item **Filters → Artistic**.

a. **Clothify**: This filter adds a cloth like texture to the image.

b. **Cubism**: This filter modifies the given image in such a way that it is made up of small cubes. You can set the size of the cube in the dialog box that appears.

c. **Oilify**: This filter modifies the image like an oil painting.

d. **Soft Glow**: This filter lights the image with a soft glow.

e. **Weave**: This filter modifies the image as if it were printed over woven ribbons of paper.

![Fig. 7.71 : Before applying Artistic filter](image1)

![Fig. 7.72 : After applying Clothify filter](image2)

![Fig. 7.73 : After applying Cubism](image3)

![Fig. 7.74 : After applying Oilify](image4)
There are so many specialised softwares for creating animations. GIMP can also be used to create simple preset animations. We will discuss how to give animation effects to an image using GIMP, in the following section.

Let us open an image as shown in Figure 7.77. This image is created using Logos in GIMP. You have already studied the creation of logos in lower classes. You can create different types of logos using the menu item File → Create → Logos.

Different types of animations can be created using GIMP. Let us discuss two of them:

1. Rippling
2. Burn-In

All these animations are available in the menu item Filters → Animations.

a. Giving Rippling animation

After opening the image as shown in Figure 7.77, select the menu item Filters → Animations → Rippling. On selecting this, you will get a dialog box as shown in Figure 7.78. You can set different parameters for the animation from this dialog box. Or you can simply leave the default values and click the OK button.
Now GIMP will create a new image as shown in Figure 7.79.

To play this animation, select the menu item **Filters → Animation → PlayBack** from the new image. Then you will get a window as shown in Figure 7.80. To play the animation click on the **Play** button on the top of this window as shown in Figure 7.80. You will see a rippling animation in this window.

To save this animation, you have to save this file as a *gif* file. Only *gif* file can show the animation. Click on the menu item **File → Save As**. Then you will get a new window where you can specify name of the file. You can give any name for the file. But at the end of the name you can type *gif* as the extension for the file. After giving the name, click the **Save** button. Then you will get an **Export** dialog box as shown in Figure 7.81.

In the **Export** dialog box, select the **Save As Animation**, which is shown in Figure 7.81. Then click the **Export** button. The new *gif* file is saved in your computer. This file with the animation can be used for different purpose such as for creating presentations or webpages.

**b. Giving Burn-In animation**

This animation requires an image with two layers. Create one more layer with white colour. After creating the layer, the **Layers** dialog will be as shown in figure 7.82. Now select the menu item **Filters → Animations → Burn-In**. Then you will get a dialog box. Click **OK** button from this dialog.
box. Now GIMP will create a new image with the animation as shown in Figure 7.83. When you play back this image, you will see that the image is slowly appearing in the window as shown in Figure 7.84. You can export this animation as a gif file for future use.

Fig. 7.83 : Image after applying Burn-in

Fig. 7.84 : Playing animation

Check yourself

1. To save an animation in GIMP, it must be saved in _______ format.
2. The filter that can be used to give more clarity to the edges of an image is _______.
3. Compare Gaussian blur and Selective Gaussian Blur.
4. The artistic filter that lights the image with a soft glow is _______.
5. How can we use a colour balance setting previously saved when an image is edited?

Let us sum up

GIMP provides a number of powerful tools to enhance the appearance of an image. The Paths tool can be used to draw a path on the canvas very easily. We can create different types of patterns using the Paths tool. We can copy a portion of an image in any shape using this tool. We can also align a text to a path. The colour dialog box in GIMP can display the colours in five different ways such as GIMP, CMYK, Water Colour, Wheel and Palette. A light picture can be made dark or a dark picture can be made light by setting the brightness and contrast of the image. We can give a different colour effect to an image by setting the Color Balance. Subtractive and Additive colour schemes are the two widely used colour schemes. Subtractive colour scheme is used in printing. Additive colour scheme is used in television and computer screens. GIMP provides a large number of filters, that can modify an image in different ways. Gimp can also be used to create simple animations.
Learning outcomes

After the completion of this chapter the learner will be able to
• use paths tool to draw various patterns.
• use paths tool to copy any portion of an image in any shape.
• use paths tool to align text to a path.
• use the colour dialog box in different ways to select a colour.
• adjust the brightness and contrast of an image.
• adjust the colour scheme of an image.
• differentiate the use of subtractive and additive colour schemes.
• use filters in a variety of ways to modify an image.
• use filters to create animations.

1. Using Paths tool draw the following images.
   a) ![Image](image1.png) b) ![Image](image2.png)

2. Open an image containing a human figure. Use the paths tool to select the human figure and copy the figure in another image.

3. Using Paths tool, align a text as shown in the figure.

4. Open a landscape image in GIMP. Apply various Blur filters on this image. Save the image as jpg file after applying each filter.

5. Open a landscape image in GIMP. Apply various Distort filters on this image. Save the image as jpg file after applying each filter.

6. Open a landscape image in GIMP. Apply various Artistic filters on this image. Save the image as jpg file after applying each filter.

7. Open a landscape image in GIMP. Apply different Light and Shadow filters on this image. Save the image as jpg file after applying each filter.

8. Create a logo with text “WELCOME”. Save this logo as a jpg file. Then open this jpg file in GIMP. Create a rippling animation with this image and save the file in ‘gif’ format.

9. Open an image in Gimp. Change the colour scheme and save the new image with a different name.
Sample questions

Very short answer type
1. Each point in the Paths tool is called ___________.
2. To create a closed path, click on the first point while holding the _______ key down.
3. _______ dialog box is used to make a path visible or invisible.
5. Presence of all colours in additive colour method gives _______ colour.
6. CMYK colour scheme is used in _______ purpose.
7. The letter ‘K’ in CMYK represents _______ colour.
8. ‘Cubism’ filter is available in _______ category of filters.
9. What is an anchor point?
10. What is a direction line?
11. How can you add a new point in a path?
12. How can you remove a point from the path?
13. What is the use of Paths dialog box?
14. How can you give brightness to a photograph appearing dark?

Short answer type
1. Explain the steps to align a text to a path.
2. Explain the steps to create an animation in GIMP.
3. Explain different colour schemes.
4. Explain any three Blur Filters.
5. Explain any three Artistic Filters.
6. Explain any three Distorts Filters.
7. Explain the use of Paths tool.
8. What is the use of colour balancing? How is it done?

Long answer type
1. Explain the various styles for displaying colours in colour dialog box in GIMP.
2. Explain various categories of filters available in GIMP.
3. How do you create animation in GIMP?
Have you surfed the Internet to search your examination result or to know whether you got admission to the Plus One course in a school of your choice? Have you visited an ATM counter to draw money? Have you transferred songs, images or movie clips from your computer to a cell phone or booked a train ticket using Internet? If your answer to any of these questions is ‘yes’, you have accessed the services of a computer network. In this chapter, we will learn more about the working of networks and their advantages. We will also discuss different media and devices, different types of networks and the rules to be followed in data communication using these devices.

8.1 Computer network

Computer network is a group of computers and other computing hardware devices (such as printers, scanners, modems, CD drives, etc.) connected to each other electronically through a communication medium. They can communicate with each other, exchange commands, share data, hardware and other resources. Computers on a network may be linked through cables, telephone lines, radio waves, satellites or infrared light beams.
8.1.1 Need for network

Internet is a good example for a computer network. It is impossible to imagine a world without e-mails, online newspapers, blogs, chat and other services offered through the Internet. Apart from these, there are many other advantages in using networked computers instead of stand-alone computers. Some of them are listed below.

- Resource sharing
- Price-performance ratio
- Communication
- Reliability
- Scalability

**Resource sharing:** The sharing of available hardware and software resources in a computer network is called resource sharing. For example, the contents of a DVD placed in a DVD drive of one computer can be read in another computer. Similarly, other hardware resources like hard disk, printer, scanner, etc. and software resources like application software, anti-virus tools, etc. can also be shared through computer networks.

**Price-performance ratio:** One can easily share the resources available in one computer with other computers. The cost of purchasing licensed software for each computer can be reduced by purchasing network versions of such software. This will least affect the performance of such resources and lead to considerable savings in cost.

**Communication:** Computer network helps user to communicate with any other user of the network through its services like e-mail, chatting, video conferencing etc. For example, one can send or receive messages within no time irrespective of the distance.

**Reliability:** It is possible to replicate or backup data/information in multiple computers using the network. For example, the C++ files, photos or songs saved in one computer can also be saved in other computers in the same network. These can be retrieved from other computers in which they are saved in case of disasters (malfunctioning of computers, accidental deletion of files, etc.)

**Scalability:** Computing capacity can be increased or decreased easily by adding or removing computers to the network. In addition to this, the storage capacity of networks can also be increased by including more storage devices to the network.
8.1.2 Some key terms

Some of the key terms related to computer network are explained below:

**Bandwidth**: Bandwidth measures the amount of data that can be sent over a specific connection in a given amount of time. Imagine you are in a highway or a public road. The bigger the road, the more will be the number of vehicles that can travel on it. Moreover, the traffic here is faster than on a narrow road. On a narrow road, the traffic is likely to be congested. We can say that the bandwidth of a bigger road is higher than a narrow road.

Bandwidth describes the maximum data-transfer rate between computers in a network. In digital systems, bandwidth is measured in bits per second (bps). If the bandwidth is more, data travels faster and hence large amounts of data can be transferred within a particular time span across the network. For example, an Internet connection via cable modem may provide 25 Mbps of bandwidth.

**Noise**: Noise is unwanted electrical or electromagnetic energy that lowers the quality of data signals. It occurs from nearby radio transmitters, motors or other cables. The transfer of all types of data including texts, programs, images and audio over a network is adversely affected by noise.

**Node**: Any device (computer, scanner, printer, etc.) which is directly connected to a computer network is called a node. For example, computers linked to the computer network in the school are nodes. When we connect the Internet to our computer, our computer becomes a node of the Internet.

---

Let us do

Make a list of the hardware and software resources shared in your school network.

---

8.2 Data communication system

In a computer network, computing devices are connected in various ways, to communicate and share resources. **Data communication** is the exchange of digital data between any two devices through a medium of transmission. Figure 8.1 show the representation of a general data communication system. The following five basic elements are necessary for building any data communication system.
**Fig. 8.1 : Data communication system**

Message : It is the information to be communicated. Major forms of information include text, picture, audio, video, etc.

Sender : The computer or device that is used for sending messages is called the sender, source or transmitter.

Receiver : The computer or device that receives the messages is called the receiver.

Medium : It is the physical path through which a message travels from the sender to the receiver. It refers to the way in which nodes are connected.

Protocol : The rules under which message transmission takes place between the sender and the receiver is called a protocol.

### 8.3 Communication medium

Data communication is possible only if there is a medium through which data can travel from one device to another. The medium for data transmission over a computer network is called **communication channel** or **communication medium**. The communication medium between computers in a network are of two types: guided and unguided. In guided or wired medium, physical wires or cables are used and in unguided or wireless medium radio waves, microwaves or infrared signals are used for data transmission.

#### 8.3.1 Guided medium (Wired)

The coaxial cable, twisted pair cable (Ethernet cable) and optical fibre cable are the different types of cables used to transfer data through computer networks.

**a. Twisted pair cable (Ethernet cable)**

This is the most widely used media in small computer networks. It consists of four twisted pairs which are enclosed in an outer shield. These pairs are colour coded. Twisted pair cables are of two types: (i) Unshielded Twisted Pair (UTP) cables and (ii) Shielded Twisted Pair (STP) cables.
Unshielded Twisted Pair (UTP) cable: As its name suggests, the individual pairs in UTP cables are not shielded. Figure 8.2 shows the components of a UTP cable.

**Characteristics of UTP cable**
- Low cost cable available for setting up small networks.
- Thin and flexible cable.
- Ease of installation.
- Carries data up to a length of 100 m at a stretch.

Shielded Twisted Pair (STP) cable: It is the same cable as the UTP, but with each pair shielded individually. An outer shield then covers all the pairs like in UTP.

**Characteristics of STP cable**
- Shielding in STP offers better immunity against noise.
- It is more expensive than UTP cable.
- Compared to UTP cable, STP cable is difficult to install.

An RJ-45 connector is used to connect UTP/STP twisted pair cable to a computer. Figure 8.3 shows the STP cable and RJ-45 connector.

b. Coaxial cable

A coaxial cable consists of an inner conductor surrounded by a tubular insulating layer which is further covered by a tubular conducting shield. It has an outer insulation to
protect the cable too. Figure 8.4 shows the construction of a coaxial cable.

**Characteristics of coaxial cable**

- Carries data to longer distances (185 m - 500 m) at a stretch.
- High bandwidth.
- Less electromagnetic interference due to the outer shield.
- Thicker than twisted pair.
- Less flexible than twisted pair.
- Difficult to install than twisted pair cable.

c. **Optical fibre cable**

Optical fibres are long thin glass fibres through which data is transmitted as light signals. Data travels as fast as light and can be transmitted to far off distances. Figure 8.5 shows the major parts of an optical fibre cable.

Optical fibre has the following parts:

- Core - the thin glass rod at the centre through which the light travels.
- Cladding - the outer optical material surrounding the core that reflects the light back into the core.
- Coating - the plastic coating that protects the cable from damage and moisture.

These optical fibres are arranged in bundles of hundreds and thousands and are protected by the outer covering of the cable called jacket.

At the source end, the optical transmitter converts electrical signals into optical signals (modulation) using semiconductor devices such as light-emitting diodes (LEDs) or laser diodes. At the destination end, the optical receiver, consisting of a photo detector, converts light back to electric signals (demodulation) using the photoelectric effect. The speed of transmission and the distance of signals are higher for laser diodes than for LEDs.
Characteristics of optical fibre cable

- High bandwidth for voice, video and data applications
- Carries data over a very long distance at a stretch.
- Not susceptible to electromagnetic fields, as it uses light for data transmission.
- The most expensive and the most efficient communication media available for computer networks.
- Installation and maintenance are difficult and complex.

8.3.2 Unguided medium (Wireless)

Electromagnetic waves are used for wireless communication on computer networks. Frequencies of waves are measured in Hertz (Hz). Based on their frequencies, electromagnetic waves are categorised into various types as shown in Figure 8.6. From this category we can infer that only radio waves, microwaves and infrared rays are used for wireless communication.

Fig. 8.6 : Electromagnetic Spectrum

a. Radio waves

Radio waves have a frequency range of 3 KHz to 3 GHz. Radio waves can be used for short and long distance communication. These waves are easy to generate and can penetrate through the walls of a building easily. That is why radio waves are widely used for communication—both indoors and outdoors. Cordless phones, AM and FM radio broadcast and mobile phones make use of radio wave transmission.

Fig. 8.7 : Radio wave transmission
Characteristics of radio wave transmission

- Waves are transmitted in all directions, therefore transmitting and receiving antennas need not be aligned face to face.
- Relatively inexpensive than wired media.
- Can penetrate through most objects.
- Transmission can be affected by motors or other electrical equipment.
- Less secure mode of transmission.
- Permissions from authorities concerned are required for the use of radio wave transmission.

b. Micro waves

Micro waves have a frequency range of 300 MHz (0.3 GHz) to 300 GHz. Microwaves travel in straight lines and cannot penetrate any solid object. Therefore, high towers are built and microwave antennas are fixed on their top for long distance microwave communication. As these waves travel in straight lines the antennas used for transmitting and receiving messages have to be aligned with each other. The distance between two microwave towers depends on many factors including frequency of the waves being used and heights of the towers. Figure 8.9 shows the components of a microwave transmission system.
Characteristics of micro wave transmission

- Relatively inexpensive than wired media.
- Offers ease of communication over difficult terrain.
- The transmission is in straight lines. Therefore, the transmitting and receiving antennas need to be properly aligned (line of sight transmission).

C. Infrared waves

Infrared waves have a frequency range of 300 GHz to 400 THz. These waves are used for short range communication (approx. 5 m) in a variety of wireless communications, monitoring and control applications.

Home entertainment remote control devices, cordless mouse and intrusion detectors are some of the devices that utilise infrared communication (refer Figure 8.10).

Characteristics of infrared wave transmission

- A line of sight transmission; hence information passed to one device is not leaked.
- Only two devices can communicate at a time.
- The waves cannot cross solid objects. (You may stand between the remote control and your television set and check whether the remote control works.)
- The longer the distance the weaker the performance.

8.3.3 Wireless communication technologies using radio waves

A. Bluetooth

Bluetooth technology uses radio waves in the frequency range of 2.402 GHz to 2.480 GHz. This technology is used for short range communication (approx. 10 m) in a variety of devices for wireless communication. Cell phones, laptops, mouse, keyboard, tablets, head sets, cameras etc. are some of the devices that utilise bluetooth communication (refer Figure 8.11).
**Characteristics of bluetooth transmission**

- Line of sight between communicating devices is not required.
- Bluetooth can connect up to eight devices simultaneously.
- Slow data transfer rate (up to 1 Mbps).

**b. Wi-Fi**

Wi-Fi network makes use of radio waves to transmit information across a network like cell phones, televisions, and radios. The radio waves used in Wi-Fi range from a frequency of 2.4 GHz to 5 GHz. Communication across a wireless network is two-way radio communication. The wireless adapter in a computer translates data into radio signal and transmits it using an antenna. A wireless router receives the signal and decodes it. Once decoded, the data will be sent to the Internet or network through a wired Ethernet/wireless connection. Similarly, the data received from the Internet/network will also pass through the router and coded into radio signals that will be received by the wireless adapter in a computer as indicated in Figure 8.12. Nowadays, this technology is widely used to share Internet connection with laptops or desktops.

**Characteristics of Wi-Fi transmission**

- Line of sight between communicating devices is not required
- Data transmission speed is up to 54 Mbps
- Wi-Fi can connect more number of devices simultaneously
- Used for communication up to 375 ft (114 m)

**c. Wi-MAX**

Worldwide Interoperability for Microwave Access (Wi-MAX) combines the benefits of broadband and wireless. Wi-MAX has a frequency range of 2 GHz to 11 GHz.
Wi-MAX can provide high-speed wireless Internet access over very long distances (a whole city). Wi-MAX equipment exists in two basic forms - base stations, installed by service providers to deploy the technology in a coverage area, and receivers, installed by clients. Figure 8.13 shows the basic components of a WiMAX transmission.

**Characteristics of Wi-MAX transmission**

- Hundreds of users can connect to a single station.
- Provides higher speed connection upto 70 Mbps over an area of 45 Kilometres.
- Line of sight between communicating devices is not required.
- Weather conditions like rain, storm etc. could interrupt the signal.
- Very high power consumption.
- High costs of installation and operation.

**d. Satellite link**

Long distance wireless communication systems use satellite links for transmitting signals. Usually, a signal travels in a straight line and is not able to bend around the globe to reach a destination far away. Signals can be sent to geostationary satellites in space and then redirected to another satellite or directly to a far away destination. A geostationary satellite orbits the earth in the same direction and amount of time it takes to revolve the earth once is equal to the time taken for earth’s one rotation. From the earth, therefore, the satellite appears to be stationary, always above the same area of the earth. These satellites carry electronic devices called transponders for receiving, amplifying, and re-broadcasting signals to the earth.

Transmission of signals from the earth to a satellite is called **uplink** and from a satellite
to the earth is called **downlink**. There are multiple micro wave frequency bands which are used for satellites links. Frequency used for uplink varies from 1.6 GHz to 30.0 GHz and that for downlink varies from 1.5 GHz to 20.0 GHz. Downlink frequency is always lower than the uplink frequency.

The satellite system is very expensive, but its coverage area is very large. Communication satellites are normally owned by governments or by government approved organisations of various countries.

**Characteristics of transmission using satellite link**

- Satellites cover a large area of the earth.
- This system is expensive.
- Requires legal permission and authorisation.

---

**Check yourself**

1. Name the basic elements needed for a data communication system.
2. Define resource sharing.
3. Name two classifications of communication channels between computers in a network.
4. Name the connector used to connect UTP/STP cable to a computer.
5. The cable media that use light to transmit data signals to very long distances is ________.
6. AM and FM radio broadcast and mobile phones make use of ________ medium for transmission.
7. A short range communication technology that does not require line of sight between communicating devices is ________.
8. A communication system that is very expensive, but has a large coverage area when compared to other wireless communication systems is ________.

---

**8.4 Data communication devices**

A data communication device provides an interface between computer and the communication channel. These devices are used to transmit, receive, amplify and route data signals across a network through various communication media.

**8.4.1 Network Interface Card (NIC)**

Network Interface Card (NIC) is a device that enables a computer to connect to a network and communicate. It provides hardware interface between a computer and a
network. It can be a separate circuit board that is installed in a computer or a circuit already integrated with the motherboard. NIC can prepare, send, receive and control data on the network. It breaks up data into manageable units, translates the protocols of the computer to that of the communication medium and supplies address recognition capabilities.

Figure 8.15 (a, b) shows the NIC card and wireless NIC card. Some NIC cards have wired connections (Ethernet), while others are wireless (Wi-Fi). Ethernet NICs include jacks for network cables, while Wi-Fi NICs contain built-in transmitters / receivers (transceivers) and an antenna. NICs can transfer data at a speed of 1 Gbps.

8.4.2 Hub

A hub is a device used in a wired network to connect computers/devices of the same network. It is a small, simple, passive and inexpensive device (refer Figure 8.16). Computers/devices are connected to ports of the hub using Ethernet cable. When NIC of one computer sends data packets to hub, the hub transmits the packets to all other computers connected to it. Each computer is responsible for determining its data packets. The computer for which the data packets are intended accepts it. Other computers on the network discard these data packets. The main disadvantage of hub is that it increases the network traffic and reduces the effective bandwidth, as it transmits data packets to all devices connected to it.

8.4.3 Switch

A switch is an intelligent device that connects several computers to form a network. It is a higher performance alternative to a hub. It looks exactly like a hub. Switches are capable of determining the destination and redirect the data only to the intended node. Switch performs this by storing the addresses of all the devices connected to it in a table. When a data packet is send by one device, the switch reads the destination address on the packet and transmits the packet to the destination device with the help of the table. A switch performs better than a hub on busy networks, since it generates less network traffic in delivering messages.
8.4.4 Repeater

A repeater is a device that regenerates incoming electrical, wireless or optical signals through a communication medium (refer Figure 8.17). Data transmissions through wired or wireless medium can travel only a limited distance as the quality of the signal degrades due to noise. Repeater receives incoming data signals, amplifies the signals to their original strength and retransmits them to the destination.

8.4.5 Bridge

A bridge is a device used to segmentise a network. An existing network can be split into different segments and can be interconnected using a bridge. This reduces the amount of traffic on a network. When a data packet reaches the bridge, it inspects the incoming packet’s address and finds out to which side of the bridge it is addressed (to nodes on the same side or the other side). Only those packets addressed to the nodes on the other side, will be allowed to pass the bridge. Others will be discarded. The packet that passes the bridge will be broadcast to all nodes on the other side and is only accepted by the intended destination node. Figure 8.18 shows the function of a bridge.

8.4.6 Router

A router is a device that can interconnect two networks of the same type using the same protocol. It can find the optimal path for data packets to travel and reduce the amount of traffic on a network. Even though its operations are similar to a bridge, it is more intelligent. The router can check the device address and the network address and can
use algorithms to find the best path for packets to reach the destination. Figure 8.19 shows the role of a router.

8.4.7 Gateway

A gateway is a device that can interconnect two different networks having different protocols (refer Figure 8.20). It can translate one protocol to another protocol. It is a network point that acts as an entrance to another network. Its operations are similar to that of a router. It can check the device address and the network address and can use algorithms to find the best path for packets to reach the destination. Further, while interconnecting two networks with different protocols, there must be some mutual understanding between the networks. A gateway is capable of understanding the address structure used in different networks and seamlessly translate the data packet between these networks.

8.5 Data terminal equipments

A data terminal equipment (DTE) is a device that controls data flowing to or from a computer. It is connected to the transmission medium at the end of a telecommunication link. Here we discuss the most commonly used DTEs - modem and multiplexer.

8.5.1 Modem

A modem is an electronic device used for communication between computers through telephone lines (refer Figure 8.21). The name is formed from the first three letters of the two words modulator and demodulator. It converts digital signals received from a computer to analog signals for telephone lines. It also converts the analog signals received
back from telephone lines to digital signals for the computer. The speed of the modem determines how fast it can send and receive information through telephone lines. Speed of modem is measured in bits per second (bps).

### 8.5.2 Multiplexer/Demultiplexer

Have you ever wondered how 200 or more TV channels are transmitted through a single cable in a television network? It is called multiplexing. Similar is the case with data transmission over networks. Multiplexing is sending multiple signals on a physical medium at the same time in the form of a single, complex signal and then recovering the separate signals at the receiving end. Multiplexing divides the physical medium into logical segments called frequency channels. Multiplexer combines (multiplexes) the inputs from different sources and sends them through different channels of a medium. The combined data travels over the medium simultaneously. At the destination, a demultiplexer separates (demultiplexes) the signal and sends them to destinations. Figure 8.22 shows the function of a multiplexer and de-multiplexer.

![Function of multiplexer and demultiplexer](image-url)
8. Computer Networks

Let us do

Make a list of networking devices and communication medium necessary to create a small computer network having a maximum of 10 nodes.

Check yourself

1. Compare hub and switch.
2. What is the use of a repeater?
3. The devices used to interconnect two networks of same type is ______.
4. Differentiate between router and bridge.
5. A device that can interconnect two different networks having different protocols is ______.
6. An electronic device used for communication between computers through telephone lines is ______.

8.6 Network topologies

Imagine that we have ten computers and we need to interconnect them to form a network. What are the ways by which we can interconnect them?

Using available media and based on certain conditions, there are different ways of interconnecting the nodes. The way in which the nodes are physically interconnected to form a network is called a Topology. Major topologies are bus, star, ring and mesh.

8.6.1 Bus topology

In bus topology (refer Figure 8.23) all the nodes are connected to a main cable called bus. If a node has to send data to another node, it sends data to the bus. The signal travels through the entire length of the bus. All nodes check the bus, and only the node for which data is addressed accepts it. A small device called terminator is attached at each end of the bus. When

Fig. 8.23: Bus topology
the signal reaches the end of the bus, the terminator absorbs the signal and removes it from the bus. Now the bus is free to carry another signal. This prevents the reflection of a signal back on the cable and hence eliminates the chances of signal interference. The process of transmitting data from one node to all other nodes is called broadcasting.

**Characteristics of bus topology**
- Easy to install.
- Requires less cable length and hence it is cost effective.
- Failure of a node does not affect the network.
- Failure of cable (bus) or terminator leads to a break down of the entire network.
- Fault diagnosis is difficult.
- Only one node can transmit data at a time.

### 8.6.2 Star topology

In star topology each node is directly connected to a hub/switch as shown in Figure 8.24. If any node has to send some information to any other node, it sends the signal to the hub/switch. This signal is then broadcasted (in case of a hub) to all the nodes but is accepted only by the intended node. In the case of a switch, the signal is sent only to the intended node.

**Characteristics of star topology**
- More efficient compared to bus topology.
- Easy to install.
- Easy to diagnose faults.
- Easy to expand depending on the specifications of central hub/switch.
- Failure of hub/switch leads to failure of entire network.
- Requires more cable length compared to bus topology.

### 8.6.3 Ring topology

In ring topology, all nodes are connected using a cable that loops in a ring or circle. A ring topology is in the form of a circle that has no start and no end (refer Figure 8.25). Terminators are not necessary in a ring topology. Data travels only in one direction in a ring. While they are passed from one node to the next, each node regenerates the
signal. The node for which the signal is intended reads the signal. After travelling through each node, the signal reaches back to the sending node from where it is removed.

Characteristics of ring topology
- No signal amplification is required as each node amplifies the signal.
- Requires less cable length and hence is cost effective.
- If one node fails, entire network will fail.
- Addition of nodes to the network is difficult.

8.6.4 Mesh topology
In mesh topology, every node is connected to other nodes. So there will be more than one path between two nodes as shown in Figure 8.26. If one path fails, the data will take another path and reach the destination.

Characteristics of mesh topology
- Network will not fail even if one path between the nodes fails.
- Expensive because of the extra cables needed.
- Very complex and difficult to manage.

Identify the network topology used in your school lab.

8.7 Types of networks
A computer network may span any amount of geographical area. It can be on a table, in a room, in a building, in a city, in a country, across continents or around the world. On the basis of the area covered, computer networks are classified as:

- PAN - Personal Area Network
- LAN - Local Area Network
- MAN - Metropolitan Area Network
- WAN - Wide Area Network
8.7.1 Personal Area Network (PAN)

PAN is a network of communicating devices (computer, mobile, tablet, printer, etc.) in the proximity of an individual. It can cover an area of a radius with few meters (refer Figure 8.27).

When we transfer songs from one cell phone to another or from a PC to an MP3 player, a PAN is set up between the two. PAN can be set up using guided media (USB) or unguided media (Bluetooth, infrared).

8.7.2 Local Area Network (LAN)

LAN is a network of computing and communicating devices in a room, building, or campus. It can cover an area of radius with a few meters to a few Kilometers. A networked office building, school or home usually contains a single LAN, though sometimes one building can contain a few small LANs (Like some schools have independent LANs in each computer lab) as shown in Figure 8.28. Occasionally a LAN can span a group of nearby buildings. In addition to operating in a limited space, a LAN is owned, controlled and managed by a single person or an organisation.

LAN can be set up using wired media (UTP cables, coaxial cables, etc.) or wireless media (infrared, radio waves, etc.). If a LAN is setup using unguided media, it is known as WLAN (Wireless LAN).

8.7.3 Metropolitan Area Network (MAN)

MAN is a network of computing and communicating devices within a city. It can cover an area of a few Kilometers to a few hundred Kilometers radius. MAN is usually formed by interconnecting a number of LANs and individual computers. All types of communication media (guided and unguided) are used to set up a MAN. MAN is
typically owned and operated by a single entity such as a government body or a large corporation (refer Figure 8.29).

8.7.4 Wide Area Network (WAN)

WAN is a network of computing and communicating devices crossing the limits of a city, country or continent. It can cover an area of over hundreds of Kilometers in radius. WAN usually contain a number of interconnected individual computers, LANs, MANs and maybe other WANs. All types of communication media (guided and unguided) are used to set up a WAN as shown in Figure 8.30. The best known example of a WAN is the Internet. Internet is considered as the largest WAN in the world. A network of ATMs, banks, government offices, international organisations, offices, etc. spread over a country, continent or covering many continents are examples of WAN.

Table 8.1 summerises the characteristics of PAN, LAN, MAN and WAN.
8.8 Logical classification of networks

This classification is based on the role of computers in the network and division falls into two categories: peer-to-peer and client-server.

8.8.1 Peer-to-Peer

A peer-to-peer network has no dedicated servers. Here a number of computers are connected together for the purpose of sharing information or devices. All the computers are considered equal. Any computer can act as a client or as a server at any instance. This network is ideal for small networks where there is no need for dedicated servers, like home network or small business establishments or shops.

8.8.2 Client-Server

The client-server concept is the driving force behind most of the networks. It is similar to going to a restaurant, reading the menu, calling the waiter (server) and then ordering one’s preference from the menu. If the ordered item is available in the restaurant at that time, it is ‘served’ to whom the order was placed (client), else the request is refused.

In a network, the client-server architecture consists of high-end computer (called server) serving lower configuration machines called clients. A server provides clients with specific services (responses) upon client’s request. The services include sharing of data, software and hardware resources. Figure 8.31 shows the general client-server architecture.

Client-server architecture is an example for centralised software management. When software is loaded on the server and shared among the clients, changes made to the software in the server will reflect in the clients also. So there is no need to spend time and energy for installing updates and tracking files independently on the clients.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>PAN</th>
<th>LAN</th>
<th>MAN</th>
<th>WAN</th>
</tr>
</thead>
<tbody>
<tr>
<td>Area covered</td>
<td>Small area (Up to 10 m radius)</td>
<td>A few meters to a few Kilometers (Up to 10 Km radius)</td>
<td>A city and its vicinity (Up to 100 Km radius)</td>
<td>Entire country, continent, or globe</td>
</tr>
<tr>
<td>Transmission speed</td>
<td>High speed</td>
<td>High speed</td>
<td>Moderate speed</td>
<td>Low speed</td>
</tr>
<tr>
<td>Networking cost</td>
<td>Negligible</td>
<td>Inexpensive</td>
<td>Moderately expensive</td>
<td>Expensive</td>
</tr>
</tbody>
</table>

Table 8.1: Characteristics summary of PAN, LAN, MAN, WAN
Classifications for servers are

a) **File server** - A computer that stores and manages files for multiple users on a network.
b) **Web server** - A computer dedicated to responding to requests for web pages.
c) **Print server** - Redirects print jobs from clients to specific printers.
d) **Database server** - Allows authorised clients to view, modify and/or delete data in a common database.

**Check yourself**

1. In bus topology, when the signal reaches the end of the bus, _______ absorbs the signal and removes it from the bus.
2. In which topology is every node connected to other nodes?
3. Categorise and classify the different types of networks given below.
   - ATM network, Cable television network, Network within the school,
   - Network at home using bluetooth, Telephone network, Railway network.
4. What is PAN?

### 8.9 Identification of computers over a network

Imagine that you are in India and you wish to write a letter to your friend in America. What would you do? You write a letter, put it in an envelop, write your friend’s address on it and write your address on the back. When the letter is posted in a post office in India, it is stamped with a unique seal and date. After going through a feasible route the letter reaches the post office in America, where it is stamped again with a unique seal and date. Then, the postman makes sure that it reaches the specified addressee. In a network, data is sent in the form of packets in a similar way.

Once a network has been set up, the nodes can communicate among themselves. But for proper communication, the nodes should be uniquely identifiable. If node X sends some information to node Y on a network, then it is mandatory that nodes X and Y are uniquely identifiable on the network. Let us see how this is achieved.

#### 8.9.1 Media Access Control (MAC) address

A Media Access Control (MAC) address is a universally unique address (12 digit hexadecimal number) assigned to each NIC (Network Interface Card) by its
manufacturer. This address is known as the MAC address. It means that a machine with an NIC can be identified uniquely through the MAC address of its NIC. MAC address of an NIC is permanent and never changes.

MAC addresses are 12-digit hexadecimal (or 48 bit Binary) numbers. By convention, MAC addresses are usually written in one of the following two formats:


The first half (MM:MM:MM) of a MAC address contains the ID number of the adapter manufacturer. The second half (SS:SS:SS) of a MAC address represents the serial number assigned to the adapter (NIC) by its manufacturer. For example, in the following MAC address,

00:A0:C9 : 14:C8:35

the prefix 00:A0:C9 indicates that the manufacturer is Intel Corporation. The last three numbers 14:C8:35 are given by the manufacturer (Intel in this example) to this NIC.

### 8.9.2 Internet Protocol (IP) Address

An IP address is a unique 4 part numeric address assigned to each node on a network, for their unique identification. IP address is assigned to each machine by the network administrator or the Internet Service Provider. An IP address is a group of four bytes (or 32 bits) each of which can be a number from 0 to 255.

To make it easier for us to remember, IP addresses are normally expressed in decimal format as a “dotted decimal number” as indicated in Figure 8.33.

On a network, the IP address of a machine is used to identify it. IP protocol identifies a machine with its IP address to route the packets.

There are two versions of IP addresses: version 4 (IPv4) and version 6 (IPv6). IPv4 uses 32 bits and IPv6 uses 128 bits for an IP address. Using IPv4 only $2^{32}$ (approximately 4 billion) distinct devices can be addressed.

As the number of devices which need to be networked (mobile phones, home appliances, personal communication devices, etc.) is increasing at a very fast pace, IPv4 addresses are being exhausted. To address this problem IPv6 was developed and it is now being deployed. Using IPv6, $2^{128}$ (approximately $4 \text{ billion} \times 4 \text{ billion} \times 4 \text{ billion} \times 4 \text{ billion}$) distinct devices can be addressed.
A network protocol is the special set of rules to be followed in a network when devices in the network exchange data with each other. Each protocol specifies its own rules for formatting data, compressing data, error checking, identifying and making connections and making sure that data packets reach its destination.

Several computer network protocols have been developed for specific purposes and environments. Some commonly used protocols are TCP/IP, SPx/IPx etc.

**TCP/IP**

TCP/IP, Transmission Control Protocol/Internet Protocol, is a suite of communications protocols used to interconnect network devices on the local networks and the Internet. TCP/IP defines rules for how electronic devices (like computers) should be connected to the Internet and how data should be transmitted between them.

When data is to be sent from one computer to another over Internet, it is first broken into smaller packets by TCP and then sent. When these packets are received by the receiving computer, TCP checks packets for errors. If errors are found, TCP submits requests for retransmission; else packets are assembled into the original message according to the rules specified in TCP protocol. Figure 8.34 shows the steps involved in TCP/IP operation.

**Let us do**

Identify the IP and MAC Id of each networked machine in your school and prepare a table as follows. (Use ipconfig /all at command prompt).

<table>
<thead>
<tr>
<th>Sl No</th>
<th>Computer Name</th>
<th>IP</th>
<th>MAC</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

![Fig: 8.34 : How TCP/IP works](image-url)
in the working of TCP/IP protocol. Delivery of each of these packets to the right destinations is done by Internet protocol (IP). Even though different packets of the same message may be routed differently, they will reach the same destination and get reassembled there. HTTP, FTP and DNS are three sub protocols of TCP/IP protocol suite.

**HTTP**

HTTP stands for Hypertext Transfer Protocol. It is a standard protocol for transferring requests from client-side and to receive responses from the server-side. The HTTP client (browser) sends a HTTP request to the HTTP server (web server) and server responds with a HTTP response. This pair of request and response is called an HTTP session (refer Figure 8.35).

The response from the server can be static such as a file already stored on the server, or dynamic, such as, the result of executing a piece of code by the server as per the request from the client.

*The two important characteristics of HTTP are*

- HTTP is transmission medium independent.
- HTTP is stateless (The server and client are aware of each other only during a request or response. Afterwards, each forgets the other).

**FTP**

FTP stands for File Transfer Protocol. It is a standard for exchanging of data and program files across a network. FTP is the easiest way to transfer files between computers via the Internet. It uses TCP and IP to perform uploading and downloading. A FTP client program installed in the computer can help in the uploading (sending files to another computer) and downloading (receiving files from another computer) of files.

FTP uses client-server architecture in servers with security features, username and password protection for file transfer. An FTP client program (Filezilla, Cute FTP, etc) installed in the computer can help in the easy uploading and downloading of files.

**DNS**

DNS stands for Domain Name System. DNS returns the IP address of the domain name, that we type in our web browser’s address bar. (like mobile phone automatically dialing the phone number when we select a name from contact list).

The DNS system has its own network. DNS implements a database to store domain names and IP address information of all web sites on the Internet. DNS assumes that IP
addresses do not change (statically assigned). If one DNS server does not know how to translate a particular domain name, it asks another one, and so on, until the correct IP address is returned.

8.11 Uniform Resource Locator (URL)

URL stands for Uniform Resource Locator. URL is a formatted text string used by web browsers, email clients and other software to identify a network resource on the Internet. Every resource on the Internet has a unique URL. Network resources are files that can be plain web pages, other text documents, graphics, programs, etc.

URL consists of letters, numbers and punctuations. URL string can be divided into three parts.

a) Network protocol (also called the scheme)

b) Domain name (Host name or address)

c) File name

For example, the URL http://www.dhsekerala.gov.in/index.html has three parts as shown in Figure 8.36. The detailed description of these three parts are given below:

![Figure 8.36: URL of DHSE web site](image)

**a. Protocol**

The protocol enables the browser to know what protocol is used to access the information specified in the domain.

**b. Domain name**

Domain name is the name assigned to a server through the Domain Name System (DNS). Domain names are used in URLs to identify the particular web server. Domain names provide Internet users with a short name that is easy to remember. Whenever we have to communicate with a computer on Internet, we can do so by using its IP address. But it is practically impossible for a person to remember the IP addresses of all the computers, one may have to communicate with. Therefore, a system has been
Let us sum up

We learned about computer networks, the essential technology of the century, in this chapter. Importance of network was discussed by highlighting the various advantages it provides. We discussed the various communication media and their pros and cons. The devices used at various situations while forming a network was also discussed. Before discussing the types of network, we learned the different ways a network could be formed by discussing various topologies. We then discussed protocol and how TCP/IP send/receive data across the network. Methods to uniquely identify a node in the network were introduced and finally we concluded discussing URL.

A domain name usually has more than one part: top level domain name or primary domain name and sub-domain name(s). For example, in the domain name above, ‘in’ is the primary domain name; ‘gov’ is the sub-domain of in and ‘dhsekerala’ is the sub-domain of ‘gov’. There are only a limited number of top level domains and these are divided into two categories: Generic Domain Names and Country-Specific Domain Names. Examples of generic and country specific domain names are given in Table 8.2.

<table>
<thead>
<tr>
<th>Generic Domain Names</th>
<th>Country Specific Domain Names</th>
</tr>
</thead>
<tbody>
<tr>
<td>·com</td>
<td>Commercial business</td>
</tr>
<tr>
<td>·edu</td>
<td>Educational institutions</td>
</tr>
<tr>
<td>·gov</td>
<td>Government agencies</td>
</tr>
<tr>
<td>·mil</td>
<td>Military</td>
</tr>
<tr>
<td>·net</td>
<td>Network organizations</td>
</tr>
<tr>
<td>·org</td>
<td>Organizations (nonprofit)</td>
</tr>
</tbody>
</table>

c. File name

It is the file to be opened. In the example given in Figure 8.35, 'index.html' is the file that is to be accessed from the web server specified by the domain name.

Let us do

Make a list of valid URL, containing two examples for each generic domain name and country specific domain name. Also note down the file name opened by default (for file look at the URL in address bar after the site is opened).
Learning outcomes

After the completion of this chapter the learner will be able to
• identify and choose a communication medium.
• compare different types of network.
• explain the logical classification of networks.
• identify how data is send across networks.
• design small networks.
• explain how a node is identified in a network.
• identify the various parts of a URL.

Sample questions

Very short answer type

1. The transmission media which carry information in the form of light signals is called __________.
   a. Coaxial    b. Twisted    c. WiFi    d. Optical Fiber

2. Different networks with different protocols are connected by a device called ______.
   a. Router    b. Bridge    c. Switch    d. Gateway

3. In which topology, the failure of any one computer will affect the network operation?

4. To transmit signals from multiple devices through a single communication channel simultaneously, we use ______ device.
   a. Modem    b. Switch    c. Router    d. Multiplexer

5. Satellite links are generally used for
   a. PANs    b. LANs    c. MANs    d. All of the above

Short answer type

1. Define bandwidth.

2. Switch and Hub are two devices associated with networking. Differentiate them.

3. What is an IP address? Give an example of IP address.

4. What is TCP/IP? What is its importance?

5. What is Bluetooth?

6. Distinguish between router and gateway.

7. Explain the need for establishing computer networks.

8. What are the uses of computer networks?

9. What is the limitation of microwave transmission? How is it eliminated?

10. Briefly describe the characteristics of Wi-Fi.
11. An International School is planning to connect all computers, spread over distance of 45 meters. Suggest an economical cable type having high-speed data transfer, which can be used to connect these computers.

12. Suppose that you are the administrator of network lab in one Institution. Your manager directed you to replace 10 Mbps switch by 10 Mbps Ethernet hub for better service. Will you agree with this decision? Justify your answer.

13. You need to transfer a biodata file stored in your computer to your friend’s computer that is 10 kms away using telephone network
   a. Name the device used for this at both ends.
   b. Explain how the file is send and received inside the device, once a connection between two computers is established.

14. When is a repeater used in a computer network?

15. Compare infrared and Bluetooth transmission.

16. Identify and explain the device used for connecting a computer to a telephone network.

17. Briefly explain LAN topologies.

18. Briefly describe TCP/IP protocol.

19. What is a MAC address? What is the difference between a MAC address and an IP address?

**Long answer type**

1. How are computer networks classified, based on size?
2. Compare different LAN topologies.
3. Explain various types of guided communication channels.
4. Compare different unguided media.
5. Define the term protocol. Briefly describe any two communication protocols.
6. Briefly describe the various communication devices used in computer networks.
7. Which is/are communication channel(s) suitable in each of the following situations?
   a. Setting up a LAN.
   b. Transfer of data from a laptop to a mobile phone.
   c. Transfer of data from one mobile phone to another.
   d. Creating a remote control that can control multiple devices in a home.
   e. Very fast communication between two offices in two different countries.
   f. Communication in a hilly area.
   g. Communication within a city and its vicinity where cost of cabling is too high.
In the previous chapter we saw that the Internet is the largest computer network in the world. We use the Internet to check SSLC results, to submit applications for higher secondary school admissions and check its status, to get information about various types of scholarships and to submit applications for receiving them, etc. Can you imagine life without the Internet today? It would be difficult for us to manage all the above tasks without it. Internet has definitely made life easier for us. It has influenced our daily life to a great extent. Because of its wide popularity and increase in use even the television sets with facilities for Internet connectivity have come up in markets.

People generally use the Internet to search information, access e-mails, make bill payments, for online shopping, online banking, to connect with people in social networking sites, etc. The reach of Internet is very vast and it helps in reducing cost and time. Issues like online intrusion to privacy, online fraud, cyber-attacks, etc. are becoming common now. Apart from the Internet and its access methods, let us discuss the various services provided by the Internet like search engines, e-mail, social media and about the threats and preventive measures while using Internet in this chapter.
9.1 History of the Internet

The Internet started as a small network through a project by the United States Department of Defence by the name ARPANET (Advanced Research Projects Agency Network). During 1970s this military network was connected to the computers of Universities and companies that worked for the Department of Defence. In 1984 the military network split from ARPANET to form MILNET to be used by the American military only. ARPANET which used TCP/IP protocol for communication was thereafter used for scientific research and information sharing. Later, several other networks merged with ARPANET to form a large network. ARPANET is considered as the first wide area network (WAN). Vinton Gray Cerf who was instrumental in the development of Internet and TCP/IP protocol, is considered as the father of Internet.

Vinton Gray Cerf (1943 - ) popularly called Vint Cerf, an American computer scientist, is widely known as 'Father of the Internet'. He was instrumental in the initial development of Internet along with his fellow American computer scientist Bob Kahn. He worked for the United States Department of Defence Advanced Research Projects Agency (DARPA) and had a key role in the development of TCP/IP protocol. He was also involved in the formation of ICANN.

In 1989, Tim Berners Lee, a researcher, proposed the idea of World Wide Web (WWW). Tim Berners Lee and his team are credited with inventing Hyper Text Transfer Protocol (HTTP), HTML and the technology for a web server and a web browser. Using hyperlinks embedded in hypertext the web developers were able to connect web pages. They could design attractive webpages containing text, sound and graphics. This change witnessed a massive expansion of the Internet in the 1990s.

Various types of computers loaded with diverse operating systems in different organisations at geographically distant locations joined this network making it a global phenomenon. TCP/IP protocol is used as the communication protocol for Internet. Any computer that joins Internet should follow the TCP/IP protocol. In 1998, Internet Corporation for Assigned Names and Numbers (ICANN) was established. ICANN does not control the Internet content; rather it develops policies on the Internet’s Uniform Resource Locators (URL). Today, Internet is the largest public network that connects billions of computers all over the world and provides several services like searching, e-mail, file transfer, social networking,
etc. The **Internet** is an interconnected system of computer networks that serves the users all over the world.

An **intranet** is considered as a private computer network similar to Internet that uses TCP/IP protocol to share information, software or services within an organisation. An intranet can host websites, provide e-mail service, file transfer and other services available on Internet.

When an intranet is made accessible to some computers that are not part of a company’s private network it is called an **extranet**. A network that allows vendors and business partners to access a company resource can be considered as an example of extranet.

### 9.2 Connecting the computer to the Internet

As we know today, the Internet has become very popular and almost all organisations and people around the world are joining it. Earlier, people used the Internet to search for information and check e-mails only, but today it is used to book train tickets, recharge mobile phones, Internet banking and a lot more. Therefore almost all of us require an Internet connection in our computers or mobile devices.

The following are the hardware and software requirements for connecting a computer to the Internet:

- A computer with Network Interface Card (wired/wireless) facility and an operating system that supports TCP/IP protocol
- Modem
- Telephone connection
- An Internet account given by an Internet Service Provider (ISP)
- Software like browser, client application for e-mail, chat, etc.

Nowadays desktop computers or laptops are not the only devices that we use to connect to the Internet. People have also started using tablets, smart phones, etc. to browse the Internet. Some of these devices come with built-in modems, whereas others use a wireless dongle or wireless connection from a modem to access the Internet.

### 9.3 Types of connectivity

Today most websites use images and multimedia content to make webpages more attractive. Several websites provide videos that can be downloaded or viewed on the Internet. Instead of distributing software in CDs or other storage media, it is now distributed online by various vendors. The latest trend shows that software like word processors, spreadsheets, antivirus, etc. are used online on a rental basis instead of
installing it on each computer. In all these cases, a large volume of data is transferred online. Therefore the speed or data transfer rate of the Internet is an important aspect. **Data transfer rate** is the average number of bits transferred between devices in unit time.

\[
\begin{align*}
1 \text{ kbps} & = 1000 \text{ bits per second} \\
1 \text{ Mbps} & = 1000 \text{ kbps} \\
1 \text{ Gbps} & = 1000 \text{ Mbps}
\end{align*}
\]

The main factor that decides Internet access speed is the type of connectivity we choose to link to the Internet. Internet connectivity is classified based on the speed of the connection and the technology used. They can be broadly classified as dial-up connectivity, wired broadband connectivity and wireless broadband connectivity. The data transfer rates of each type of connectivity may vary as technology advances.

### 9.3.1 Dial-up connectivity

A dial-up connection uses the conventional telephone line and a dial-up modem to dial and connect to the server at the Internet Service Provider (ISP). Figure 9.2 shows the dial-up connectivity system. As the connection is made by dialing, it takes time to connect to the server at the ISP. This connection commonly uses a 56 kbps modem that can transmit data up to a maximum speed of 56 kbps. This slow connection is comparatively less costly when compared to other types of connections. Another disadvantage is that a dial-up connection requires exclusive use of the telephone line, i.e., while accessing Internet, we cannot make or receive telephone calls (voice calls). Nowadays, broadband connections that have a higher speed are replacing dial-up connections.
9.3.2 Wired broadband connectivity

The term broadband refers to a broad range of technologies that helps us to connect to the Internet at a higher data rate (speed). Wired broadband connections are ‘always on’ connections that do not need to be dialled and connected. Broadband connections use a broadband modem (refer Figure 9.3) and allow us to use the telephone even while using the Internet. Table 9.1 shows the comparison between dial-up and wired broadband connections.

![Diagram of dial-up connectivity](Fig. 9.2 : Dial-up connectivity)

**Table 9.1 : Comparison between dial-up and wired broadband connections**

<table>
<thead>
<tr>
<th>Dial-up connection</th>
<th>Wired broadband connection</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Slow connection, speed upto 56 kbps</td>
<td>• High speed connection, speed usually higher than 256 kbps</td>
</tr>
<tr>
<td>• Requires dialing to connect to ISP</td>
<td>• Always on connection</td>
</tr>
<tr>
<td>• Uses telephone line exclusively</td>
<td>• Simultaneous use of voice and Internet</td>
</tr>
<tr>
<td>• Uses dial-up modem</td>
<td>• Uses broadband modem</td>
</tr>
</tbody>
</table>

Popular broadband technologies are Integrated Services Digital Network (ISDN), Cable Internet, Digital Subscriber Line (DSL), Leased Lines and Fiber to the Home (FTTH).

* a. Integrated Services Digital Network (ISDN)*

ISDN is a broadband service capable of transporting voice and digital data. Most ISDN lines offered by telephone companies give users two lines. The users can use one line for voice and the other for data, or they can use both lines for data. ISDN lines are capable of offering data transfer rates upto 2 Mbps.

* b. Cable Internet*

Cable Internet access provides Internet access using coaxial cables laid for television signal transmission to our homes. The service provider uses a cable modem at our
home to connect our computer to cable network. Cable TV systems are designed to carry large bandwidth and therefore cable Internet can provide speeds between 1 Mbps to 10 Mbps.

c. **Digital Subscriber Line (DSL)**

DSL is another broadband service that provides connection to the Internet through standard telephone lines. DSL allows the user to use copper telephone lines for both Internet communication and for making voice calls simultaneously. It is composed of several subcategories, the most common being Asymmetric Digital Subscriber Line (ADSL). ADSL is a communication technology that allows faster flow of information over a telephone line. The down stream speed of ADSL services typically ranges from 256 kbps to 24 Mbps. This connection requires an ADSL modem at our homes/offices. ADSL is the most popular broadband service available in India.

d. **Leased Line**

Leased lines are dedicated lines used to provide Internet facility to ISPs, business, and other large enterprises. An Internet leased line is a premium Internet connection that provides speed in the range from 2 Mbps to 100 Mbps and is comparatively costly. This is why leased lines are used only for connecting large campus of organisations like educational institutions to Internet.

e. **Fibre To The Home (FTTH)**

Fibre to the Home (FTTH) uses optical fibers for data transmission. Optical fibres are laid from the ISP to our homes. FTTH technology has been accepted worldwide to implement high speed Internet to the home. Since optical fibres are known to have high bandwidth and low error rates, they provide very high speed connectivity. A Network Termination Unit (NTU) is installed in our homes, which is connected to our computer through an FTTH modem.

### 9.3.3 Wireless broadband connectivity

Wireless broadband connectivity provides almost the same speed as that of a wired broadband connection. The popular wireless broadband accesses are Mobile Broadband, Wi-MAX, Satellite Broadband and Wi-Fi. Some of the wireless modems available for use to connect to Internet are shown in Figure 9.4.

a. **Mobile broadband**

Mobile broadband is wireless Internet access using mobile phone, USB wireless modem, tablet or other mobile devices. The modem is built into mobile phones, tablets, USB
Mobile broadband offers the freedom to allow the user to access the Internet from anywhere on the move. This technology uses the cellular network of mobile phones for data transmission. The mobile technology for data transmission has been changing from 2nd Generation (2G) through 3rd Generation (3G) to the current 4th Generation (4G). The speed of data transmission increases with the progression of generations of mobile technology.

b. Wi-MAX

In the previous chapter we learned that Worldwide Interoperability for Microwave Access (Wi-MAX) is used as an alternative for wired broadband. Wi-MAX offers a Metropolitan Area Network which can provide wireless Internet upto a distance of 50 Km. Connectivity is provided using devices like Wi-MAX handsets, USB dongles, devices embedded in laptops, etc. that have a Wi-MAX modem integrated in it. This technology provides a maximum connection speed of up to 70 Mbps.

c. Satellite broadband

Satellite broadband technology is a method by which Internet connectivity is provided through a satellite. A Very Small Aperture Terminal (VSAT) dish antenna and a transceiver (transmitter and receiver) are required at the user’s location. A modem at the user’s end links the user’s computer with the transceiver. Download speed is up to 1 Gbps for this technology. It is among the most expensive forms of broadband Internet access. They are used by banks, stock exchanges, governments, etc. and also for Internet access in remote areas.

9.3.4 Internet access sharing methods

An Internet connection can be shared among several computers using a LAN, Wi-Fi network or Li-Fi network.

a. Using LAN

The Internet connected to a computer in a Local Area Network (LAN) can be shared among other computers in the network. This can be done either using features available in the operating system or using any proxy server software available in the market. Sharing can also be done by connecting computers directly to the router using a cable.

b. Using Wi-Fi network

We have heard of Wi-Fi campuses in large educational institutions, coffee shops, shopping malls, hotels, etc. We also know that some of the broadband modems at our homes and schools offer Wi-Fi Internet access. Wi-Fi is a popular short distance data transmission technology that is used for network access, mostly Internet. Wi-Fi locations
receive Internet connection through any one of the above mentioned wired or wireless broadband access methods, as discussed in the previous section. They provide us Internet connectivity through a Wi-Fi router or a wireless network access point. Such an access point, popularly called hotspot, has a range of about 100 meters indoors and a greater range outdoors. We access Internet in our Wi-Fi enabled devices like laptops, tablets, mobile phones, etc. through these hotspots. A drawback of Wi-Fi is that it is less secure than wired connections.

c. Using Li-Fi network

Li-Fi (Light Fidelity) is a fast optical version of Wi-Fi, which uses visible light for data transmission. The main component of this communication is a bright LED (Light Emitting Diode) lamp that can transmit data and a photo diode that serves as the receiver. LEDs can be switched on and off to generate a binary string of 1s and 0s. The flickering of this LED is so fast that the human eye cannot detect it. A data rate of over 100 Mbps is possible using this technique as light offers very high bandwidth. Another advantage is that since Li-Fi uses light, it can be used in aircrafts and hospitals where radio waves may cause interference. It can also be used underwater where Wi-Fi does not work. It provides greater security as light cannot penetrate walls when compared to Wi-Fi. One of the shortcomings of Li-Fi is that it works only in direct line-of-sight. In future this technology can be further developed to use light bulbs as a source of Internet.

Check yourself

1. ARPANET stands for _______________.
2. Who proposed the idea of www?
3. The protocol for Internet communication is _______________.
4. What do you mean by an ‘always on’ connection?
5. A short distance wireless Internet access method is _______________.

Prepare a comparison chart on the different methods of Internet connection.
9.4 Services on Internet

The internet offers a variety of services. Services like WWW, e-mail, search engines, social media, etc. are widely used throughout the globe. In this section we shall discuss some of the services of Internet.

9.4.1 World Wide Web (WWW)

The World Wide Web (WWW) is a system of interlinked hypertext documents accessed via the Internet. It is a service on the Internet that uses Internet infrastructure. WWW is a huge client-server system consisting of millions of clients and servers connected together. Each server maintains a collection of documents and they can be accessed using a reference called Uniform Resource Locator (URL). These documents may contain, text, images, videos and other multimedia content. It may also contain hyperlinks to documents on different servers. Selecting a hyperlink results in a request to fetch that document/web page from the server and display it. The WWW works by establishing hypertext links between documents anywhere on the network. Clients can access the documents on the servers using software called browser. A browser is responsible for properly displaying the documents.

a. Browser

A web browser is a software that we use to retrieve or present information and to navigate through web pages in the World Wide Web. The document to be displayed is identified using a URL. A URL consists of its DNS name and the file name to be retrieved. It also specifies the protocol for transferring the document across the network. A browser is capable of displaying text, images, hypertext links, videos, sounds, scripts (program code inside a web page), etc. in a web document/page. Most of WWW documents are created using Hyper Text Markup Language (HTML) tags and are called web pages. The web browser interprets these tags and displays a formatted page. It allows us to navigate through web pages using the hyperlinks available in web pages. Some common browsers are Google Chrome, Internet Explorer, Mozilla Firefox, Opera, and Safari. Icons of some popular browsers are shown in Figure 9.6. Some of these browsers have a mobile version that can be used in mobile operating systems.

![Icons of popular browsers](image)
b. Web Browsing

All of us have visited web sites by entering the website address (URL) into web browsers and then using the hyperlinks in it to move through the web pages. Traversing through the web pages of World Wide Web is called web browsing. Major operations performed while web browsing are shown in Figure 9.7.

![Fig. 9.7 : Web browsing](image)

Suppose you wish to visit the website ‘www.kerala.gov.in’. What will you do? You will enter this URL in the address box of the web browser and press Enter key. The steps a browser will follow to display a webpage may be summarised as follows.

1. The browser determines the URL (http://www.kerala.gov.in) entered.
2. The browser then sends a request to the DNS server of the user’s ISP to get the IP address of the URL.
3. The ISP’s DNS server replies with the IP address.
4. The browser then makes a TCP connection to the web server at the IP address (www.kerala.gov.in).
5. Then it sends a GET request for the required file (web page) to the web server.
6. The web server returns the web page.
7. The TCP connection is released.
8. The browser processes the contents of the webpage and displays it.
9. Internet

9.4.2 Search engines

There are millions of pages available on the Internet that contain information on a variety of topics. But it is very difficult to search for a topic in this large collection of web pages. Internet search engine websites are special programs that are designed to help people to find information available in World Wide Web. Search engine programs search documents available on World Wide Web for specified keywords and return a list of the documents/web pages matching the keywords.

Let us discuss the technology behind these websites. Search engine web sites use programs called web crawlers or spiders or robots to search the web. Web crawlers search the web pages stored in the different web servers and find possible keywords. The search engine website stores these keywords along with their URLs to form an index in the search engine’s web servers. When we use the search engine website to search a particular topic (keyword), it does not search the World Wide Web. It only searches the index, which the web crawler programs have created in the search engine’s web server for the topic/keyword. Search engines

![Fig. 9.8 : Working of a search engine](image)

![Fig. 9.9 : Search results of different search engines](image)
select a list of URLs where the particular topic is found from the index and displays it as the result. Figure 9.8 shows the working of a search engine.

Some of the most popular web search engine sites are Google, Bing, Yahoo Search, Ask, etc. Figure 9.9 shows the search results of different search engines.

**9.4.3 E-mail**

E-mail enables us to contact any person in the world in a matter of seconds. Billions of e-mail messages are sent over the Internet every day. *Electronic mail or e-mail* is a method of exchanging digital messages between computers over Internet.

E-mail has become an extremely popular communication tool. The e-mail will be delivered almost instantly in the recipient’s mail box (Inbox). Apart from text matter, we can send files, documents, pictures, etc. as attachment along with e-mail. The same e-mail can be sent to any number of people simultaneously. Figure 9.10 shows a sample e-mail message.

*Fig. 9.10 : A sample e-mail message*

Most of you will have an e-mail address. The structure of an e-mail address is: user name@domain name. An example of an e-mail address is

```
scertkerala@gmail.com
```

An e-mail address consists of two parts separated by @ symbol. The first part *scertkerala* is the username that identifies the addressee and the second part *gmail.com* is the domain name of the e-mail server, i.e., the name of the e-mail service provider.

E-mails can be accessed using websites like *gmail.com, hotmail.com*, etc. that provide web applications consisting of functions to send, receive, forward, reply and organise emails. Such a facility is popular and is commonly referred to as web mail.
E-mails can also be accessed using e-mail client software that is installed in our computers. Such software uses our e-mail address and password to retrieve e-mails from the e-mail service provider’s server and store it in our computer. An e-mail client allows to send, receive and organise e-mail. The messages sent when the computer is offline are stored in the program and send later when computer is online. For receiving messages, e-mail client applications usually use either the Post Office Protocol (POP) or the Internet Message Access Protocol (IMAP). The popular e-mail client applications are Microsoft Outlook and Mozilla Thunderbird.

a. Sections of an e-mail

A client software gives provisions to enter the following sections.

To (Recipient Address) – A box to provide the e-mail addresses of the primary recipients to whom the e-mail has to be sent.

Cc (Carbon copy) – Write the e-mail addresses of the secondary recipients to whom the message has to be sent.

Bcc (Blind carbon copy) – Write the e-mail addresses of the tertiary recipients who receive the message. When the message is received the primary and secondary recipients cannot see the email addresses of the tertiary recipients in the message. Depending on e-mail service used, the tertiary recipients may only see their own e-mail address in Bcc, or they may see the e-mail addresses of all recipients.

Subject – Provide a meaningful subject for your conversation here. This helps you to identify a conversation with a particular person when you search your e-mails later.

Content – Type your message here. Today most of the e-mail service providers offer features to create an attractive message by giving colours, changing font styles, size, etc.

Attachment facility allows us to send files like documents, pictures, etc. along with an e-mail. The ‘Send’ button is used to send the message to the recipients. ‘Reply’ button allows you to send a reply back to the sender of the message received. ‘Forward’ button helps you to send a message received by you to other people. Figure 9.11 shows the major sections of an e-mail.

![Fig. 9.11 : Composing an e-mail](image-url)
b. Working of e-mail

Have you ever wondered how e-mail is sent from your computer to a friend on the other side of the world? When an e-mail is sent from your computer using web mail or e-mail client software, it reaches the e-mail server of our e-mail service provider. From there the message is routed from sender’s e-mail server all the way to the recipient’s e-mail server. The recipient’s e-mail server then delivers the e-mail to the recipient’s mailbox (inbox), which stores the e-mail and waits for the user to read it. Simple Mail Transfer Protocol (SMTP) is used for e-mail transmission across Internet. Figure 9.12 shows the working of e-mail.

1. Sender composes message using e-mail client/ web mail
2. Sender uploads message to SMTP server
3. Message traverses Internet (probably passing through several routers)
4. Message arrives at receiving server and is placed in recipient’s mailbox file/folder
5. Recipient’s e-mail client/ web mail checks mailbox for new messages and downloads message
6. Recipient reads message using e-mail client/ web mail.

Fig. 9.12 : Working of e-mail

c. Advantages of using e-mail

The benefits of using e-mail facility are listed below.

- **Speed**: An e-mail is delivered instantly to any location across the globe. We can send the same e-mail to multiple users simultaneously.
- **Easy to use**: We can send and receive e-mails, organise our daily conversations and save them easily on our computer.
- **Provision of attachments**: The attachment feature allows to send pictures, files, documents, etc. along with e-mail.
- **Environment friendly**: E-mails do not use paper and save a lot of trees from being cut down.
- **Reply to an e-mail**: When we need to reply to an e-mail, we can use the provision of attaching previous e-mails as reference. It helps to refresh the recipient about the subject.
• **Cost-effective**: When compared to fax or conventional mail, e-mail is less expensive.

• **Available anywhere anytime**: Messages can be read at user’s convenience. Access to mailbox is available anytime.

The e-mail service, though beneficial in our daily life, can be misused in different ways as listed below.

• **E-mails may carry viruses**: Viruses send along with e-mail can harm our computer system. Viruses can also illegally access our e-mail address book and spread virus infected messages to all email addresses in it.

• **Junk mails**: Checking and deleting unwanted mails consume a lot of time.

---

### Internet of Things (IoT)

*Can you imagine a fridge which checks its egg tray and reminds you to buy eggs in your mobile phone or orders the nearby grocery store to supply eggs to your home; an air conditioner that can be switched on or off using your mobile phone; or a car that automatically reminds you about filling fuel as you approach a fuel pump? This is being made possible using Internet of Things (IoT). IoT is the concept of connecting all devices like mobile phones, fridges, cars, air conditioners, lamps, wearable devices, etc. to the Internet. Each device is provided with a unique IP address which identifies it and allows it to transfer data over Internet without human intervention. The huge increase in the number of IP addresses due to the implementation of IPv6 supports the introduction of this technology. The IoT can be used to monitor health of patients and inform the doctor about an urgency, applied to things which help us reduce wastage like power, water, etc. and improve the way we work and live.*

---

### 9.4.4 Social media

All of us are familiar with Wikipedia, the free encyclopedia in Internet. We have also heard about people responding to social issues through Facebook, Twitter, etc. Also we know that people use YouTube to share videos and for promotion of products or business. All of these are part of social media which is changing the way we communicate, entertain and live. Social media refers to the use of mobile and web-based technologies through which individuals and communities can create, share, discuss and modify content.

In social media, interactions among people happen in virtual communities and networks over Internet. These digital technologies influence the formation and activities of civil communities to a great extent.
a. **Classification of social media**

The various types of social media that exist on the Internet are: Internet forums, social blogs, microblogs, wikis, social networks, content communities and a lot more. Figure 9.13 displays logos of popular social media websites. Here we discuss the most popular classifications of social media.

1. **Internet forums**

An Internet forum is an online discussion website where people can engage in conversations in the form of posted messages. Each Internet forum will have sub forums which may have several topics. Each discussion on a topic is called a thread. People can login and start a thread or respond to discussion in a thread. Some forums allow anonymous login also. Discussions can be about programming, social/political issues, fashion, etc. These discussions help us to learn and find solutions to problems. Ubuntu Forum – a community that provides help on Ubuntu is a popular forum.

2. **Social blogs**

A blog (web log) is a discussion or informational website consisting of entries or posts displayed in the reverse chronological order i.e., the most recent post appears first. Some blogs provide comments on a particular subject; others function as personal online diaries and some others as online brand advertising for a particular individual or company. Initially blogs were created by a single user only. But now there are multi-author blogs that are professionally edited. Blogger.com and Wordpress.com are popular sites that offer blogging facility.

3. **Microblogs**

Microblogs allow users to exchange short sentences, individual images or video links. People use microblogs to share what they observe in their surroundings – information about events and opinions about topics from a wide range of fields. Microblogging offers a communication mode that is spontaneous and can influence public opinion. Twitter.com is a popular microblogging site.

4. **Wikis**

Wikis allow people to add content or edit existing information in a web page, to form a community document. Wiki is a type of content management system. Editing done by
users is very closely monitored by other editors and therefore incorrect information, advertising, etc. are removed immediately. wikipedia.org – the free online encyclopedia is the most popular wiki on web.

5. Social networks

Social networking sites allow people to build personal web pages and then connect with friends to communicate and share content. We can share text, pictures, videos, etc. and comment to the posts. A social networking site can be for general topics or for a specific area like professional networking. Public opinion is greatly influenced by the discussions and posts in these websites. Popular social networking sites are facebook.com and linkedin.com.

6. Content communities

Content communities are websites that organise and share contents like photos, videos, etc. Youtube.com is a popular video sharing site and flickr.com shares pictures.

Most of today’s social media websites offer more than one type of service, i.e., social networking and microblogging; blogging and internet forum; etc. Studies have revealed that social media is now recognised as a social influencer.

b. Advantages of social media

- **Bring people together:** Social networking allows people to find long-lost childhood friends and make new ones.

- **Plan and organise events:** These sites help users to organise and participate in events.
• **Business promotion**: Social media offers opportunities for businesses to connect with customers, implement marketing campaigns, manage reputation, etc.

• **Social skills**: These sites allow people to express their views over a particular issue and become an agent for social change.

c. **Limitations in use of social media**

• **Intrusion to privacy**: The personal information of users can be used for illegal activities. Information like the e-mail address, name, location and age can be used to commit online crimes.

• **Addiction**: Addiction to these sites wastes our valuable time. It will negatively affect our mental states and may lead to depression and tension. It can reduce the productivity of workers in an organisation. Students may lose concentration and this in turn may affect their studies.

• **Spread rumours**: Social media will spread the news very quickly. It can facilitate or worsen a crisis by spreading negative information or misinformation at an incredible speed.

d. **Social media interaction – Best practices**

• Avoid unnecessary uploading of personal data like e-mail address, telephone number, address, pictures and videos.

• Setting time schedule for using these sites can save wastage of time.

• In social media websites like wikis and blogs, photo and video sharing are public. What you contribute is available for all to see. Be aware of what you post online. Avoid posting content you may regret later.

• Set your privacy levels in such a way that you know exactly who can see your posts and who can share them. The three basic privacy levels in social media are private, friends and public.

   • **Prepare a chart on the different social networking websites and their uses.**

   • **Create a blog of your class and update the activities like achievements in sports, arts, class tests, assignments, etc.**

   • **Conduct a survey in your school to find the most popular Internet browser. Also prepare a chart based on the collected data.**
9.5 Cyber security

Today, we know that people use Internet to transfer personal and confidential information or make payments, organisations like banks perform all their financial transactions using their computer network, railways do business – selling tickets, information on running trains, etc. using the railway’s computer network. Can you imagine the volume of financial loss and other issues that may occur if these computer networks are not available, even for a short time?

Security to computer networks is vital because important data can be lost and privacy can be violated. Further, work or business can be interrupted for several hours or even days if a network comes under attack. With the arrival of the Internet, security has become a major concern as people started using Internet as a tool for communication and doing business. Every organisation should monitor its network for possible intrusion and other attacks. Here we discuss the common threats that affect a computer network.

9.5.1 Computer virus

A computer virus is a program that attaches itself to another program or file enabling it to spread from one computer to another without our knowledge and interferes with the normal operation of a computer. A virus might corrupt or delete data on our computer, replicate itself and spread to other computers or even erase everything in the hard disk. Almost all viruses are attached to executable files. A virus may exist on a computer, but it cannot infect the computer unless this malicious program is run or opened. Viruses spread when the file they are attached to, is transferred from one computer to another using a portable storage media (USB drives, portable hard disks, etc.), file sharing, or through e-mail attachments. Viruses have become a huge problem on the Internet and have caused damage worth billions.
9.5.2 Worm

A computer worm is a stand alone malware (malicious software) program that replicates itself in order to spread to other computers. Worms spread from computer to computer on its own. Unlike a virus, it does not need to attach itself to a program to propagate. A worm takes advantage of the data transport features of the computer system to travel without help. Worms always slow data traffic on the network by consuming bandwidth, whereas viruses almost always corrupt or modify files on a computer. The most destructive effect that a worm can cause is through e-mails. A worm can send a copy of itself to every address in an e-mail address book. Then, the worm sends itself to everyone listed in each of the receiver’s address book and so on.

I LOVE YOU worm

This worm affected computers in 2000 by overwriting most of the files. Users received this worm as an e-mail with a subject line “ILOVEYOU” and with a file attachment LOVE-LETTER-FOR-YOU.TXT.vbs. Those who clicked the attachment got their computers affected by the worm and lost their files.

9.5.3 Trojan horse

A Trojan horse, will appear to be a useful software but will actually do damage once installed or run on the computer. Users are typically tricked into loading and executing it on their systems. When a Trojan is activated on a computer, they can cause serious damage by deleting files and destroying information on the system. Some Trojans create a backdoor on the computer. This gives malicious users access to confidential or personal information in the computer through the network. Unlike viruses and worms, Trojans do not reproduce by infecting files nor do they self-replicate.

Ie0199.exe Trojan

E-mail users received a message that offered a free upgrade to Internet Explorer that contained an executable file Ie0199.exe as attachment. This e-mail instructed the user to download and install this program for the upgrade. The users who followed these instructions got their files infected.
9.5.4 Spams

Spams or junk mails are unsolicited e-mails sent indiscriminately to persons to promote a product or service. Spammers collect e-mail addresses from chat rooms, websites, customer lists, newsgroups, etc. Clicking on links in spams may send users to websites that host certain viruses. Today most e-mail service providers provide e-mail filters that can successfully separate genuine email from spams as indicated in Figure 9.14.

9.5.5 Hacking

In computer networking, hacking is a technical effort to manipulate the normal behavior of network connections and connected systems. Hacking is performed both by computer security experts and by computer criminals. Computer experts perform hacking to test the security and find the vulnerabilities in computer networks and computer systems. Such computer experts are often called ‘white hats’ and such hacking is called ethical hacking.

Computer criminals break into secure networks to destroy data or make the network unusable for those who are authorised to use the network. They do this with the intent of stealing confidential data or destroying files. Such criminals are called ‘black hats’.

**Trojan War**

In Greek mythology, the Trojan War was waged against the city of Troy by the Greeks after Prince Paris of Troy stole away the Greek Queen Helen. The Greeks fought a battle with the city of Troy for ten long years. The Greek soldiers got fed up and wanted to return to their homes. Then, Athena, the Goddess of war gave the Greeks an idea to end the war. According to the plan, they built a big hollow wooden horse. The hollow horse was filled with soldiers and they left it as a gift for the Trojans. All other soldiers pretended to abandon their camp. Trojans thought that they had won the war. They pulled the huge horse to their city. They started celebrations of their victory. In the night when everyone was asleep, the Greek soldiers opened the horse and came out. They killed the sleeping soldiers of Troy and rescued Queen Helen.

**Fig. 9.14 : Collection of spams in the e-mail menu**
There is another category of hackers called grey hat hackers, who fall between white and black hackers. They sometimes act illegally, though with good intentions, to identify the vulnerabilities. Grey hat hackers do this to achieve better security.

9.5.6 Phishing

Phishing is a type of identity theft that occurs online. Phishing is an attempt to acquire information such as usernames, passwords and credit card details by posing as the original website, mostly that of banks and other financial institutions. Phishing websites have URLs and home pages similar to their original ones. The act of creating such a misleading website is called spoofing. People are persuaded to visit these spoofed websites through e-mails. Users are tempted to type their usernames, passwords, credit card numbers, etc. in these web pages and lose them to these websites. These frauds use this information to steal money. Phishing is currently the most widespread financial threat on the Internet. The URL in Figure 9.15 indicates that it is a phishing website.

9.5.7 Denial of Service (DoS) attack

A Denial of Service (DoS) attack is usually aimed at a web server. Such an attack forces the server/computer to restart. An attack in which the attackers’ goal is to shut down the target server rather than stealing data is called DoS attacks. This prevents genuine users of a service/website on the web server from using that service. This attack can be done using a single computer called Denial of Service (DoS) attack or using more than one computer called Distributed Denial of Service (DDoS) attack.
We have learned that when we type a website address in the browser and press the Enter key, the browser requests for that web page from the server. DoS attacks sends large number of such requests to the server until it collapses under the load and stops functioning. A DoS attack using a computer on a network slows down the network by flooding a server with a large number of requests. A DDoS attack uses multiple computers in the network that it has previously infected. These infected computers called ‘zombies’, work together and send out large quantities of fake messages/requests to the target server. Figure 9.16 shows the Distributed Denial of Service attack. This increases the amount of data traffic to the target server. This leads to server overload and the server is unable to provide services to its users. The target computer is thus forced to reset / restart leading to unavailability of its service for a period of time. A DoS attack interrupts network service for some period, but it does not cause severe damage to files as in the case of a virus attack.

9.5.8 *Man-in-the-Middle attacks*

A man-in-the-middle attack refers to an attack in which an attacker secretly intercepts electronic messages between the sender and the receiver and then captures, inserts and modifies messages during message transmission. If sender transmits messages without appropriate security, the attacker may exploit the vulnerabilities in the network to capture and modify the messages and send the modified messages to the receiver. Since the network transmission still works properly, both the sender and receiver will find it difficult to notice that the messages have been trapped or modified by an intruder. If we use such a computer for online transactions, the man in the middle may capture our bank account number and password to steal money, leading to financial loss. Encrypted connections such as HTTPS (HTTP Secure), SFTP (Secure FTP), etc. should be used for secure transactions, so that intruders cannot modify the messages.

9.6 *Preventing network attacks*

Threats to computers and networks are a major issue as long as information is accessible and transferred across the Internet. Different defense and detection mechanisms are developed to deal with these attacks.
9.6.1 Firewall

A firewall is a system of computer hardware and software that provides security to the computer network in an organisation. A firewall controls the incoming and outgoing network traffic by analysing the data and determining whether they should be allowed through or not, based on a rule set. Firewalls deny malicious data from entering into the computer networks as shown in Figure 9.17.

![Firewall](image)

**Fig. 9.17 : Firewall**

### Sandboxing

Sandboxing is a technique through which programs that are suspected to be infected with a virus can be run. Through sandboxing such programs are run in a separate memory area and therefore cannot damage our operating system.

9.6.2 Antivirus scanners

Viruses, worms and Trojan horses are all examples of malicious software (malware). Antivirus tools are used to detect them and cure the infected system. Antivirus software scans files in the computer system for known viruses and removes them if found. The antivirus software uses virus definition files containing signatures (details) of viruses and other malware that are known. When an antivirus program scans a file and notices that the file matches a known piece of malware, the antivirus program stops the file from running, and puts it into ‘quarantine’. Quarantine is a special area for storing files probably infected with viruses. These files can later be deleted or the virus can be removed. For effective use of antivirus software, virus definitions must be updated regularly.

9.6.3 Cookies

Cookies are small text files that are created when we use a browser to visit a website. Cookies keep track of our movements within the web site – remembers our user name, preferences, e-mail address, etc. Browsers store cookies for an interval of time, usually in a cookie folder on the client’s computer. Cookies are text files and so they are not executable programs. Web sites use cookies mainly because they save time and make browsing efficient.

Cookies are treated as data and so it is not a virus, but it is always possible for a hacker to use it for malicious purposes. Cookies can be used to act as a spyware. There are
harmful cookies that are used by different websites to compromise our privacy. Such websites store a special cookie in our computer that will keep track of our activities like, websites visited, products purchased or the forms that are filled. Most browsers provide facilities to manage/delete harmful cookies. Frequent deletion of cookies helps to prevent illegal access and use of personal information.

9.7 Guidelines for using computers over Internet
Following are the major guidelines for using computers over Internet.
• Most of the computer viruses are spread through e-mail attachments. Do not open any e-mail attachment that you are not sure about the sender.
• Download files only from reputed sources. Do not use/copy software that you cannot confirm the origin.
• Avoid clicking on pop-up advertisements. Close them instead.
• Use USB drives with caution. Plugging someone else’s USB storage into your computer or plugging your own USB storage into a computer at an Internet cafe/unsafe computer, can spread an infection through the USB storage.
• Make sure the firewall is set and turned on.
• Use strong passwords. Change passwords at regular intervals.
• Update the virus definitions of your antivirus program periodically online.
• Keep a regular backup of your important files (on DVD, another hard disk, etc.)
• Be careful about giving personal data online. If you see e-mail message requests for personal data such as telephone number, address, credit card number, etc. from unknown persons, ignore it.

• Visit banks’ websites by typing the URL into the address bar. Do not click on links within e-mails to go to bank websites. Banks or any of its representatives never sends you e-mail/SMS or phone calls to get your personal information, usernames or password. Never reveal your passwords or ATM card details to anyone.

• Check whether the website you are visiting is secure while performing financial transactions. The web address in the address bar should start with ‘https://’. Also look for a lock icon on the browser’s address bar.

• Keep a regular check on your online accounts. Regularly login to your online accounts, and check your statements. If you see any suspicious transaction, report them to your bank or credit card provider.

---

**Guidelines for Setting up a Strong Password**

- A password should have at least 8 characters.
- A password should contain:
  - Upper case letters
  - Lower case letters
  - Numbers
  - Symbols like @, #, $, etc.
- A password should not be personal information like name, date of birth, etc. or common words.
- Never disclose your password to others.
- Do not write it on a paper or store it in a file in your computer.
- Do not use the same password for all logins.
- Change password often.

---

![Secure banking - lock icon and https](image)
Let us do

- Conduct a group discussion on the topic “security threats / cyber attacks to your system”, and draw a bar diagram based on information arrived in the event.
- List the names of various viruses and their features in the form of a chart.

Check yourself

1. What is a virus?
2. What do you mean by phishing?
3. The small text files used by browsers to remember our email id’s, user names, etc are known as ______________.
4. The act of breaking into secure networks to destroy data is called ______________ hacking.
5. What is quarantine?

Let us sum up

The Internet, which was started as a defence project of the US government has become a part of our life. Today the Internet is accessed using mobile devices like mobile phones, tablets, etc. than using a desktop computer. Therefore speed of Internet access has become an important factor. New technologies connect to Internet focus on data transmission speed. Internet services like e-mail, social media, searching etc. have changed the way we communicate. Each of the above services has its own benefits and risks. Computer networks today play an important role in providing the above services. It has increased the risk factors for networks, like viruses, worms, Trojan horse, phishing, etc. Antivirus software, firewalls, etc. are used to protect computer networks from different kinds of attacks. The risks for a network attack can be reduced by following certain guidelines while using computers on Internet.

Learning outcomes

After the completion of this chapter the learner will be able to
- recognise the people behind the evolution of Internet.
- identify the hardware and software requirements for Internet connection.
- use the services available on Internet.
- classify the different types of social media.
- judge the risks while interacting with social media.
- recognise the threats to network security.
Sample questions

Very short answer type
1. Why is the invention of HTTP and HTML considered as an important land mark in the expansion of Internet?
2. Compare intranet and extranet.
3. Write short notes on
   a. Mobile broadband   b. Wi-MAX
4. Explain the terms web browser and web browsing.
5. Compare blogs and microblogs.
6. What are wikis?
7. What is firewall?

Short answer type
1. Your neighbour Ravi purchased a new PC for his personal use. Mention the components required to connect this PC to Internet.
2. What are the advantages of using broadband connection over a dial-up connection?
3. XYZ engineering college has advertised that its campus is Wi-Fi enabled. What is Wi-Fi? How is the Wi-Fi facility implemented in the campus?
4. Madhu needs to prepare a presentation. For this, he uses www.google.com to search for information. How does google display information when he types ‘Phishing’ in the search box and clicks search button?
5. Manoj’s e-mail id is manoj@gmail.com. He sends an e-mail to Joseph whose e-mail id is joseph@yahoo.com. How is the mail sent from Manoj’s computer to Joseph’s computer?
6. How does a Trojan horse affect a computer?
7. Explain a few threats that affect a computer network.

Long answer type
1. Suppose you wish to visit the website of kerala school kalolsavam, www.schoolkalolsavam.in and you have entered the URL in the address bar. Write the steps that follow until the home page is displayed.
2. Write the disadvantages of social media. What are the different ways to avoid the disadvantages of social media?
3. Explain the various broadband technologies available for Internet access.
Information Technology (IT) is growing rapidly. It has influenced almost every sphere of life and has become an integral part of our daily life. Various IT applications available today help to make life easier. For example, we can pay various utility bills, reserve railway or airline tickets and do online shopping from anywhere, anytime. IT is also extensively used in the field of education. One of its recent contributions is e-Learning with virtual classrooms. The possibilities of IT are increasingly used in e-Governance, e-Business and in health care applications as well.

This chapter discusses some of these areas where IT is widely used today. In the case of online shopping, the required items can be ordered and the same will be delivered at our doorstep. Cash transactions can also be made online. The field of education has also advanced with the development of IT. Teachers and students need not be in the same room as in the conventional teaching system. They can share virtual class rooms and make use of e-Learning materials, sitting in dispersed locations. Healthcare is another major area which uses IT for its assistance. With the use of new computer aided medical imaging devices and related technologies, various diseases can be diagnosed at a very early stage.
key role in conducting research for the development of new drugs. We also discuss various ICT enabled services in this chapter.

Information and Communication Technology (ICT) is the term often used as an extended synonym for Information Technology (IT). ICT is more specific in integrating telecommunication and computers comprising of many technologies for capturing, storing, processing, interpreting and printing information.

10.1 e-Governance

Information Technology (IT) has contributed much to the smooth functioning of governments. It comprises many technologies for capturing, processing, interpreting, storing and transmitting information. IT helps governments to take quick and judicious decisions. It also increases transparency and accountability in all its services. Information and Communication Technology (ICT) aided Governance is generally known as e-Governance.

**e-Governance** is the application of ICT for delivering Government services to citizens in a convenient, efficient and transparent manner. The objective of e-Governance is to ensure that the services of the Government reach the public promptly and effectively. In Kerala, we have many government departments like the Motor Vehicle Department, Education, Revenue, etc. which have successfully implemented e-Governance. Let us now discuss various types of interactions in e-Governance.

10.1.1 Types of interactions in e-Governance

e-Governance facilitates interaction among different stakeholders in governance. Categories of these interactions are described as follows:

**Government to Government (G2G)** - It is the electronic sharing of data and/or information among government agencies, departments or organisations. The goal of G2G is to support e-Governance initiatives by improving communication, data access and data sharing.

**Government to Citizens (G2C)** - It creates an interface between the government and citizens. Here the citizens enjoy a large range of public services. It increases the availability and accessibility of public services. It also improves the quality of services. Its primary purpose is to make the government citizen-friendly.

**Government to Business (G2B)** - Here, e-Governance tools are used to aid the business community to interact with the government. The objective is to cut red-tapism, save time, reduce operational costs and create a more transparent business environment while dealing with the government.

**Government to Employees (G2E)** - Government, being the biggest employer has to interact with its employees on a regular basis. This interaction is a two-way process between the government and the employees. The policies and guidelines for implementing
various government programmes are made available to the employees as government orders or circulars through e-Governance portals. The salary and personal details of government employees are also managed through e-Governance services. Use of ICT tools helps in making these interactions fast and efficient.

### 10.1.2 e-Governance infrastructure

In India, the e-Governance infrastructure mainly consists of State Data Centers (SDC) for providing core infrastructure and storage, State Wide Area Network (SWAN) for connectivity and Common Service Centers (CSC) as service delivery points. The integration of these three components of e-Governance is shown in Figure 10.1.

**Fig 10.1 : e-Governance infrastructure**

#### a. State Data Centre (SDC)

State Data Centre (SDC) is one of the important constituents of the core infrastructure for supporting e-Governance initiatives of National e-Governance Plan (NeGP). Under NeGP, it is proposed to create SDCs to combine services, applications and infrastructure and to provide efficient electronic delivery of G2G, G2C and G2B services. These services can be rendered by each state government through a common delivery platform. This platform is supported by a core connectivity infrastructure such as State Wide Area Network (SWAN) and Common Service Centre (CSC) connectivity that is extended up to the village level. State Data Centre provides several functionalities. These include keeping central data repository of the state, securing data storage, online delivery of services, citizen information/services portal, state intranet portal, disaster recovery, etc. SDCs also provide better operation and management control and minimize the overall cost of data management, resource management, deployment etc.

#### b. Kerala State Wide Area Network (KSWAN)

Kerala State Wide Area Network (KSWAN) has been set up as a backbone of the State Information Infrastructure (SII). It connects Thiruvananthapuram, Kochi and Kozhikode as its hubs and extends to all the 14 districts linking each of the 152 Block
Panchayats. The network also connects a large number of various offices of government departments. The infrastructure supports the integration of a large number of G2G, G2C services with the applications received from the State Data Centre.

c. Common Service Centre (CSC)

Common Service Centres (CSC) are the front-end delivery points of the government, private and social sector services for the rural citizens of India. A highlight of the CSCs is that it offers web-enabled e-Governance services in rural areas. It helps in utility payments such as electricity, telephone and water bills, submission of online applications and generating and distributing the certificates to the needy. Other services that could be offered through CSC are listed below:

- Agriculture services
- Education and training services
- Health services
- Rural banking and insurance services
- Entertainment services
- Commercial services

In Kerala Akshaya centres are working as Common Service Centres.

Akshaya centres

Akshaya centres were initially launched in the year 2002 in the Malappuram district in Kerala. Its intention was to impart e-Literacy to the citizens. Akshaya was conceived as a landmark ICT project by the Kerala State Information Technology Mission (KSITM) to bridge the digital divide and to bring the benefits of ICT to the entire population of the State. The services include e-grantz, e-filing, e-district, e-ticketing, submitting online application for ration card and electoral ID, Aadhaar enrolment, Aadhaar based services, insurance and banking services.

Akshaya was launched on 18th November 2002 by the former President of India, Dr. A. P. J. Abdul Kalam.

Akshaya works in the Private Public Partnership (PPP) Model. An Akshaya centre is owned by a private entrepreneur preferrably from the same panchayath where the Akshaya centre is located and its selection is done by local self governments. The income for the Akshaya Entrepreneurs is the nominal service charge collected either from the citizen or paid by the government for each transaction.

www.akshaya.kerala.gov.in
10.1.3 Benefits of e-Governance

Implementing e-Governance has many advantages. It informs the public about the functioning of the government and the policies they are trying to implement. Major benefits of e-Governance are listed below:

- **e-Governance** leads to automation of government services, ensuring the information regarding the activities of public welfare is easily available to all citizens.
- e-Governance strengthens the democracy by ensuring greater participation of citizens at all levels of governance.
- It ensures more transparency in the functioning and thus helps eliminate corruption.
- It makes every government department responsible as they know that they are closely observed.
- Proper implementation of e-Governance saves unnecessary visits of the public to offices. It saves time and money.

10.1.4 Challenges to e-Governance

Though e-Governance has many benefits, it faces some challenges too. Let us have a look at a few challenges in the implementation of e-Governance.

- The existing digital divide is an obstacle in utilising the services of e-Governance. Those who live in remote areas with lower e-Literacy will face difficulty to access the services of e-Governance.
- e-Governance applications being computer/web based, security measures are highly required since there is possibility of cyber-attack.
- Usually a huge initial investment and planning are required for the proper implementation and maintenance of e-Governance services.
- Many people are anxious about the sharing of their personal information, biometry, etc. to the agencies designated for data collection.
- Integrity of various departments is very much essential for the efficiency and effectiveness of e-Governance.
10.1.5 Useful e-Governance websites

Table 10.1 shows the addresses of some websites that provide various services of the Government of Kerala. Figure 10.2 shows the home page of the Department of Higher Secondary Education, Kerala State and Figure 10.3 shows the home page of e-District portal.

<table>
<thead>
<tr>
<th>Address of website</th>
<th>Purpose/Service</th>
</tr>
</thead>
<tbody>
<tr>
<td><a href="http://www.dhsekerala.gov.in">www.dhsekerala.gov.in</a></td>
<td>An official site of the Department of Higher Secondary Education, Government of Kerala that provides various facilities and services to students, teachers and school administrators.</td>
</tr>
<tr>
<td><a href="http://www.edistrict.kerala.gov.in">www.edistrict.kerala.gov.in</a></td>
<td>It provides government services to the public.</td>
</tr>
<tr>
<td><a href="http://www.incometaxindia.gov.in">www.incometaxindia.gov.in</a></td>
<td>It provides the services of Income Tax department.</td>
</tr>
<tr>
<td><a href="http://www.keralamvd.gov.in">www.keralamvd.gov.in</a></td>
<td>It is the official website of the Motor Vehicles Department of Kerala.</td>
</tr>
<tr>
<td><a href="http://www.rti.gov.in">www.rti.gov.in</a></td>
<td>Right to Information Act 2005 mandates timely response to a citizen who requests for information from the Government or authorities under it.</td>
</tr>
<tr>
<td><a href="http://www.itmission.kerala.gov.in">www.itmission.kerala.gov.in</a></td>
<td>It is a Government of Kerala site which provides managerial support to various IT initiatives.</td>
</tr>
<tr>
<td><a href="http://www.spark.gov.in">www.spark.gov.in</a></td>
<td>It is a web based G2E integrated solution for Service and Payroll Management.</td>
</tr>
</tbody>
</table>

Table 10.1 : Some e-Governance websites

Fig. 10.2 : The home page of DHSE website
As an official site of the Department of Higher Secondary Education, Government of Kerala, www.dhsekerala.gov.in provides various facilities and services to students, teachers and school administrators. The services include registration for the examinations, issue of hall tickets, publication of exam results, distribution of various circulars and notifications, etc. This site also provides facilities for downloading various forms and study materials including model question papers.

**Fig. 10.3 : The home page of e-District portal.**

e-District is a State Mission Mode Project under the National e-Governance plan. The project aims at supporting computerisation for services to the public.

In Kerala, issue of different certificates of the Department of Revenue is integrated with the e-District portal. It has simplified all complex procedures in government offices and made the citizens’ life easy. It has been a difficult task for the citizen to obtain copies of public records, submit applications, meet officials, or to seek information regarding their day-to-day needs. This has caused the loss of his/her day’s income, time as well as the cost of transportation. At government offices, sometimes, the relevant record, information, or official may not be available, resulting in repeated visits and additional expenses.

To avail a service in e-District, one has to apply online through the web portal or approach a nearby Akshaya centre with essential documents. Akshaya centre submits an online application on behalf of the citizen. This application through a work-flow reaches the village officer. After processing the application, the village officer forwards it to the next higher authority or approves it and issues the certificate using the digital signature. The availability of the certificate in the portal is informed with an SMS alert.
10.2 e-Business

We often visit shopping places and it takes a considerable amount of time and effort for shopping. What about the idea of shopping without leaving your home? It is one of the realities of the times. Almost all services and business are available online now. They are only a few clicks away.

**e-Business** is the sharing of business information, maintaining business relationships and conducting business transactions by means of the ICT application. Companies (business), public institutions (administration), as well as individuals (consumer) engage in e-Business. e-Business helps in effective e-marketing and increasing sales through effective use of e-Commerce services. It also reduces communication and travel cost through online meeting and shared workspace, etc.

10.2.1 e-Commerce and e-Business

Although the terms e-Commerce and e-Business are often used interchangeably there are differences. e-Commerce covers business transaction that involve exchange of money, whereas e-Business includes all aspects of running a business such as marketing, obtaining raw materials or goods, customer education, looking for suppliers etc. Thus e-Business is an extension of e-Commerce.

10.2.2 Electronic Payment System (EPS)

Can you think of living without money in your pocket? If somebody tells that he/she lived a week without touching currency notes, will you believe? Today we live in a world where almost every commodity has a price tag attached to it. Then how is it possible to buy something without giving money, the paper currency?

Electronic Payment System (EPS) is the solution. When we move on to electronic business, exchange of money also needs to be electronic. It is both convenient and secure if properly implemented. EPS plays an important role in e-Business.
A system of financial exchange between buyers and sellers in an online environment is called an **Electronic Payment System** (EPS). The financial exchange is facilitated by a digital financial instrument (such as credit/debit card, electronic cheque or digital cash) backed by a bank and/or an intermediary.

### 10.2.3 e-Banking

Banking has also undergone drastic changes with the advancements in Information Technology. Our traditional concept of banking has changed a lot. For example, now there is no need to visit bank for making financial transactions. We can do the transaction using online banking facilities even while travelling. Facilities such as ATM, debit cards, credit cards, Internet banking and core banking help in transforming traditional banking into e-Banking. **e-Banking** or electronic banking is defined as the automated delivery of banking services directly to customers through electronic channel. It can access data without geographical limitations.

### 10.2.4 Advantages of e-Business

e-Business provides many advantages to customers and firms. Let us discuss some of the major advantages of using e-Business applications.

- **It overcomes geographical limitations.** If you have a physical store, you are limited by the geographical area where you can provide service. But with e-Commerce, this limitation can be overcome.

- **e-Business reduces the operational cost.** An e-Commerce merchant does not need a prominent physical location; it reduces the operational cost. A portion of money thus saved can be passed on to the customers in the form of discounts.

- **It minimises travel time and cost.** Sometimes customers have to travel long distances to reach their preferred store. e-Business allows them to visit the same store virtually.

- **It remains open all the time.** e-Business application services are always open (24×7). From the merchant's point of view, it increases the number of service requests they receive. From the customer's point of view an 'always open' store is more convenient.

- **We can locate the product quicker from a wider range of choices.** On an e-Business website the consumers can have a wider range of choices of a product from various sellers. Customers can quickly locate their preferences from the given product lists. Some websites remember customer preferences and shopping lists to facilitate repeat purchase. The features like product characteristics and price comparisons are the other attractions of e-Business applications.
### 10.2.5 Challenges to e-Business

Though e-Business has enormous potential in the business world, it faces many challenges, particularly in developing countries like India. Major challenges are discussed below:

- A good percentage of the population is unaware of IT applications and its uses. Surprisingly, most of the regular Internet users also lack knowledge about online business and its possibilities.
- Most of the customers, especially to rural population, do not possess plastic money - credit card, debit card and net banking system, which is necessary for e-Business.
- If not used with caution, customers may lose valuable information like their credit card number, passwords, etc.
- Products like apparel, handicrafts, jewellery, etc are often purchased after examining physically. But in online shopping, customers don’t have this ‘touch and feel’ advantage.
- For the success of e-Business of any organisation or company, perfect and efficient shipment service is a necessity.

### 10.2.6 Useful e-Business websites

Some popular e-Business websites are given in Table 10.2. Figure 10.4 and 10.5 are the home pages of some e-Business websites.

<table>
<thead>
<tr>
<th>Address of website</th>
<th>Purpose/Service</th>
</tr>
</thead>
<tbody>
<tr>
<td><a href="http://www.irctc.co.in">www.irctc.co.in</a></td>
<td>Indian Railway Catering and Tourism Corporation Limited web site for reservation and cancellation of railway tickets and hotels for accommodation.</td>
</tr>
<tr>
<td><a href="http://www.ebay.in">www.ebay.in</a></td>
<td>It is one of the largest online shopping sites in India.</td>
</tr>
<tr>
<td><a href="http://www.licindia.com">www.licindia.com</a></td>
<td>Insurance company website.</td>
</tr>
<tr>
<td><a href="http://www.airindia.com">www.airindia.com</a></td>
<td>Online site for booking Air India flight tickets.</td>
</tr>
<tr>
<td><a href="http://www.keralartc.com">www.keralartc.com</a></td>
<td>Online website for KSRTC bus ticket booking.</td>
</tr>
<tr>
<td><a href="http://www.bookmyshow.com">www.bookmyshow.com</a></td>
<td>Movies and theatre ticket booking website.</td>
</tr>
</tbody>
</table>

*Table 10.2: Some e-Business websites*
Indian Railway Catering and Tourism Corporation Limited (IRCTC) is a government of India enterprise. It handles the catering, tourism, and online ticketing operations of the railways. IRCTC provides online booking facilities of railway tickets and offers other services like checking reservation status, train timing, reservation of hotels for the tourists across the country.

Amazon.com, Inc. is a US based company with headquarters in Washington. It is the world’s largest retailer. Initially started as an online bookstore it soon diversified itself into selling software, video games, electronics, furniture, food, toys, jewellery, etc. The company also produces consumer electronics. Amazon has separate retail websites for different countries. In 2013, Amazon launched its site for India, www.amazon.in.
10.3 e-Learning

We are familiar with the traditional classroom consisting of a teacher, students, teaching aids, etc. Think of a virtual class where you are attending classes as a student and a teacher is engaging class from a distant location, may be from a different country. Is this possible? Yes it is! Through e-Learning you can overcome many limitations of conventional teaching-learning process. The use of electronic media and ICT (Information and Communication Technologies) in education is termed e-Learning.

10.3.1 e-Learning tools

There are many tools for enhancing e-learning process. Some of the e-Learning tools are discussed below:

a. **Electronic books reader (e-Books)**

Think of going to school without bags packed with text books, but all necessary books are still with you in a small hand-held storage device! It is interesting, isn't it? e-Book reader is a device that can store lot of books in digital form. Portable computer devices that are loaded with digital book content via communication interfaces is called electronic books reader. It can open any book, any page quickly, without much effort. In principle, any web document can be downloaded from the Internet, sometimes by making online payment, and read whenever required. In some e-Book readers voice output is also available and the reader needs to just listen the audio of the text.

b. **e-Text**

Textual information available in electronic format is called e-Text. This text can be read and interacted with an electronic device like computer, e-Book reader, etc. e-Text can be converted to various formats to our liking using softwares. e-Text can be automatically read aloud with the help of a computer or an e-Text reader device. This is quite helpful for visually challenged people.

c. **Online chat**

It is a real-time exchange of text messages between two or more persons over the Internet. In the virtual class environment, online chatting is used to discuss the topics with teachers and other students. Chatting can be performed even with a low speed
Internet connection. Video chatting facility is also available. It however requires fairly high speed Internet connection and supporting devices such as web camera and speakers. On line chat is a framework that provides interaction in a social environment. It helps communicating with people at different places. This facility can also be used to deliver and transfer live lectures given by the faculty. Students can login from the remote locations and attend the lecture.

d. e-Content

Nowadays lot of e-Learning materials are delivered in different multimedia formats like videos, presentations, graphics, animations, etc. The e-Contents once prepared can be broadcasted through television channels, webcasted or uploaded in websites. Uploaded content can be downloaded, viewed and saved for future reference. The multimedia contents have more scope to convey the subject matter effectively. It can show actual or simulated activities which are not possible in the traditional classroom based teaching.

e. Educational TV channels

There are many telecasting/webcasting channels which are dedicated for the e-Learning purpose. These channels broadcast recorded classes on various subjects, interviews with experts, lab experiments, etc. Some of these channels can be watched in the Internet also. Dooradarshan’s ‘VYAS’ and Kerala Government’s ‘VICTERS’ channel are examples of educational television channels.

10.3.2 Advantages of e-Learning

e-Learning has lot of advantages. They are listed below:

• e-Learning has the ability to offer courses on variety of subjects to large number of students from distant location.

• In e-Learning cost for learning is much less. It saves journey time and money, instructor fees, etc.

• People with limited financial resources are very much supported by the lower cost of e-Learning.

• It provides facility to do online courses from various nationally or internationally reputed institutions.

• Time and place is not a constraint for e-Learning.

10.3.3 Challenges to e-Learning

Listed below are some of the challenges faced by e-Learning:

• Face to face contact between students and teachers is not possible.

• Proper interaction among teachers and students are often limited due to the lack of infrastructural facilities.

• Equipment and technology (computer and high speed Internet) requirement restrict adoption of e-Learning.

• Learners who require constant motivation may not be serviced adequately.

• Hands-on practicals in real laboratory scenario is also a constraint in e-Learning.
10.3.4 Useful e-Learning websites

The summary of useful e-Learning websites are shown in Table 10.3. Figure 10.6 shows the home page of IGNOU (Indira Gandhi National Open University).

<table>
<thead>
<tr>
<th>Address of website</th>
<th>Purpose/Service</th>
</tr>
</thead>
<tbody>
<tr>
<td><a href="http://www.ignouonline.ac.in">www.ignouonline.ac.in</a></td>
<td>Website of Indira Gandhi National Open University, one of the leading open universities offering various courses in the distance education mode.</td>
</tr>
<tr>
<td><a href="http://www.nptel.iitm.ac.in">www.nptel.iitm.ac.in</a></td>
<td>National Programme on Technology Enhanced Learning (NPTEL) provides e-Content through online Web and Video for courses in Engineering, Science and humanities streams.</td>
</tr>
<tr>
<td><a href="http://www.ncert.nic.in">www.ncert.nic.in</a></td>
<td>Website of National Council of Educational Research and Training. Includes many features such as providing study materials and reference materials in Hindi and English.</td>
</tr>
<tr>
<td>www.spoken_tutorial.org</td>
<td>It is an IIT Mumbai initiative. It provides software training through the spoken tutorials. All the courses are offered totally free of cost as it is funded by the Government of India.</td>
</tr>
<tr>
<td><a href="http://www.w3schools.com">www.w3schools.com</a></td>
<td>W3Schools is a web developer information website, with tutorials and references relating to web development topics such as HTML, CSS, JavaScript, PHP, SQL, and JQuery.</td>
</tr>
<tr>
<td><a href="http://www.gcflearnfree.org">www.gcflearnfree.org</a></td>
<td>GCFLearnFree.org is supported by the Goodwill Community Foundation. It provides easy-to-follow lessons in mathematics, science and technology and English to help anyone anywhere learn skills and gain knowledge.</td>
</tr>
</tbody>
</table>

Table 10.3: Some e-Learning websites

![Fig. 10.6: The home page of IGNOU site](image-url)
IGNOU (Indira Gandhi National Open University) is an open university under Government of India. The website provides several features including eGyankosh, which is a digital repository available in text and video format. The site also provides webcasting facility linking to education channels - Gyandarshan, Gyanvani and EDUSAT. Virtual class provides links to all the online programmes conducted by the University.

NPTEL is an abbreviation for National Programme on Technology Enhanced Learning which is an initiative by seven Indian Institutes of Technology (IIT) and Indian Institute of Science (IISc) for creating course content in engineering and science. Web based Course materials have been developed for different courses and are accessible freely through the website. Lecture contents are also made available in web site through video.

Check yourself

1. Real-time exchange of text messages between two or more persons over Internet is termed ________.
2. Pick the odd one out:
   (a) e-Book reader  (b) e-Text  (c) television channels  (d) e-business
3. Define e-Text.
4. Give an example for an e-Learning tool.
10.4 ICT applications in health care

Developments in ICT have contributed much in the field of medical practice and medical care. There is an enormous range of opportunities for significant cost reduction and service enhancement through IT applications in health care. Let us discuss some of the changes that ICT has brought about in the field of medicine and healthcare.

10.4.1 Medical equipments

Most of the modern medical equipment work with the support of computers. Scanners like CT and MRI depend on computers to process their data into a readable format. Micro-processors are used to control a variety of support devices. Computer guided lasers are used in surgery, even in the removal of brain tumours. Some hand-held devices are also available that help patients to lead normal life. A device for self-monitoring of sugar levels for people with diabetes is an example.

10.4.2 Electronic Medical Record (EMR)

There has been a move to store all patients' records in digital format. This is known as Electronic Medical Record (EMR). An EMR is mostly used by doctors for diagnosis and treatment. There are many advantages in keeping patients record in electronic format.

Some of them are listed below:

- It is a more economical way of storing data.
- Access to medical history of patients will be easier and quicker.
- Transfer of records will be quicker between doctors and hospitals.
- Data can be examined to analyse the medical conditions of the patients.
- Prescription will be legible and are stored for later reference.

10.4.3 Web-based support/diagnosis

On the Internet you can find a wide variety of medical information, including information about available treatments/alternative therapies, access to medical research/journals, support groups for people suffering from particular conditions, etc.

Some websites also provide facility for symptom diagnosis - for people who wish to get primary awareness about their health problem without the help of a doctor. However there are some risks involved here. This can lead to incorrect diagnosis and cause false complacency or anxiety.
10.4.4 Telemedicine
Telemedicine has been used to share observations and prescriptions with the experts in the medical field. A surgeon in one part of the world can procure medical expertise from another who is far away, while performing surgery. It reduces cost and time. A patient in a critical condition can get attention from a surgeon who may not be physically available at the operation theatre. Wireless transmission helps medical personnel, transport workers and hospitals to keep in touch in emergency.

10.4.5 Research and development
Over recent years drug discovery has been a concern for many in the pharmaceutical industry. Escalating costs and increasing complexity suggest that traditional research and development methods are to be changed. Now the convergence of information and bio-technology is revolutionising drug discovery and design. Today, drugs meant for specific purposes can be developed with the use of advanced computers. Use of IT may radically alter the cost associated with the discovery of drug over the coming years. Thus IT helps in diagnosis, treatment of patients and better running of hospitals.

10.5 ICT enabled services
ICT enabled services, also called web enabled services cover the entire range of operations which make use of ICT for improving services provided by an organisation. These services provide a wide range of career options that include opportunities in call centres, BPOs, medical transcription, etc. Some of the common ICT enabled services are discussed in the following sections.

10.5.1 Business Process Outsourcing (BPO)
Outsourcing is a term used in the business field. It is a practice used by different companies to reduce costs by transferring portions of work to outside suppliers. It is the process of hiring another company to handle business activities for you. Business process outsourcing (BPO) is a subset of outsourcing. It involves contracting of the operations and responsibilities of specific business functions to a third-party service provider. Outsourcing sometimes involves transferring employees and asset from one firm to another.

Companies implement Business Process Outsourcing (BPO) because it increases their efficiency and saves cost. Processes such as human resource management, customer care services, payroll, etc. are some of the processes that are usually given to BPO.

10.5.2 Knowledge Process Outsourcing (KPO)
Knowledge Process Outsourcing (KPO) is a form of outsourcing. Here knowledge and information related work is carried out by a different company or subsidiary within the same organisation. It helps in saving costs and resources. Some of the core processes outsourced in KPO include: data search, data integration, market research, fraud analytics, etc. The KPO sector has experienced explosive growth in recent years. Industries that are increasingly using KPO include legal, financial services, management and consulting.
10.5.3 Call centre

Call centres are becoming a very important part of any business/service organisation. Call centres facilitate the public for the payment of bills, purchase of goods, etc. A call centre is a telephone service facility set up to handle a large number of both incoming and outgoing calls for an organisation.

Call centres are also called service centres, sales centres, contact centres, etc. Basic responsibility of a call centre is to handle the telephone calls for supporting various services provided by an organisation. Call centres are used by telemarketing companies, computer product help desks and any large organisation that uses the telephone to sell products and carryout services. Generally the calls can be classified as in-bound calls and out-bound calls. In-bound calls are usually meant to seek assistance, help, or to order, while out-bound calls are meant for sales promotion or other messages.

Some firms, however, specialise only in calls that are in-bound or out-bound. Most telephonic orders are handled by call centres and not by the manufacturers or suppliers of goods or services.

10.5.4 Teleconferencing

Teleconferencing is a meeting or conference held between two or more parties in remote locations, made possible by the use of IT infrastructure and services.

Teleconferencing is used to connect several different people from several different locations. It is used in educational, business and administrative fields. Saving time, reducing travel expense and including several people in a decision-making process are some of the advantages.

10.5.5 Video conferencing

Video conferencing is a type of teleconferencing wherein we can include the video of the parties involved in the conference. Videoconference allows people at remote locations join in a conference and share information. A video camera and a speakerphone are connected to a computer and the computers are connected to the network or Internet.

Video conferencing is a facility which enables participants in distant locations to take part in a conference by means of audio and video communication.

Let us sum up

Information Technology (IT) is a fast growing field. It is widely used in our day today activities. Business transactions, government activities, learning processes, research and medical field, etc. are some of the major areas where IT is substantially utilised. The explosion in the development of communication owes much to information technology. The use of IT helps people communicate with less effort and minimum cost. ICT is another term often used as an extended synonym for IT. Some of the ICT enabled services include BPO, KPO, Call centre, Teleconferencing and Video conferencing. Hence IT and ICT enabled services have become inseparable part of modern society.
Learning outcomes

After the completion of this chapter the learner will be able to

• list the facilities of e-Governance, e-Business, e-Learning.
• explain the tools used in e-Learning.
• list the ICT applications in health care.
• list various advantages and challenges faced in implementing e-Governance, e-Business, e-Learning applications.
• use some of the useful websites in each area.
• utilise various ICT enabled services.

Sample questions

Very short answer types

1. Name an electronic device using which we can easily read e-Text.
2. Write the full forms of BPO and KPO.
3. Name any two e-Learning tools.

Short answer types

1. List out different types of interactions in e-Governance.
2. Differentiate between BPO and KPO.
3. What are the advantages of e-Governance?
4. What are the duties of Akshaya?
5. Write down the function of Call centres.

Long answer types

1. What are the major challenges faced in the implementation of e-Learning?
2. Compare the advantages and disadvantages of implementing e-Business?
3. Explain any three IT enabled services in detail.
4. Discuss in detail various uses of IT in health care field.
5. What is Common Service Centre (CSC)? List some of the services offered through CSC.
References